We have moved at community.getvera.com

Author Topic: Secondary User  (Read 730 times)

Offline Z-Waver

  • Master Member
  • *******
  • Posts: 4437
  • Karma: +249/-120
Secondary User
« on: December 26, 2015, 05:32:31 pm »
On a door/window sensor I have a notification for User1, that successfully sends a Vera Alerts. I have a very similar notification just different wording for User2/Profile2 that does not work.

When I run the Vera Alerts report, the notification is present, but the user field is blank. It doesn't matter which user I choose for this notification, the user field is always blank in Vera Alerts. If I select User1 and User2, User1 does show up in the user field on the report, but not User2.

Perhaps unsurprisingly, when the user field is blank and the notification is sent and it matches Vera Alerts, I get this in the log
Code: [Select]
LuaInterface::CallFunction_Job device 62 function SVeraAlert_VeraAlert1_DeviceNotification_jo
b failed [string "module("L_VeraAlert", package.seeall)..."]:1245: bad argument #1 to 'gmatch' (string expected, got nil)

The notification does appear under Account -> My Alerts, when the sensor is tripped. Yes, I opened the Notification Configuration panel in Vera Alerts.

« Last Edit: December 26, 2015, 05:36:16 pm by Z-Waver »

Offline Z-Waver

  • Master Member
  • *******
  • Posts: 4437
  • Karma: +249/-120
Re: Secondary User
« Reply #1 on: December 26, 2015, 05:51:55 pm »
I seem to have found a solution.

User2 had been setup as a Notification Only user and that didn't work. Removing User2 and re-adding User2 as a Guest, rather than Notification only and then rebooting Vera caused everything to start working as expected.

I suppose that it is a permissions issue. It's an annoying quirk, that's for sure.