Author Topic: dataMine 2 documentation  (Read 19034 times)

Offline doinitsideways

  • Jr. Member
  • **
  • Posts: 94
  • Karma: +2/-0
Re: dataMine 2 documentation
« Reply #30 on: July 13, 2017, 05:32:49 pm »
Hi,

Just my 2c

I found i had to select the tick box under the 3 variables that we put the UUID data into to get it to work... But beside that, thanks heaps @RWoerz

Cheers,
Josh

Offline tbully

  • Sr. Member
  • ****
  • Posts: 279
  • Karma: +1/-1
Re: dataMine 2 documentation
« Reply #31 on: July 14, 2017, 06:41:51 pm »
Hello -

Hoping someone can give me a help on a new DM install on a VeraSecure.

I keep getting the "select USB" window during initialization.


lsusb Output
Code: [Select]
root@MiOS_55001685:/# lsusb
Bus 001 Device 011: ID 05dc:a817 Lexar Media, Inc.
Bus 001 Device 003: ID 05e3:0608 Genesys Logic, Inc. USB-2.0 4-Port HUB
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 004: ID 0e8d:7662 MediaTek Inc.
Bus 001 Device 005: ID 04e2:1420 Exar Corp.
Bus 001 Device 006: ID 04e2:1420 Exar Corp.
Bus 001 Device 010: ID 1bc7:0026 Telit


FDISK Output
Code: [Select]
Disk /dev/sda: 15 GiB, 16039018496 bytes, 31326208 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0xba0d28b4

Device    Boot Start       End   Blocks  Id System
/dev/sda1       2048  31324159 15661056   c W95 FAT32 (LBA)

I don't see anything mounted:
Code: [Select]
root@MiOS_55001685:/# mount
rootfs on / type rootfs (rw)
/dev/root on /rom type squashfs (ro,relatime)
proc on /proc type proc (rw,noatime)
sysfs on /sys type sysfs (rw,noatime)
tmpfs on /tmp type tmpfs (rw,nosuid,nodev,noatime)
/dev/mtdblock6 on /overlay type jffs2 (rw,noatime)
overlayfs:/overlay on / type overlayfs (rw,noatime,lowerdir=/,upperdir=/overlay)
tmpfs on /dev type tmpfs (rw,relatime,size=512k,mode=755)
devpts on /dev/pts type devpts (rw,relatime,mode=600)
debugfs on /sys/kernel/debug type debugfs (rw,noatime)
/dev/mtdblock10 on /storage type jffs2 (rw,relatime)
/dev/mtdblock10 on /etc/cmh-firmware type jffs2 (rw,relatime)
/dev/mtdblock10 on /etc/cmh-backup type jffs2 (rw,relatime)
/dev/mtdblock9 on /mios type squashfs (ro,relatime)
root@MiOS_55001685:/#

But even if I mount manually to /datamine/ (directory manually created by me/root), it still doesn't seem to help.

Pointers?


-------

EDIT:
I saw I had a capital M in /datamine/.   I made that fix but still not mounting:

Code: [Select]
50 07/14/17 18:47:09.735 luup_log:337: dataMine: Initialising dataMine System (2.000) <0x76a31520>
06 07/14/17 18:47:09.736 Device_Variable::m_szValue_set device: 337 service: urn:cd-jackson-com:serviceId:DataMine1 variable: errorStatus was: true now: false #hooks: 0 upnp: 0 skip: 0 v:(nil)/NONE duplicate:0 <0x76a31520>
06 07/14/17 18:47:09.736 Device_Variable::m_szValue_set device: 337 service: urn:cd-jackson-com:serviceId:DataMine1 variable: ChannelCnt was: 0 now: 0 #hooks: 0 upnp: 0 skip: 0 v:0x1504b40/NONE duplicate:1 <0x76a31520>
06 07/14/17 18:47:09.737 Device_Variable::m_szValue_set device: 337 service: urn:cd-jackson-com:serviceId:DataMine1 variable: ChannelRec was: 0 now: 0 #hooks: 0 upnp: 0 skip: 0 v:(nil)/NONE duplicate:1 <0x76a31520>
50 07/14/17 18:47:09.766 luup_log:337: dataMine: Error reading tmpfile during mountcheck <0x76a31520>
06 07/14/17 18:47:09.767 Device_Variable::m_szValue_set device: 337 service: urn:cd-jackson-com:serviceId:DataMine1 variable: mountLocation was:  now:  #hooks: 0 upnp: 0 skip: 0 v:(nil)/NONE duplicate:1 <0x76a31520>
06 07/14/17 18:47:09.767 Device_Variable::m_szValue_set device: 337 service: urn:cd-jackson-com:serviceId:DataMine1 variable: mountType was:  now:  #hooks: 0 upnp: 0 skip: 0 v:(nil)/NONE duplicate:1 <0x76a31520>
50 07/14/17 18:47:09.794 luup_log:337: dataMine: Mounting dataMine storage (<span style="font-family: Verdana, Arial, Helvetica, sans-serif; font-size: 12.48px; background-color: rgb(240, 244, 247);">/dev/sda1</span>) to (/datamine/) <0x76a31520>
50 07/14/17 18:47:09.841 luup_log:337: dataMine: mount command output:'' <0x76a31520>
50 07/14/17 18:47:09.869 luup_log:337: dataMine: Error reading tmpfile during mountcheck <0x76a31520>
06 07/14/17 18:47:09.870 Device_Variable::m_szValue_set device: 337 service: urn:cd-jackson-com:serviceId:DataMine1 variable: mountLocation was:  now:  #hooks: 0 upnp: 0 skip: 0 v:(nil)/NONE duplicate:1 <0x76a31520>
06 07/14/17 18:47:09.870 Device_Variable::m_szValue_set device: 337 service: urn:cd-jackson-com:serviceId:DataMine1 variable: mountType was:  now:  #hooks: 0 upnp: 0 skip: 0 v:(nil)/NONE duplicate:1 <0x76a31520>
50 07/14/17 18:47:09.897 luup_log:337: dataMine: Mount point error: ::<span style="font-family: Verdana, Arial, Helvetica, sans-serif; font-size: 12.48px; background-color: rgb(240, 244, 247);">/dev/sda1</span> <0x76a31520>
06 07/14/17 18:47:09.898 Device_Variable::m_szValue_set device: 337 service: urn:cd-jackson-com:serviceId:DataMine1 variable: errorStatus was: false now: true #hooks: 0 upnp: 0 skip: 0 v:(nil)/NONE duplicate:0 <0x76a31520>
50 07/14/17 18:47:09.904 luup_log:337: dataMine: ERROR: Startup state is 'uninitialised'! <0x76a31520>
06 07/14/17 18:47:09.905 Device_Variable::m_szValue_set device: 337 service: urn:cd-jackson-com:serviceId:DataMine1 variable: ChannelCnt was: 0 now: 0 #hooks: 0 upnp: 0 skip: 0 v:0x1504b40/NONE duplicate:1 <0x76a31520>
06 07/14/17 18:47:09.905 Device_Variable::m_szValue_set device: 337 service: urn:cd-jackson-com:serviceId:DataMine1 variable: ChannelRec was: 0 now: 0 #hooks: 0 upnp: 0 skip: 0 v:(nil)/NONE duplicate:1 <0x76a31520>
50 07/14/17 18:47:09.905 luup_log:337: dataMine: Reinitialising configuration structure <0x76a31520>
50 07/14/17 18:47:09.906 luup_log:337: dataMine: Startup complete <0x76a31520>
50 07/14/17 18:47:24.213 luup_log:337: dataMine: Delete backups complete - No files found <0x6f631520>
06 07/14/17 18:47:24.242 Device_Variable::m_szValue_set device: 337 service: urn:cd-jackson-com:serviceId:DataMine1 variable: diskTotal was: 8192 now: 8192 #hooks: 0 upnp: 0 skip: 0 v:(nil)/NONE duplicate:1 <0x6f631520>
06 07/14/17 18:47:24.243 Device_Variable::m_szValue_set device: 337 service: urn:cd-jackson-com:serviceId:DataMine1 variable: diskUsed was: 7284 now: 7288 #hooks: 0 upnp: 0 skip: 0 v:(nil)/NONE duplicate:0 <0x6f631520>
06 07/14/17 18:47:24.243 Device_Variable::m_szValue_set device: 337 service: urn:cd-jackson-com:serviceId:DataMine1 variable: diskFree was: 908 now: 904 #hooks: 0 upnp: 0 skip: 0 v:(nil)/NONE duplicate:0 <0x6f631520>
06 07/14/17 18:47:24.244 Device_Variable::m_szValue_set device: 337 service: urn:cd-jackson-com:serviceId:DataMine1 variable: diskUsedPcnt was: 89 now: 89 #hooks: 0 upnp: 0 skip: 0 v:(nil)/NONE duplicate:1 <0x6f631520>
-2-===========================================================================
-3-===========================================================================
rootfs on / type rootfs (rw)
/dev/root on /rom type squashfs (ro,relatime)
proc on /proc type proc (rw,noatime)
sysfs on /sys type sysfs (rw,noatime)
tmpfs on /tmp type tmpfs (rw,nosuid,nodev,noatime)
/dev/mtdblock6 on /overlay type jffs2 (rw,noatime)
overlayfs:/overlay on / type overlayfs (rw,noatime,lowerdir=/,upperdir=/overlay)
tmpfs on /dev type tmpfs (rw,relatime,size=512k,mode=755)
devpts on /dev/pts type devpts (rw,relatime,mode=600)
debugfs on /sys/kernel/debug type debugfs (rw,noatime)
/dev/mtdblock10 on /storage type jffs2 (rw,relatime)
/dev/mtdblock10 on /etc/cmh-firmware type jffs2 (rw,relatime)
/dev/mtdblock10 on /etc/cmh-backup type jffs2 (rw,relatime)
/dev/mtdblock9 on /mios type squashfs (ro,relatime)
-4-===========================================================================
-5-===========================================================================
SetDataDirectory-/datamine/
SetMountUUID    -05dc-a817
SetMountPoint   -<span style="font-family: Verdana, Arial, Helvetica, sans-serif; font-size: 12.48px; background-color: rgb(240, 244, 247);">/dev/sda1</span>
SetManualMount  -0
-6-===========================================================================
{"dbVersion":2,"Events":{"count":0,"last":0},"Version":"2.000","Variables":[],"Graphs":[],"guiConfig":[],"nextId":1}
-7-===========================================================================

-------
FINAL EDIT.  Delete this noise if you want!  (sorry)
I reread the message above my post and also checked the three check boxes.  All is well now.

Thanks! 
« Last Edit: July 14, 2017, 07:05:17 pm by tbully »

Offline thomasx

  • Newbie
  • *
  • Posts: 14
  • Karma: +0/-1
Re: dataMine 2 documentation
« Reply #32 on: January 01, 2018, 08:24:14 pm »
Hi

How can the scale range on the Dashboard dial be changed. I need to increase it quite a bit for my application?

Thanks, Thomasx

Offline tomtcom

  • Hero Member
  • *****
  • Posts: 987
  • Karma: +23/-31
Re: dataMine 2 documentation
« Reply #33 on: March 24, 2018, 12:25:06 pm »
Can anyone expand on the details around Online Status on page 5 of the documentation? I have the grey radio button.

?Online Status? indicator ? this is green if the web interface is communicating with Vera, and grey if
Vera is not communicating with the browser. It displays red if communication is OK, however there
are errors within dataMine (eg. Initialisation error, or error writing data to the USB).

Does it mean there is a problem or values might not be updating when grey? I can sit here and watch it but like most people we probably always want to see green. :)

Offline tomtcom

  • Hero Member
  • *****
  • Posts: 987
  • Karma: +23/-31
Re: dataMine 2 documentation
« Reply #34 on: March 24, 2018, 12:26:48 pm »
Hi

How can the scale range on the Dashboard dial be changed. I need to increase it quite a bit for my application?

Thanks, Thomasx

Check page 8 of the documentation, that might help you out.

Offline subrat35

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
Re: dataMine 2 documentation
« Reply #35 on: July 10, 2018, 05:37:14 am »
Hello,
I am rather a new user of Vera.
I would like to log the data coming from Fibaro wall plugs (that work through Z-wave) connected to my Vera plus controller.
I got a USB successfully mounted on the USB drive and made it to log the data. Attached is a screenshot:

Now, while trying to install the DataMine plugin for Vera, the MiOS Marketplace "doesn't find any unit to connect with." Am I missing any steps?
My computer and the controller are on the same network and I can access the controller via putty and can also see the web interface of the controller.
Please suggest how to install the plugin and proceed with the data handling?