We have moved at community.getvera.com

Author Topic: Novice manual to rpi2?  (Read 6526 times)

Offline rabeliyo

  • Sr. Newbie
  • *
  • Posts: 25
  • Karma: +0/-0
Re: Novice manual to rpi2?
« Reply #15 on: February 16, 2016, 04:47:16 am »
Send me a PM with the startup.lua, paste it between code tags (# sign above)...  I'll see if I can spot any issues with it.

Ok, i have the ALTUI files, i make the step 20 and do

./openLuup_reload startup.lua

But when i open the web browser and paste the direction i only see No handler



Enviado desde mi SM-G925F
I send you a PM with the startup.lua

Thanks!! :D

Enviado desde mi SM-G925F mediante Tapatalk


Offline rabeliyo

  • Sr. Newbie
  • *
  • Posts: 25
  • Karma: +0/-0
Re: Novice manual to rpi2?
« Reply #16 on: February 16, 2016, 04:57:58 am »
It in /etc/cmh-ludl/LuaUPnP.log.  Just a plain text file.
2016-02-16 10:32:31.620   :: openLuup STARTUP ::
2016-02-16 10:32:31.621   openLuup.init::      version 2015.11.27  @akbooer
2016-02-16 10:32:32.423   openLuup.scheduler:: version 2015.11.27  @akbooer
2016-02-16 10:32:32.423   openLuup.server::    version 2015.12.09  @akbooer
2016-02-16 10:32:32.514   openLuup.plugins::   version 2015.11.06  @akbooer
2016-02-16 10:32:32.605   openLuup.scenes::    version 2015.11.12  @akbooer
2016-02-16 10:32:32.695   openLuup.chdev::     version 2015.11.09  @akbooer
2016-02-16 10:32:32.761   openLuup.io::        version 2015.10.15  @akbooer
2016-02-16 10:32:32.761   openLuup.luup:0:      version 2015.11.16  @akbooer
2016-02-16 10:32:32.841   openLuup.rooms::     version 2015.10.15  @akbooer
2016-02-16 10:32:32.841   openLuup.requests::  version 2015.11.09  @akbooer
2016-02-16 10:32:32.993   luup.create_device:: [1] D_ZWaveNetwork.xml / I_ZWave.xml /
2016-02-16 10:32:33.157   luup.create_device:: [2] D_SceneController1.xml /  / D_SceneController1.json
2016-02-16 10:32:33.158   openLuup.init:: loading configuration user_data.json
2016-02-16 10:32:33.219   openLuup.init:: loading user_data json...
2016-02-16 10:32:33.224   openLuup.init:: loading rooms...
2016-02-16 10:32:33.225   openLuup.init:: ...room loading completed
2016-02-16 10:32:33.225   openLuup.init:: loading devices...
2016-02-16 10:32:33.227   luup.create_device:: [1] D_ZWaveNetwork.xml / I_ZWave.xml /
2016-02-16 10:32:33.228   luup.create_device:: [2] D_SceneController1.xml /  / D_SceneController1.json
2016-02-16 10:32:33.228   openLuup.init:: loading scenes...
2016-02-16 10:32:33.228   openLuup.init:: number of scenes = 0
2016-02-16 10:32:33.246   openLuup.init:: ...scene loading completed
2016-02-16 10:32:33.246   openLuup.init:: loading installed plugin info...
2016-02-16 10:32:33.246   openLuup.init:: ...user_data loading completed
2016-02-16 10:32:33.246   openLuup.init:: running _openLuup_STARTUP_
2016-02-16 10:32:33.247   openLuup.init:: init phase completed
2016-02-16 10:32:33.247   openLuup.server:: starting HTTP server on 192.168.1.104:3480 tcp{server}: 0x1fcff28
2016-02-16 10:32:33.247   openLuup.scheduler:: starting
2016-02-16 10:33:32.759   openLuup.server:: new client connection: tcp{client}: 0x1fd8da8
2016-02-16 10:33:32.761   openLuup.server:: /data_request?id=lr_ALTUI_Handler&command=home tcp{client}: 0x1fd8da8
2016-02-16 10:33:32.764   openLuup.server:: request completed (10 bytes, 1 chunks, 2 ms) tcp{client}: 0x1fd8da8
2016-02-16 10:33:32.981   openLuup.server:: /favicon.ico tcp{client}: 0x1fd8da8
2016-02-16 10:33:32.982   openLuup.HTTP.FILE:: file not found:favicon.ico
2016-02-16 10:33:32.983   openLuup.server:: request completed (0 bytes, 0 chunks, 1 ms) tcp{client}: 0x1fd8da8
2016-02-16 10:35:03.110   openLuup.server:: closing client connection: tcp{client}: 0x1fd8da8
2016-02-16 10:38:33.407   openLuup.heartbeat:: memory: 0.6Mb, uptime: 0.00 days, cpu: 0.3 sec (0.09%)
2016-02-16 10:44:33.904   openLuup.heartbeat:: memory: 0.6Mb, uptime: 0.01 days, cpu: 0.5 sec (0.07%)
2016-02-16 10:50:34.402   openLuup.heartbeat:: memory: 0.6Mb, uptime: 0.01 days, cpu: 0.6 sec (0.06%)
2016-02-16 10:54:56.454   openLuup.server:: new client connection: tcp{client}: 0x1f5aac8
2016-02-16 10:54:56.456   openLuup.server:: /data_request?id=lr_ALTUI_Handler&command=home tcp{client}: 0x1f5aac8
2016-02-16 10:54:56.458   openLuup.server:: request completed (10 bytes, 1 chunks, 2 ms) tcp{client}: 0x1f5aac8
2016-02-16 10:54:56.491   openLuup.server:: /favicon.ico tcp{client}: 0x1f5aac8
2016-02-16 10:54:56.492   openLuup.HTTP.FILE:: file not found:favicon.ico
2016-02-16 10:54:56.492   openLuup.server:: request completed (0 bytes, 0 chunks, 1 ms) tcp{client}: 0x1f5aac8
2016-02-16 10:54:59.018   openLuup.server:: new client connection: tcp{client}: 0x1f8f098
2016-02-16 10:54:59.023   openLuup.server:: /data_request?id=lr_ALTUI_Handler&command=home tcp{client}: 0x1f5aac8
2016-02-16 10:54:59.025   openLuup.server:: request completed (10 bytes, 1 chunks, 2 ms) tcp{client}: 0x1f5aac8
2016-02-16 10:54:59.041   openLuup.server:: /favicon.ico tcp{client}: 0x1f5aac8
2016-02-16 10:54:59.042   openLuup.HTTP.FILE:: file not found:favicon.ico
2016-02-16 10:54:59.042   openLuup.server:: request completed (0 bytes, 0 chunks, 1 ms) tcp{client}: 0x1f5aac8
2016-02-16 10:55:00.911   openLuup.server:: /data_request?id=lr_ALTUI_Handler&command=home tcp{client}: 0x1f5aac8
2016-02-16 10:55:00.914   openLuup.server:: request completed (10 bytes, 1 chunks, 2 ms) tcp{client}: 0x1f5aac8
2016-02-16 10:55:00.930   openLuup.server:: /favicon.ico tcp{client}: 0x1f5aac8
2016-02-16 10:55:00.931   openLuup.HTTP.FILE:: file not found:favicon.ico
2016-02-16 10:55:00.931   openLuup.server:: request completed (0 bytes, 0 chunks, 1 ms) tcp{client}: 0x1f5aac8
2016-02-16 10:55:03.035   openLuup.server:: /data_request?id=lr_ALTUI_Handler&command=home tcp{client}: 0x1f5aac8
2016-02-16 10:55:03.038   openLuup.server:: request completed (10 bytes, 1 chunks, 2 ms) tcp{client}: 0x1f5aac8
2016-02-16 10:55:03.060   openLuup.server:: /favicon.ico tcp{client}: 0x1f5aac8
2016-02-16 10:55:03.061   openLuup.HTTP.FILE:: file not found:favicon.ico
2016-02-16 10:55:03.061   openLuup.server:: request completed (0 bytes, 0 chunks, 1 ms) tcp{client}: 0x1f5aac8

Enviado desde mi SM-G925F mediante Tapatalk


Offline akbooer

  • Moderator
  • Master Member
  • *****
  • Posts: 6387
  • Karma: +291/-70
  • "Less is more"
Re: Novice manual to rpi2?
« Reply #17 on: February 16, 2016, 05:03:21 am »
You haven't started AltUI. Take a look at the example startup.lua file and make sure yours does the same.
3x Vera Lite-UI5/Edge-UI7, 25x Fibaro, 23x TKB, 9x MiniMote, 2x NorthQ Power, 2x Netatmo, 1x Foscam FI9831P, 9x Philips Hue,
Razberry, MySensors Arduino, HomeWave, AltUI, AltHue, DataYours, Grafana, openLuup, ZWay, ZeroBrane Studio.

Offline CudaNet

  • Beta Testers
  • Hero Member
  • *****
  • Posts: 1401
  • Karma: +42/-11
  • Chimichanga !
Re: Novice manual to rpi2?
« Reply #18 on: February 16, 2016, 12:32:54 pm »
I took a peek at the startup file this morning and the only modification made to it was for the bridge (IP address). I suggested checking that dkjson was installed as I've seen that cause a No Handler. I found it odd as it was mentioned that once AltUI is installed they were able to start the UI but it wanted to update, why would it update when it just loaded the latest files ...

You haven't started AltUI. Take a look at the example startup.lua file and make sure yours does the same.
openLuup, AltUI, Zway and HomeWave, enough said...

Offline akbooer

  • Moderator
  • Master Member
  • *****
  • Posts: 6387
  • Karma: +291/-70
  • "Less is more"
Re: Novice manual to rpi2?
« Reply #19 on: February 16, 2016, 12:42:30 pm »
The startup.lua file is NOT being run in the log posted.  A fresh startup with startup.lua looks like this:

Code: [Select]
2016-02-16 17:37:08.295   :: openLuup STARTUP ::
2016-02-16 17:37:08.296   openLuup.init::      version 2016.01.28  @akbooer
2016-02-16 17:37:08.511   openLuup.scheduler:: version 2015.11.27  @akbooer
2016-02-16 17:37:08.511   openLuup.server::    version 2016.01.28  @akbooer
2016-02-16 17:37:08.806   openLuup.plugins::   version 2015.12.22  @akbooer
2016-02-16 17:37:08.845   openLuup.scenes::    version 2015.11.12  @akbooer
2016-02-16 17:37:08.932   openLuup.chdev::     version 2016.01.28  @akbooer
2016-02-16 17:37:08.934   openLuup.io:0:        version 2016.01.31  @akbooer
2016-02-16 17:37:08.934   openLuup.luup:0:      version 2016.02.10  @akbooer
2016-02-16 17:37:09.083   openLuup.rooms::     version 2015.10.15  @akbooer
2016-02-16 17:37:09.083   openLuup.requests::  version 2015.11.09  @akbooer
2016-02-16 17:37:09.084   luup.create_device:: [1] D_ZWaveNetwork.xml /  /
2016-02-16 17:37:09.084   luup.create_device:: [2] D_SceneController1.xml /  /
2016-02-16 17:37:09.084   openLuup.init:: loading configuration startup.lua
2016-02-16 17:37:09.084   openLuup.init:: running _openLuup_STARTUP_

whereas the posted one shows:

Code: [Select]
2016-02-16 10:32:33.158   openLuup.init:: loading configuration user_data.json
2016-02-16 10:32:33.219   openLuup.init:: loading user_data json...

Note the difference:

2016-02-16 17:37:09.084   openLuup.init:: loading configuration startup.lua

versus

2016-02-16 10:32:33.158   openLuup.init:: loading configuration user_data.json

3x Vera Lite-UI5/Edge-UI7, 25x Fibaro, 23x TKB, 9x MiniMote, 2x NorthQ Power, 2x Netatmo, 1x Foscam FI9831P, 9x Philips Hue,
Razberry, MySensors Arduino, HomeWave, AltUI, AltHue, DataYours, Grafana, openLuup, ZWay, ZeroBrane Studio.

Offline CudaNet

  • Beta Testers
  • Hero Member
  • *****
  • Posts: 1401
  • Karma: +42/-11
  • Chimichanga !
Re: Novice manual to rpi2?
« Reply #20 on: February 16, 2016, 01:13:43 pm »
Ah, I now see what your saying....

The startup.lua file is NOT being run in the log posted.  A fresh startup with startup.lua looks like this:

Code: [Select]
2016-02-16 17:37:08.295   :: openLuup STARTUP ::
2016-02-16 17:37:08.296   openLuup.init::      version 2016.01.28  @akbooer
2016-02-16 17:37:08.511   openLuup.scheduler:: version 2015.11.27  @akbooer
2016-02-16 17:37:08.511   openLuup.server::    version 2016.01.28  @akbooer
2016-02-16 17:37:08.806   openLuup.plugins::   version 2015.12.22  @akbooer
2016-02-16 17:37:08.845   openLuup.scenes::    version 2015.11.12  @akbooer
2016-02-16 17:37:08.932   openLuup.chdev::     version 2016.01.28  @akbooer
2016-02-16 17:37:08.934   openLuup.io:0:        version 2016.01.31  @akbooer
2016-02-16 17:37:08.934   openLuup.luup:0:      version 2016.02.10  @akbooer
2016-02-16 17:37:09.083   openLuup.rooms::     version 2015.10.15  @akbooer
2016-02-16 17:37:09.083   openLuup.requests::  version 2015.11.09  @akbooer
2016-02-16 17:37:09.084   luup.create_device:: [1] D_ZWaveNetwork.xml /  /
2016-02-16 17:37:09.084   luup.create_device:: [2] D_SceneController1.xml /  /
2016-02-16 17:37:09.084   openLuup.init:: loading configuration startup.lua
2016-02-16 17:37:09.084   openLuup.init:: running _openLuup_STARTUP_

whereas the posted one shows:

Code: [Select]
2016-02-16 10:32:33.158   openLuup.init:: loading configuration user_data.json
2016-02-16 10:32:33.219   openLuup.init:: loading user_data json...

Note the difference:

2016-02-16 17:37:09.084   openLuup.init:: loading configuration startup.lua

versus

2016-02-16 10:32:33.158   openLuup.init:: loading configuration user_data.json

openLuup, AltUI, Zway and HomeWave, enough said...

Offline rabeliyo

  • Sr. Newbie
  • *
  • Posts: 25
  • Karma: +0/-0
Re: Novice manual to rpi2?
« Reply #21 on: February 16, 2016, 05:53:42 pm »
Ok i reset all and i start again, and give me the same error.

I see that i have 6 LuaUPnP.log files.

LuaUPNP.log (the first that i posted)
LuaUPNP.log.1
LuaUPNP.log.2
LuaUPNP.log.3
LuaUPNP.log.4
LuaUPNP.log.5

I think the LuaUPNP.log.1 is the correct, i see an error address but i don't know why



Enviado desde mi SM-G925F mediante Tapatalk


Offline akbooer

  • Moderator
  • Master Member
  • *****
  • Posts: 6387
  • Karma: +291/-70
  • "Less is more"
Re: Novice manual to rpi2?
« Reply #22 on: February 16, 2016, 06:12:06 pm »
So, three things wrong I see from the start:
  • 'create_device' not defined means that the function is called in the startup.lua file, but has not been defined
  • unable to start server, probably means that another copy is already running (you've perhaps tried this a few times).  The command http://VeraIP:3480/data_request?id=exit should kill the running copy
  • you're not running the latest version from GitHub
You haven't posted the startup.lua file you're using (although you did PM it to @CudaNet)
3x Vera Lite-UI5/Edge-UI7, 25x Fibaro, 23x TKB, 9x MiniMote, 2x NorthQ Power, 2x Netatmo, 1x Foscam FI9831P, 9x Philips Hue,
Razberry, MySensors Arduino, HomeWave, AltUI, AltHue, DataYours, Grafana, openLuup, ZWay, ZeroBrane Studio.

Offline CudaNet

  • Beta Testers
  • Hero Member
  • *****
  • Posts: 1401
  • Karma: +42/-11
  • Chimichanga !
Re: Novice manual to rpi2?
« Reply #23 on: February 16, 2016, 06:27:34 pm »
My fault, logs prompted me to check the PM again and sure enough...

Code: [Select]
do -- the BRIDGE !!
  local d = create_device ("Remote Vera", "D_VeraBridge.xml")
  luup.ip_set ("192.168.1.122", d)         -- set remote Vera IP address
end

So, three things wrong I see from the start:
  • 'create_device' not defined means that the function is called in the startup.lua file, but has not been defined
  • unable to start server, probably means that another copy is already running (you've perhaps tried this a few times).  The command http://VeraIP:3480/data_request?id=exit should kill the running copy
  • you're not running the latest version from GitHub
You haven't posted the startup.lua file you're using (although you did PM it to @CudaNet)
openLuup, AltUI, Zway and HomeWave, enough said...

Offline rabeliyo

  • Sr. Newbie
  • *
  • Posts: 25
  • Karma: +0/-0
Re: Novice manual to rpi2?
« Reply #24 on: February 17, 2016, 06:22:45 am »
I download the lasted version from GitHub and overwrite the old files.
-I do again the step 19
-I put ./openluup_reload reset and at same time y paste the url in my browser, give me a "not a data request" text.

- I do a ...id=exit in my browser.
-Execute ./openLuup_reload startup.lua and paste de url ...home in my browser
-The same no handler error  :'(



Enviado desde mi SM-G925F mediante Tapatalk


Offline akbooer

  • Moderator
  • Master Member
  • *****
  • Posts: 6387
  • Karma: +291/-70
  • "Less is more"
Re: Novice manual to rpi2?
« Reply #25 on: February 17, 2016, 07:05:43 am »
Well, this time you got an error writing one of the AltUI update files.  It's not clear to me why this happened.  What file system are you writing this to?  Have you, perhaps run out of space?  Is it repeatable?

The update takes about a minute, when it appears that nothing is happening, so give it time.  The system, on successful update, should restart after which you should be able to access the AltUI handler.
3x Vera Lite-UI5/Edge-UI7, 25x Fibaro, 23x TKB, 9x MiniMote, 2x NorthQ Power, 2x Netatmo, 1x Foscam FI9831P, 9x Philips Hue,
Razberry, MySensors Arduino, HomeWave, AltUI, AltHue, DataYours, Grafana, openLuup, ZWay, ZeroBrane Studio.

Offline rabeliyo

  • Sr. Newbie
  • *
  • Posts: 25
  • Karma: +0/-0
Re: Novice manual to rpi2?
« Reply #26 on: February 17, 2016, 05:21:55 pm »
I send the commands by ssh (putty) from my windows computer and my windows browser.
The raspberry has 16gb and OSMC installed (Debian)
Now i,m try to reinstall the ALTUI and wait to the restart (never restart the other times)
I hope finally works....
If not, maybe anyone can send me the altui files and install it by WinsSCP

Enviado desde mi SM-G925F mediante Tapatalk


Offline rabeliyo

  • Sr. Newbie
  • *
  • Posts: 25
  • Karma: +0/-0
Re: Novice manual to rpi2?
« Reply #27 on: February 18, 2016, 05:22:15 am »
Ok, i reinstall the altui (wait all night but not restart the system) and paste the url, the first time i can enter.
But when i do an exit and try to re-enter, give me the error.
When i press the update, nothing happend, and wait a long, but nothing.

I give up,
 :'(

Enviado desde mi SM-G925F mediante Tapatalk


Offline schneeb

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
Re: Novice manual to rpi2?
« Reply #28 on: February 18, 2016, 12:22:04 pm »
I took a peek at the startup file this morning and the only modification made to it was for the bridge (IP address). I suggested checking that dkjson was installed as I've seen that cause a No Handler. I found it odd as it was mentioned that once AltUI is installed they were able to start the UI but it wanted to update, why would it update when it just loaded the latest files ...


I'm seeing lots of errors relating to dkjson on a minimal raspbian install; any ideas how I can get this installed?

*edit* managed to install dkjson .deb available via http://mirrordirector-mb.raspbian.org/raspbian/pool/main/l/lua-dkjson/

can now see the UI... curious why lua-dkjson doesn't get found by apt-get?
« Last Edit: February 18, 2016, 12:39:46 pm by schneeb »

Offline CudaNet

  • Beta Testers
  • Hero Member
  • *****
  • Posts: 1401
  • Karma: +42/-11
  • Chimichanga !
Re: Novice manual to rpi2?
« Reply #29 on: February 18, 2016, 12:52:56 pm »
Don't give up, keep the logs coming and a screen shot of the error (assuming it's not still the handler). If you're able to reproduce the error that's a great start, we're just trying to understand the root cause here. I know you mentioned that you're using a 16GB SD card, I'm no expert with Debian/OSMC but did this allow you to expand the partition or does OSMC provide this within a utility/command line etc.. ? What is the result of df -h ?

I have some SD cards (for testing) arriving on Saturday, I'd be more than happy to install OSMC to help troubleshoot this.

Ok, i reinstall the altui (wait all night but not restart the system) and paste the url, the first time i can enter.
But when i do an exit and try to re-enter, give me the error.
When i press the update, nothing happend, and wait a long, but nothing.

I give up,
 :'(

Enviado desde mi SM-G925F mediante Tapatalk
openLuup, AltUI, Zway and HomeWave, enough said...