We have moved at community.getvera.com

Author Topic: Variable Setup Complete message  (Read 657 times)

Offline beerguy

  • Jr. Member
  • **
  • Posts: 96
  • Karma: +0/-0
Variable Setup Complete message
« on: February 23, 2016, 07:09:46 pm »
First, and foremost, thank you for the excellent app. It has become one of my most valued apps. And because of that, when it stops working life becomes difficult :-)

On my VeraLite UI5 it has been working great for months. No issues.

On my VeraEdge UI7 I quite often get the message "Variable Setup Complete" after a restart but it never fully loads and the app doesn't work. More often than not another restart takes care of it and it works again. I have version 1.6 which I believe is the most recent.

Please let me know if there is any additional information that I can provide to help troubleshoot.

Thanks again for the app.

Patrick

Offline Stuart

  • Moderator
  • Hero Member
  • *****
  • Posts: 728
  • Karma: +71/-2
Re: Variable Setup Complete message
« Reply #1 on: February 24, 2016, 12:42:36 am »
Hi Patric
It's always possible that I broke something but there are some code paths that leave less than helpful messages in the plugin UI,  I'm actually doing a bit of restructuring to clean that up and also bypass some  infrequent errors in certain underlying lua modules -  likely a week or so away ...

Having said that - the log messages are fairly comrehensive. So setting gc_debug to 3 and getting a log file narrows down the issue pretty quickly.  So that's the first thing to do ....

What's causing the restarts? If more than one instance of GCal then the startup is staggered (for the current version) so a restart in mid restart could cause issues etc.