We have moved at community.getvera.com

Author Topic: Experiences & Username Issues w/ going from VeraLite UI5 to VeraPlus & UI7  (Read 1549 times)

Offline Wekurtz74

  • Full Member
  • ***
  • Posts: 236
  • Karma: +3/-0
First of all, I decided to do a fresh install.  That seems to have been unnecessary, but nonetheless it is what I have done.

1.   My Lite was (and still is on) UI5.  When I installed the Plus, I was prompted to create a new account.  I entered my old account information and it created a new account.  This has now created a problem with having what I would call a UI5 and a UI7 account with identical usernames and email accounts.  I must advise anyone else trying this to avoid this as it has caused many problems -- the most immediate of which was not being able to log into my Plus except with one browser on one computer which apparently stored some information in cache.   Eventually, what I needed to do was a create a new account with a new name and different email.  This at least allows me to log onto the Plus from any browser and SOME android apps.
   1.A. -- Does anyone know if there is a way to delete an account with Vera?
    1.B. -- IF an account cannot be deleted, is there a way to associate 2 different usernames with the same email address? 


2.  Garrettwp's outstanding AutHomation app was not working for me on UI 7 in remote mode. I understand it is not underdevelopment anymore as Garrett has moved on, but this was disappointing.  It took me a bit of time to get it going, and I think I have solved the issues.  If anyone else is having this issue, post here and I will try to help you.  I am not 100% I have solved this, but if you are playing around with it, I would suggest your download the latest beta and read the information at the end of the Beta thread for help.     

3.   Experiencing some issues with basic PLEG actions.  Very simple stuff -- Motion turns on light, then X minutes later, the light should go off.  I can get the light to go on, I just cant get it turn off after the delay.  Unclear why this doesn't work when it worked perfectly under UI5.   

Offline JasonJoel

  • Full Member
  • ***
  • Posts: 123
  • Karma: +22/-109
Why would you use pleg instead of a scene for a simple light timer like that? Pleg seems like overkill for that.

Sent from my XT1585 using Tapatalk


Offline Wekurtz74

  • Full Member
  • ***
  • Posts: 236
  • Karma: +3/-0

Why would you use pleg instead of a scene for a simple light timer like that? Pleg seems like overkill for that.

Sent from my XT1585 using Tapatalk

I thought PLEG was the only way to do anything like that to be honest.    But, that simple action was meant to be part of a something more complicated which I have not gotten around to yet. 

Also, that said, I think have had better luck with other PLEG actions I have tried subsequent to my post.  I can probably solve this problem by simply deleting the offending item and trying again.

My concerns remain about the account issues.  I have further discovered that authomation seems to work sometimes and not work other on remote connections. 




Sent from my iPad using Tapatalk

Offline kigmatzomat

  • Sr. Member
  • ****
  • Posts: 377
  • Karma: +23/-0
Here is luup code I use as on a minimote to toggle a lamp next to my bed.   If the light is on, it drops it to 70% brightness and then slowly dims.  If it's off, it goes to 10% brightness and ramps up to full.

My lamp id is 40.  change as you need.  I think this has some extra variables I never cleaned out but c'est la vie.

local device=40
local delay=10
local mindim=0
local maxdim=100
local counter=0
local counter_max=11

local switchOnOff = luup.variable_get("urn:upnp-org:serviceId:SwitchPower1", "Status", device)
local lightLevel =luup.variable_get("urn:upnp-org:serviceId:Dimming1", "LoadLevelTarget", device)

  if (switchOnOff == "1") then
              lightLevel=70
      -- Switch is on
            while   (lightLevel >=0)  do
                 luup.call_delay( luup.call_action("urn:upnp-org:serviceId:Dimming1", "SetLoadLevelTarget", {newLoadlevelTarget = lightLevel}, device)     ,delay)                     
                 lightLevel =lightLevel-1
            end

      else
     lightLevel=10

            while   (lightLevel <100)  do
                 luup.call_delay( luup.call_action("urn:upnp-org:serviceId:Dimming1", "SetLoadLevelTarget", {newLoadlevelTarget = lightLevel}, device)     ,delay)                     
                 lightLevel =lightLevel+1
            end


         
    end

Offline jbfoster

  • Full Member
  • ***
  • Posts: 199
  • Karma: +10/-24
First of all, I decided to do a fresh install.  That seems to have been unnecessary, but nonetheless it is what I have done.

1.   My Lite was (and still is on) UI5.  When I installed the Plus, I was prompted to create a new account.  I entered my old account information and it created a new account.  This has now created a problem with having what I would call a UI5 and a UI7 account with identical usernames and email accounts.  I must advise anyone else trying this to avoid this as it has caused many problems -- the most immediate of which was not being able to log into my Plus except with one browser on one computer which apparently stored some information in cache.   Eventually, what I needed to do was a create a new account with a new name and different email.  This at least allows me to log onto the Plus from any browser and SOME android apps.
   1.A. -- Does anyone know if there is a way to delete an account with Vera?
    1.B. -- IF an account cannot be deleted, is there a way to associate 2 different usernames with the same email address? 


Email support@getvera.com from the email address you want deleted and give them the username also. It will take a few days for them to get to it but that's what I did.