Author Topic: openLuup: Turn-key Images & Linux (Aptitude) Guide  (Read 35687 times)

Offline akbooer

  • Moderator
  • Master Member
  • *****
  • Posts: 5731
  • Karma: +246/-69
  • "Less is more"
Re: openLuup: Turn-key Images & Linux (Aptitude) Guide
« Reply #255 on: December 31, 2017, 09:08:30 am »
I think it's worth trying to update your openLuup image before anything else... the turnkey image is a bit dated these days (although, to be fair, it certainly worked well!)

The check mark on the Plugins screen is meaningless, and indeed it is not checked by default.  Perhaps you clicked that box, rather than pressing the button on the right hand side?

To update openLuup from the Plugins screen, just type development into the Update box and click the update button on the right (NOT the checkbox.)

Always worth refreshing the browser after things have updated.
3x Vera Lite-UI5/Edge-UI7, 25x Fibaro, 23x TKB, 9x MiniMote, 2x NorthQ Power, 2x Netatmo, 1x Foscam FI9831P, 2x Philips Hue
Razberry, MySensors Arduino, HomeWave, AltUI, DataYours, openLuup, ZWay, ZeroBrane Studio.

Offline RHCPNG

  • Full Member
  • ***
  • Posts: 149
  • Karma: +5/-0
Re: openLuup: Turn-key Images & Linux (Aptitude) Guide
« Reply #256 on: December 31, 2017, 10:04:26 am »
I think it's worth trying to update your openLuup image before anything else... the turnkey image is a bit dated these days (although, to be fair, it certainly worked well!)

The check mark on the Plugins screen is meaningless, and indeed it is not checked by default.  Perhaps you clicked that box, rather than pressing the button on the right hand side?

To update openLuup from the Plugins screen, just type development into the Update box and click the update button on the right (NOT the checkbox.)

Always worth refreshing the browser after things have updated.

This fixed it, thnx akbooer!

Now I only still have two OpenLuup devices. Can this give me any problems?

Offline ChrisTheC

  • Full Member
  • ***
  • Posts: 125
  • Karma: +3/-1
Re: openLuup: Turn-key Images & Linux (Aptitude) Guide
« Reply #257 on: December 31, 2017, 11:00:56 am »

This fixed it, thnx akbooer!

Now I only still have two OpenLuup devices. Can this give me any problems?

That happened to me too. I think I may have checked the "Update" box on the "Plugins" page (as akbooer notes above is not needed). When I figured the correct way to update openLuup, I was left with 2 openLuup plugins.

Since I was just starting with the VirtualBox image, I didn't care if I screwed things up (easy enough to recreate from scratch at this point) . . .
I just trashed one of the openLuup plugins - see image below.

Hope this helps
Chris


Offline akbooer

  • Moderator
  • Master Member
  • *****
  • Posts: 5731
  • Karma: +246/-69
  • "Less is more"
Re: openLuup: Turn-key Images & Linux (Aptitude) Guide
« Reply #258 on: December 31, 2017, 12:14:08 pm »
The openLuup plugin should be installed as device #2 (which, in Vera, is the local scene controller.)  If you have another one, then go ahead and delete it, although I would be very interested to know what you did to do that... did you perhaps try and install it from the plugins menu?  It comes built-in with the basic system.
3x Vera Lite-UI5/Edge-UI7, 25x Fibaro, 23x TKB, 9x MiniMote, 2x NorthQ Power, 2x Netatmo, 1x Foscam FI9831P, 2x Philips Hue
Razberry, MySensors Arduino, HomeWave, AltUI, DataYours, openLuup, ZWay, ZeroBrane Studio.

Offline RHCPNG

  • Full Member
  • ***
  • Posts: 149
  • Karma: +5/-0
Re: openLuup: Turn-key Images & Linux (Aptitude) Guide
« Reply #259 on: December 31, 2017, 12:20:57 pm »
The openLuup plugin should be installed as device #2 (which, in Vera, is the local scene controller.)  If you have another one, then go ahead and delete it, although I would be very interested to know what you did to do that... did you perhaps try and install it from the plugins menu?  It comes built-in with the basic system.


I think it was already there when I got to AltUI for the first time. I did however have some troubles with my virtual network card when I first started the VM.

Offline RHCPNG

  • Full Member
  • ***
  • Posts: 149
  • Karma: +5/-0
Re: openLuup: Turn-key Images & Linux (Aptitude) Guide
« Reply #260 on: January 12, 2018, 03:46:27 am »
Just to be sure. Is there now a backup script configured in the VM that runs automatically? Because I see a backup file, but as stated, there is no scene for it.

I have to create my own scene, right?

Offline akbooer

  • Moderator
  • Master Member
  • *****
  • Posts: 5731
  • Karma: +246/-69
  • "Less is more"
Re: openLuup: Turn-key Images & Linux (Aptitude) Guide
« Reply #261 on: January 12, 2018, 01:30:29 pm »
Sorry, don?t understand this question.   Backups of the user_data.json file are made regularly (default is 6 minutes after startup, and thereafter every hour) with 5 previous versions being saved (by default.)

The AltUI interface More > Table Controllers > Backup allow you to generate a separately archived (and, by default, compressed) backup file with the option to download to your browser machine. This action can also be initiated by HTTP request.

If you need something more, then, yes, you could write your own scene to do it.  Or, indeed, an external script.
3x Vera Lite-UI5/Edge-UI7, 25x Fibaro, 23x TKB, 9x MiniMote, 2x NorthQ Power, 2x Netatmo, 1x Foscam FI9831P, 2x Philips Hue
Razberry, MySensors Arduino, HomeWave, AltUI, DataYours, openLuup, ZWay, ZeroBrane Studio.

Offline RHCPNG

  • Full Member
  • ***
  • Posts: 149
  • Karma: +5/-0
Re: openLuup: Turn-key Images & Linux (Aptitude) Guide
« Reply #262 on: January 12, 2018, 02:05:08 pm »
Sorry, don?t understand this question.   Backups of the user_data.json file are made regularly (default is 6 minutes after startup, and thereafter every hour) with 5 previous versions being saved (by default.)

The AltUI interface More > Table Controllers > Backup allow you to generate a separately archived (and, by default, compressed) backup file with the option to download to your browser machine. This action can also be initiated by HTTP request.

If you need something more, then, yes, you could write your own scene to do it.  Or, indeed, an external script.

Ok, that was the answer I was looking for. I want to save some older backups then 5 hours, for example every week. Thanks!

Offline ChrisTheC

  • Full Member
  • ***
  • Posts: 125
  • Karma: +3/-1
Re: openLuup: Guide addendum suggestion
« Reply #263 on: February 03, 2018, 11:23:00 am »
Hello CudaNet,

First, thank you again for the images & the guides.

Concerning the instruction file: raspberryPi_Debian.txt

When I followed the guide a few weeks / months? ago, I basically had an idiot moment at step [02]. The Pi that I was using was connected to my network via WiFi. I'd already had the Pi's WiFi mac address registered to my router to assign a particular ip address when booted. (this Pi is being used for osmc) But it was located at a convenient spot next to my laptop, and has a monitor & keyboard already connected.

I figured to set up the openLuup image here, and then just move the micro-sd to my LAN connected Pi in the basement (the ultimate home of openLuup)

This is where my idiot moment kicked in. After about 20 minutes of head scratching, (why won't my network assign my Pi the ip address specified in my router?) DUH DUH you idiot! you goofball! This is a brand new OS, which does NOT contain my wifi credentials.

OK, no problem. Searched the internet & learned how to edit the wpa_supplicant.conf file and on I go.

End of story.

Jump ahead in time several weeks . . .
I decided to start again from scratch & re-image my openLuup install onto a larger micro-sd. Again, I used the same (WiFi connected, osmc tasked) Pi to do the setup.

Would you believe I made the same dumb mistake AGAIN! I forgot about the wpa_supplicant.conf that I had made earlier and had another head scratching several moments.

I'm not a networking newbie, but I sure forgot twice an important step.

I think your guides (& the images) are very valuable still. Would you consider incorporating similar wording like the sample below?

Of course it's possible that I am the only one who had the idiot moment (twice)

Code: [Select]
[02] Step [02] >> image << : First time boot.
Turn-Key.
-----------------------------------------------------

[a] Power 'on' the Raspberry and allow it to fully boot.

> Attempt to ping >> ip address << :
> The system should respond with:

--

Pinging >> address << with 32 bytes of data:
Reply from >> ip address <<: bytes=32 time=1ms TTL=64
Reply from >> ip address <<: bytes=32 time<1ms TTL=64
Reply from >> ip address <<: bytes=32 time<1ms TTL=64
Reply from >> ip address <<: bytes=32 time<1ms TTL=64

--

> If you can successfully ping the Raspberry, you can proceed to the next step.
> If you cannot, then you'll need to properly troubleshoot the static, dhcp or IP subnet.

Suggested step [02] newbie addendum here. Before or after step [02] [a] whichever you think.
[b] If you cannot initially connect your Raspberry Pi to your home network with a LAN cable, (ie you are using WiFi), you will
not be able to ping the Pi. (Of course not, your wifi network is probably encrypted WPA, WPA2 etc.). In this situation, connect
a USB keyboard and a monitor directly to the Raspberry before powering on.

When the Raspberry finishes booting, login with user: pi and password: raspberry.
Type - "sudo nano /etc/wpa_supplicant/wpa_supplicant.conf" (without the quotes)
Add the following 4 lines to the end of the file that is opened:

network={
    ssid="testing" -- where "testing" is the SSID of your WiFi network. (you MUST use the quotes here)
    psk="Password" -- where "Password" is the password on your WiFi network (you MUST use the quotes here)
}

Tip: the default keyboard/locale setup will show an ampersand "@" symbol when you try to enter a quote symbol.
When entering the ssid & psk values, use the "@" key instead of the quotes and you should be good.

Save the modified file using the instruction symbols at the bottom of your monitor.

When you are returned to the $ prompt, type "sudo reboot" (without the quotes) to reboot the Pi.

After the Pi is restarted, login again with the user: pi and password: raspberry

At the $ prompt type:
ifconfig

The output on your monitor should show the ip address that was assigned by your router. Now try to ping the address
from your computer.

You should now be able to continue to step [04] using your computer.



Regards,
Chris