We have moved at community.getvera.com

Author Topic: GE CADDX Panic Buttons not working - LUUP Log attached  (Read 2864 times)

Offline dinochronos

  • Full Member
  • ***
  • Posts: 116
  • Karma: +0/-0
GE CADDX Panic Buttons not working - LUUP Log attached
« on: March 20, 2016, 03:12:29 pm »
Futzle,

I have been able to capture the logs as a result of pressing all three  panic buttons on the Device, also the check box is selected under configure for the panic buttons.

One thing I noticed is that on the log it shows the code pointing to Partion 2.. not sure why, but my alarm system is on Partion 1.  Also if you can let me know what else do you see in the logs for each of the panic buttons pressed.  I have attached the document for review with separate log sections for each of the panic buttons pressed.

Looking forward to getting this piece functioning.  My unit is a VERA Plus on UI7 running v.81 as the latest version from the app store of the plugin.

Offline futzle

  • Moderator
  • Master Member
  • *****
  • Posts: 3260
  • Karma: +192/-9
Re: GE CADDX Panic Buttons not working - LUUP Log attached
« Reply #1 on: March 21, 2016, 04:37:41 am »
You need to enable verbose logging in the plugin on the Configure tab.

"Partition2" is version 2 of the alarm service interface, not Partition 2.

Offline dinochronos

  • Full Member
  • ***
  • Posts: 116
  • Karma: +0/-0
Re: GE CADDX Panic Buttons not working - LUUP Log attached
« Reply #2 on: March 26, 2016, 12:06:31 pm »
Futlze sorry for delayed response was traveling this week.

Attached are updated log files captured with Verbose Logging selected in the configuration tab for the alarm panel.  I have one file each for each button type pressed.

And fortunately because these buttons don't trigger any alarm/siren  it worked out well to test :)

Look forward hearing your thoughts.

Thanks!

Offline futzle

  • Moderator
  • Master Member
  • *****
  • Posts: 3260
  • Karma: +192/-9
Re: GE CADDX Panic Buttons not working - LUUP Log attached
« Reply #3 on: March 28, 2016, 05:26:42 am »
Attached are updated log files captured with Verbose Logging selected in the configuration tab for the alarm panel.

Thanks. I will take a look at them. The logging is a bit sparse so I might have to add some extra logging code to see what path it is following.

Offline futzle

  • Moderator
  • Master Member
  • *****
  • Posts: 3260
  • Karma: +192/-9
Re: GE CADDX Panic Buttons not working - LUUP Log attached
« Reply #4 on: March 30, 2016, 06:15:07 pm »
Oh, I think I see what's happened.

Try to add this variable to the partition device through the UI (Advanced > New Service):

Code: [Select]
Service ID: urn:futzle-com:serviceId:CaddxNX584Security1
Variable name: EnablePanic
Value: 1

Spelling and capitalization are important, so copy-and-paste to ensure you haven't mistyped, and watch out for leading and trailing spaces.

The checkbox on the Configure tab sets the variable on the top-level Alarm device, but the code seems to check for it on the partition device.

Offline dinochronos

  • Full Member
  • ***
  • Posts: 116
  • Karma: +0/-0
Re: GE CADDX Panic Buttons not working - LUUP Log attached
« Reply #5 on: April 01, 2016, 01:44:57 am »
Futzle, I added the info exactly as you suggested to the portion device and got positive response as follows here is the log file from the panel device:
Date
Time
Event
3-31
23:19
Manual fire (Partition 1)
3-31
23:17
Tamper (Zone 5 Partition 1)
3-31
23:17
Tamper (Zone 4 Partition 1)
3-31
23:17
Tamper (Zone 3 Partition 1)
3-31
23:17
Closing (User 1 Partition 1)
3-31
23:15
Auxiliary 2 Panic (Partition 1)
3-31
22:42
First to open (User 1 Partition 1)

I only pressed the emergency and later the fire button and both tested positively, I also called the central monitoring station to double check while system in test mode and they also confirmed these panic buttons communicated positively.  I did not have a chance to test the police panic button due to time of day/night.  But I will test this tomorrow or over the weekend at an appropriate time as this would trigger an outside siren and will catch a moment that does not disturb the neighbors. 

This is great feature, which when used as a trigger, can then automate several great routines i.e.:

If the Nest CO2 detector goes off , it can then trigger a call to the central station, while meanwhile turning on all lights and setting the HVAC to full ventilation while unlocking doors for emergency access.

If Nest Smoke detector goes off, it would then trigger a call to central station, while meanwhile turning off HVAC and unlocking doors for quick exit and or access by fire dept in no one is home to prevent a forceful entry to the home.. etc.

 I will find a way to test he CO2/Smke detector for triggers or upon trigger of panic buttons to see if the rest of the steps work well too.
Brings a whole new realm to actively leveraging a smoke detector that is not actually connected to the security system such as Zwave and Nest but connecting and integrating to behave as if it was tied and monitored nevertheless.

Thank you for building this feature and glad that this performed as designed.

With  providing the additional instructors, could this be potentially a permanent code update to the plugin  instead of adding separately the service variable?




Offline futzle

  • Moderator
  • Master Member
  • *****
  • Posts: 3260
  • Karma: +192/-9
Re: GE CADDX Panic Buttons not working - LUUP Log attached
« Reply #6 on: April 01, 2016, 06:12:28 am »
Oh good, that was the bug. It's been there for years, which is a good indicator of how many people use this feature. I'll try to fix it some time, in a way that doesn't break existing users' setups. You won't need to delete the new variable you created.

CYA disclaimer: I'm a bit uneasy about relying on Vera automation for the life-and-death scenarios you've outlined. Cool though it may be, please be aware that the plugin is not designed for these kinds of situations.

Offline dinochronos

  • Full Member
  • ***
  • Posts: 116
  • Karma: +0/-0
Re: GE CADDX Panic Buttons not working - LUUP Log attached
« Reply #7 on: April 01, 2016, 10:05:56 pm »
Quote
Oh good, that was the bug. It's been there for years, which is a good indicator of how many people use this feature. I'll try to fix it some time, in a way that doesn't break existing users' setups. You won't need to delete the new variable you created.

CYA disclaimer: I'm a bit uneasy about relying on Vera automation for the life-and-death scenarios you've outlined. Cool though it may be, please be aware that the plugin is not designed for these kinds of situations.
/quote]

Futlze certainly that is clear on the reliance and disclaimer and agreed...as reliability cannot be guaranteed for a variety of factors, but if it works great ,  if it does not trigger so be it at least it one more avenue to try with nevertheless.

 BTW I also did test the police button as well today and it also triggered. So all is good and these functionalities on all three buttons do test out correctly via the service variable provided.

Offline futzle

  • Moderator
  • Master Member
  • *****
  • Posts: 3260
  • Karma: +192/-9
Re: GE CADDX Panic Buttons not working - LUUP Log attached
« Reply #8 on: April 02, 2016, 05:24:47 am »
BTW I also did test the police button as well today and it also triggered.

Thanks for verifying that (apart from the bug you found) these buttons work.