Author Topic: Vera Lite to Vera Plus upgrade, device notifications don't work  (Read 2125 times)

Offline snovvman

  • Full Member
  • ***
  • Posts: 189
  • Karma: +2/-1
I completed the Vera Lite UI7 to Vera Plus UI7 upgrade (backup, controller shift, restore).  After the upgrade, I upgraded VeraAlerts app and registered VeraAlerts from the new licenses i purchased.  I powered down Vera Lite.

The system notifications (Vera Vera Startup, Vera Reboot, Vera Alert Property Updated, etc.) and manual "send message" all work fine, but device notifications do not work.

Observations:
1) I added a new sensor and configured alerts, the notification for the new device works fine.

2) The Notifications Configuration tab shows all the configurations, but nothing gets pushed to my phones.  When I change the override, the "VA Property Update..." alerts gets through, but not the actual sensor notifications.

3) I've tried restarting Vera, restarting LUUP, refresh, no joy either way.

4) I've made sure that the checkbox is selected under device notifications.

5) The profiles and recipients are properly configured (again, system messages get through).

Is there a way to get all the notifications that were transferred from Vera Lite to work on Vera Alerts?

Thanks.


Offline snovvman

  • Full Member
  • ***
  • Posts: 189
  • Karma: +2/-1
Re: Vera Lite to Vera Plus upgrade, device notifications don't work
« Reply #1 on: April 19, 2016, 12:18:31 am »
After some more looking, this may not be a Vera Alert issue.  It seems like the device itself is not sending alerts.  The sensors, when tripped, are not sending the notifications.

Interestingly, when I toggle the sensor from armed to disarmed and back, I get an alert (because there is a notification set to alert of device triped).  When the sensor is actually tripped, it is not sending any notifications (nothing in the log).

This is happening to all the battery sensors.  I successfully woke them and re-enrolled them yesterday.  Vera is not reporting any errors.

Offline RichardTSchaefer

  • Moderator
  • Master Member
  • *****
  • Posts: 9566
  • Karma: +729/-135
    • RTS Services Plugins
Re: Vera Lite to Vera Plus upgrade, device notifications don't work
« Reply #2 on: April 19, 2016, 12:27:22 am »
See:
http://forum.micasaverde.com/index.php/topic,36274.msg275200.html#msg275200


Notifications are invoked from triggers ... so this applies to notifications as well ..

Offline snovvman

  • Full Member
  • ***
  • Posts: 189
  • Karma: +2/-1
Re: Vera Lite to Vera Plus upgrade, device notifications don't work
« Reply #3 on: April 19, 2016, 12:37:56 am »
Thanks for your reply.  I read the thread, however:

My Vera Lite was already on UI7 and the alerts/triggers worked fine. 

Once on Vera Plus, I did not delete any of the existing notifications, but did create a new trigger/notification to try.  The new trigger did not fire either.  When I look at the device log, it did not show the event even though the sensor was tripped.

Any other thoughts?

Offline snovvman

  • Full Member
  • ***
  • Posts: 189
  • Karma: +2/-1
Re: Vera Lite to Vera Plus upgrade, device notifications don't work
« Reply #4 on: April 19, 2016, 12:48:34 am »
I just powered up the Vera Lite UI7 (which is now secondary), and the alerts are now working.

Vera Lite is reporting that it cannot detect the battery sensors that I re-enrolled onto Vera Plus.

Weird...

It seems like these sensors are still "reporting" to Vera Lite, even though they were enrolled with Plus.  Again, I don't think this is a Vera Alerts issue, but I would appreciate any clues on resolving the issue.

Thanks.

Offline sirpinky

  • Sr. Newbie
  • *
  • Posts: 35
  • Karma: +0/-0
Re: Vera Lite to Vera Plus upgrade, device notifications don't work
« Reply #5 on: November 25, 2016, 11:53:49 am »
Exactly the same issue here. Any solution beside factory reset and rebuilding everything from scratch?

All battery devices after the upgrade process showed "cannot detect device", I woke them up one by one and now they all appear OK and stress test is OK on all of them.

However, they do not get triggered at all on Vera Plus. If I turn on my Vera Lite everything starts working. Once Vera Lite is turned off - nothing gets triggered.

I even noticed some apps (like Push Notification) not working anymore.

In my case, I was on UI7 on vera lite a long time ago, and it worked fine.

Love vera, just wished it wouldn't break so often... At least their support is usually great.

If you resolved this issue, please share how.