We have moved at community.getvera.com

Author Topic: Soon I am giving up on VERA...Hue plugin broke and all my scenes are destroyed!!  (Read 9662 times)

Offline mbrihed

  • Sr. Newbie
  • *
  • Posts: 26
  • Karma: +7/-8
There must be something completely wrong with VERA!!! I regret I got this controller since it is the most buggy device I have ever had in my entire life!!!

Hue had an update recently and now VERA Plus lost connection to the HUE controller and suddenly all my lights are gone and all my scenes are broken and gone.

I can't even start the Hue Device anymore!! It is paired and says connected but can't switch it on and therefore all lights in my whole house is not available in VERA Plus....

What a piece of ju*k.

Offline BOFH

  • Sr. Hero Member
  • ******
  • Posts: 2409
  • Karma: +112/-140
Do realize that the HUE plugin created by Andrei is still in beta (version 0.92) and a work in progress. As such unfortunately it can't be relied upon to work 100% all the time. Andrei released it to get feedback on issues under real world applications so he can fix those.

On the one side, I can understand your frustration at not being able to run HUE related scenes, but on the other hand blaming the Vera Plus for the behavior of a plugin is not realistic. Akin to blaming your car manufacturer for those IED air bags supplied by Takata. 

There are alternatives to Vera such as SmartThings and Homeseer (who actually have a 50% off sale now) and you may wish to research those alternatives as Vera, albeit it's working solution for me, may not be the working solution for you.
« Last Edit: May 02, 2016, 11:56:20 am by BOFH »
Vera3 UI5 UI7 Edge Plus
Trane TZEMT400AB32 | Schlage BE369 FE599 | GE 45601 45602 45603 45604 45606 45609 45631 | Intermatic HA01C HA03C HA05C HA07C CA600 CA3000 | Aeon DSC06106 | Telguard GDC1 | Foscam FI8910W FI8905W FI9821W | D-Link 930L | Wanscam JW0011 | ZModo ZPIBH13W

Offline mbrihed

  • Sr. Newbie
  • *
  • Posts: 26
  • Karma: +7/-8
Hi!

thanks for your response!

As far as I know Vera Plus has Hue as a native plugin and it is version 1.12 so I blame VERA.

The other plugin might be better and I think I will try that one since it can't be worse than the one I got out of the box with Vera Plus...

Offline BOFH

  • Sr. Hero Member
  • ******
  • Posts: 2409
  • Karma: +112/-140
I just checked my Vera Plus running UI7 1.7.1754. There is no built-in Hue plugin that I can find. The only one I can find is in the app store is the HUE plugin which was created by forum member intveltr a while back. As MIOS (Andrei) developed their own HUE  plugin, intveltr put development on his one on hold. I don't see the MIOS HUE plugin in the Vera Plus app store. Is HUE Plugin v1.7 by Intvelter the plugin you are using by any chance?

I don't have a spare HUE device I can pull from my production Vera setup unfortunately as doing so and re-adding it would crash all my scenes related to it. I was able to add a spare GE-Link bulb to Vera Plus which the internal Zigbee firmware handled.  On my Vera 3 with UI7 (and no built-in Zigbee) these are connected via the HUE hub.
 
Vera3 UI5 UI7 Edge Plus
Trane TZEMT400AB32 | Schlage BE369 FE599 | GE 45601 45602 45603 45604 45606 45609 45631 | Intermatic HA01C HA03C HA05C HA07C CA600 CA3000 | Aeon DSC06106 | Telguard GDC1 | Foscam FI8910W FI8905W FI9821W | D-Link 930L | Wanscam JW0011 | ZModo ZPIBH13W

Offline mbrihed

  • Sr. Newbie
  • *
  • Posts: 26
  • Karma: +7/-8
Attached a screenshot of my hue plugin.

Offline BOFH

  • Sr. Hero Member
  • ******
  • Posts: 2409
  • Karma: +112/-140
I'm unfamiliar with that particular plugin unfortunately. Let me see if I can get you some help...
Vera3 UI5 UI7 Edge Plus
Trane TZEMT400AB32 | Schlage BE369 FE599 | GE 45601 45602 45603 45604 45606 45609 45631 | Intermatic HA01C HA03C HA05C HA07C CA600 CA3000 | Aeon DSC06106 | Telguard GDC1 | Foscam FI8910W FI8905W FI9821W | D-Link 930L | Wanscam JW0011 | ZModo ZPIBH13W

Offline mbrihed

  • Sr. Newbie
  • *
  • Posts: 26
  • Karma: +7/-8
I tried the one you mentioned as well on the AppStore version 1.7 but it complaints about there is no username when I try to pair it with the Hue bridge...

My Guess is that Hue has changed something in their API's and if that is the case and the plugin I have is a native VERA plugin I have made up my mid to throw my VERA plus over board next time I go fishing since VERA should be aligned to all vendors they have native plugins for!!

I think VERA is a bunch of non professionals doing things on best effort and also every time I contact support it takes two days before a reply.

Offline niharmehta

  • Sr. Member
  • ****
  • Posts: 377
  • Karma: +17/-0
The MIOS HUE2 plugin by MCV.Andrei is still in Beta.  Which translates to .. "it will probably break ". 

 You are blaming Vera because something changed on HUE the other day and broke a BETA plugin?    If you are looking for something to work all the time and somehow expect every company to cross-test each of their releases and everything works.. all the time... then maybe HomeAutomation is not for you. Home Automation is a hobby for only the extremely patient or masochists right now. All the platforms have their own issues.

Can you roll back the HUE firmware to the previous one ?  If not, why not ask HUE support about what changed ? This would be a good contribution to this forum.   
In case something on Vera was corrupted, you may want to restore from a daily backup.


A simple forum search found this thread that you may get more help :
http://forum.micasaverde.com/index.php/topic,33088.180.html
Andrei seems active there and I am sure others have the same set up as you. 
2x VeraLite; 2xTrane Tstats; 45 x Switches/Dimmers/Appliance Modules; 4x Everspring Water Sensors; DSC Integration; 2 x Zwave Door Locks; 1x Ted5K; 1x Rainforest Eagle; Onkyo AVR; 6x Squeezebox;

Offline alpha1

  • Sr. Member
  • ****
  • Posts: 297
  • Karma: +2/-0
I am getting bored of these posters moaning about using Betas which in turn break some or all functionality.

mbrihed, did you take a backup?
Have you restored it?


Offline mbrihed

  • Sr. Newbie
  • *
  • Posts: 26
  • Karma: +7/-8
Hi!

I am NOT using the beta plugin.

And after investigating the HUE was working fine for 2 days after the update of the firmware of the HUE bridge.

I have had a case open with VERA on the HUE plugin since I have 2 HUE bridges and their latest version supports multiple HUE bridges. They did a remote login to the controller and updated the plugin, so it is VERA's plugin.

The plugin says it is connected to the HUE bridge now but I cannot turn it on and therefore it does not pick up any lights.

Offline niharmehta

  • Sr. Member
  • ****
  • Posts: 377
  • Karma: +17/-0
Well, then there is probably some confusion as the forum topic on this plugin version you have is titled:
Topic: Philips Hue plugin by MiOS (BETA)
Scanning that topic it seems the  install method is outside the app store which implies its  not for general deployment. The App store version I can find is the user created one from the past.

Again, instead of complaining more,  have you tried to restore your vera from a backup thats created daily? Use one before the problem started. 
Also, I have not seen you post anything in that forum topic I provided . Likely you will get more help there. 





I am NOT using the beta plugin.

And after investigating the HUE was working fine for 2 days after the update of the firmware of the HUE bridge.

I have had a case open with VERA on the HUE plugin since I have 2 HUE bridges and their latest version supports multiple HUE bridges. They did a remote login to the controller and updated the plugin, so it is VERA's plugin.

The plugin says it is connected to the HUE bridge now but I cannot turn it on and therefore it does not pick up any lights.
2x VeraLite; 2xTrane Tstats; 45 x Switches/Dimmers/Appliance Modules; 4x Everspring Water Sensors; DSC Integration; 2 x Zwave Door Locks; 1x Ted5K; 1x Rainforest Eagle; Onkyo AVR; 6x Squeezebox;

Offline BOFH

  • Sr. Hero Member
  • ******
  • Posts: 2409
  • Karma: +112/-140
It appears that the VeraPlus actually has a 'HUE plugin' baked into it's firmware that is supposed to connect to the HUE hub. However, work is underway on an update to the HUE integration which hopefully will bring some solace.
Vera3 UI5 UI7 Edge Plus
Trane TZEMT400AB32 | Schlage BE369 FE599 | GE 45601 45602 45603 45604 45606 45609 45631 | Intermatic HA01C HA03C HA05C HA07C CA600 CA3000 | Aeon DSC06106 | Telguard GDC1 | Foscam FI8910W FI8905W FI9821W | D-Link 930L | Wanscam JW0011 | ZModo ZPIBH13W

Offline integlikewhoa

  • Master Member
  • *******
  • Posts: 5630
  • Karma: +157/-382
I am getting bored of these posters moaning about using Betas which in turn break some or all functionality.

mbrihed, did you take a backup?
Have you restored it?

The problem is 99% of anything related to vera is considered BETA if not by the creator then by the users. I even hear most referring to alpha.

Now lets look at what is really the responsibility of VERA or Mios themselves. Most plugins if not all were not originally made by Vera's team. Some have been taken over but not many. Logic done by PLEG or LUA as stock scenes don't cut it. So there is not much that is really considered VERA besides hardware and UI. We all know there is no shortage of UI complaints and most will agree that AltUI is the replacmanet which leaves vera not doing so well at that either. Since they haven't rolled out a any updates (beta or not) in around 5 months they are not gaining much ground either.

That leads us into hardware, Z-wave is farily stable with only a few devices that people complain about, routing issues and such. Now that they have had Bluetooth Wifi, and Zigbee out on the PLUS for around 4 months support for devices has been unchanged (again no updates). Wifi is crippled without 5ghz, no connecting edge to your network via wifi. Zigbee support is non existent so far, and Bluetooth is the same.

So along your lines of moaning what is a valid complaint?

Vera's Energy plugin?   

Offline integlikewhoa

  • Master Member
  • *******
  • Posts: 5630
  • Karma: +157/-382
It appears that the VeraPlus actually has a 'HUE plugin' baked into it's firmware that is supposed to connect to the HUE hub. However, work is underway on an update to the HUE integration which hopefully will bring some solace.

 ;D Probley will be a fix in the next update.  ;)

Offline niharmehta

  • Sr. Member
  • ****
  • Posts: 377
  • Karma: +17/-0
HUE made API / Auth changes that affected many 3rd party integration.  Check  FB, Reddit, and other sites. Many third party integrations broke.  Apparently already authenticated devices work until they have to re-authenticate. 

Vera should have been ahead if this as its not a surprise, however, at least it explains what happened to you.
2x VeraLite; 2xTrane Tstats; 45 x Switches/Dimmers/Appliance Modules; 4x Everspring Water Sensors; DSC Integration; 2 x Zwave Door Locks; 1x Ted5K; 1x Rainforest Eagle; Onkyo AVR; 6x Squeezebox;