Author Topic: Camera[s] - Best Practices/Use/Issues  (Read 883 times)

Offline CudaNet

  • Hero Member
  • *****
  • Posts: 1401
  • Karma: +42/-10
  • Chimichanga !
Camera[s] - Best Practices/Use/Issues
« on: June 13, 2016, 12:42:06 pm »
Was hoping to discuss camera support and best practices... I'm running on an Ipad Pro, latest IOS and latest HomeWave version..
I attempted to add some camera's and I'm sure I must be doing something incorrect.

[1] Added 4 cameras, all of which are direct to my Blue Iris server, not openLuup or an MCV product.
Using the add camera, each camera is configured as follows.

- ip:port
- mjpg/[camera name]/video.mjpg
- no username
- no password

[2] Cameras worked briefly then stopped refreshing...
[3] If I long press the image, it appears to refresh and then stops again after a few seconds.
[4] Same issue on 2nd and 3rd gen iPads.

Out of curiosity, I added a web tile using http://ip:port/mjpg/cameraName/video.mjpg and it worked perfectly except it's a small frame of a much larger image.. Same works perfectly within a browser.



Is this an issue with perhaps my BI server ? A configuration issue on my part ? Certainly I'm not tasking the system as I'd expect the clickable image to only refresh as often as HomeWave refreshes. Of course I'd expect it to refresh at a much faster rate when the image is clicked and expanded for view.

Thoughts, advice from others... Camera's are Hikvision and Dahua (PTZ).

Much appreciated...
openLuup, AltUI, Zway and HomeWave, enough said...

Offline intveltr

  • Moderator
  • Hero Member
  • *****
  • Posts: 1722
  • Karma: +100/-5
Re: Camera[s] - Best Practices/Use/Issues
« Reply #1 on: June 14, 2016, 06:21:34 am »
There's probably an issue in the app's network code.  If it encounters an error it will often just give up, hence the frozen image.  I'll look into improving it.
HomeWave is available in the App Store!  Turn your iPhone/iPad into an easy-to-use remote control for Vera.

Offline CudaNet

  • Hero Member
  • *****
  • Posts: 1401
  • Karma: +42/-10
  • Chimichanga !
Re: Camera[s] - Best Practices/Use/Issues
« Reply #2 on: June 14, 2016, 12:17:43 pm »
I can certainly turn on some logging and share that if it helps isolate the issue. Just let me know how I can help...

There's probably an issue in the app's network code.  If it encounters an error it will often just give up, hence the frozen image.  I'll look into improving it.
openLuup, AltUI, Zway and HomeWave, enough said...