Author Topic: Failed to save system configuration  (Read 16541 times)

Offline ranneman

  • Full Member
  • ***
  • Posts: 141
  • Karma: +7/-0
Re: Failed to save system configuration
« Reply #45 on: January 14, 2017, 07:01:39 am »
Hi, running the latest firmware 1.7.2414 on VeraPlus and can confirm that this has not been fixed yet (at least not in my case). I use the previously mentioned workaround by using AltUI (which I think is easier than downgrading). Have been doing some testing just out of curiosity to find that if I want to add or remove a device to a scene I still get this same error. I can actually maintain LUA in scene and save it, that will not return the error. So looks like we have to wait for a final fix.
Vera lite UI7 Europe, Vera Plus, Zwave.me switches/dimmers, Zwave.me plus multi switch, Fibaro switches and multi sensors, Everspring sensors motion, temp., humidity. Honeywell Evohome, Greenwave, Sonos, Brel shades, RFXCOM, MiLights, Alexa.

Offline Jukka

  • Jr. Member
  • **
  • Posts: 73
  • Karma: +0/-0
Re: Failed to save system configuration
« Reply #46 on: January 16, 2017, 08:55:37 am »
I have used Vera3 UI5 for several years and have been quite happy with it. Everything is working..

I decided to move to Vera+ with firmware 1.7.2414. I purchased it last spring but didn?t take it in use because of problems described here in the forum. Now I decided that I have to try it.
 
It is working but I can?t add my automation scenes to it.

I should have read these messages before I created my second scene where I added LUA code to trigger section. It can?t be saved, Vera will think for a couple of minutes, then say: Failed to save system configuration. The scene does not save and it is not visible in the scene list.

If I try creating the scene again without LUA code in trigger section and save it, it says: Scene name must be unique. As if the scene was in fact created but it is not visible in the scene list. I changed the name and saved it. Again same information: Failed to save system configuration but now I got new visible scene. So is that information coming from the invisible scene or form new just created scene. Where is the first created invisible scene and how can I deleted it?

I don?t want to make new scenes to test them if I can?t delete them if they have errors..

So now I am without automation and have to wait next firmware to fix these problems..

Offline XA44Owq26HxCq88

  • Full Member
  • ***
  • Posts: 144
  • Karma: +0/-1
Re: Failed to save system configuration
« Reply #47 on: January 16, 2017, 09:09:54 am »
Just an FYI, I eventually got a Vera Tech to look at my controller via the remote access function. It appears that whatever he did fixed the problem. I did not get an explanation on what he did, but I can now deactivate a scene that has Lua code in it without "commenting" the lua code within.

So, help is on the way I would assume in the next revision of the firmware?

Offline Jukka

  • Jr. Member
  • **
  • Posts: 73
  • Karma: +0/-0
Re: Failed to save system configuration
« Reply #48 on: January 19, 2017, 02:56:52 am »
I was too hasty on my previous post. I managed to get all my scenes working when I found how to do it (bypass that save error on lua codes on triggers section) and put my code to Finish the Scene, Also, execute the following Luup code. It seems that almost everything is working again with my ?new? Vera+ (still had to do more testing.. and some scenes to do). So I am quite happy now.

But can someone explain what is the difference, if I put lua code to:
1) Triggers section, Luup Event or
2) I put the same code to Finish the Scene, Also, execute the following Luup code.

Are they executed in different order and is it affecting how Step 2 (Device Actions) are executed?

Offline rafale77

  • Hero Member
  • *****
  • Posts: 1345
  • Karma: +67/-23
Re: Failed to save system configuration
« Reply #49 on: January 22, 2017, 12:11:42 am »
The lua code in the trigger is run only if that given trigger is being used. For scene with multiple triggers, you can customize the behavior of the scene using the trigger lua. One example for me is a TTS scene where it announces different door names when different doors are being opened using the same scene.
The scene lua is executed no matter what the trigger is.
openLuup (97 devices, 134 scenes, 20 apps) controlling HomeAss + VeraPlus (138 zwave nodes, 8 Zigbee nodes, 205 devices, 20 scenes , 2 app) Bridged to Homekit and Alexa. VeraPlus ExtRooted!

Offline Jukka

  • Jr. Member
  • **
  • Posts: 73
  • Karma: +0/-0
Re: Failed to save system configuration
« Reply #50 on: January 22, 2017, 03:30:35 am »
Thanks rafale77 to explain that to me.

Now I have 3 different scenes to inform me which door is opened. When new firmware will fix that save problem I am going to change those scenes. It would be much cleaner to have only one scene for all doors (and it also consumes less valuable memory).

Offline Scott8586

  • Newbie
  • *
  • Posts: 8
  • Karma: +0/-0
Re: Failed to save system configuration
« Reply #51 on: January 22, 2017, 11:13:10 pm »
This is a serious bug!  Do we have any sort of estimate on even a beta version to fix this issue?

Offline CDL

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
Re: Failed to save system configuration
« Reply #52 on: January 25, 2017, 09:34:43 pm »
I Began getting "Failed to save system configuration" error when trying to modify a scene.

Scene name was "Front porch & garage light off"
Got rid of the "&" and changed scene name to: "Front porch, garage light off"
It Worked OK then.

I am guessing the problem may be related to how HTML special characters are encoded. I have had similar problems using special characters before. It may be safer to use only letters and numbers for device and scene names.
« Last Edit: January 26, 2017, 10:56:30 am by CDL »

Offline fabstar81

  • Full Member
  • ***
  • Posts: 122
  • Karma: +2/-0
Re: Failed to save system configuration
« Reply #53 on: January 27, 2017, 01:47:16 am »
this has noting to do with it. my scene is called slapie and any change i make, even to other scenes, will give this error.

Offline XA44Owq26HxCq88

  • Full Member
  • ***
  • Posts: 144
  • Karma: +0/-1
Re: Failed to save system configuration
« Reply #54 on: January 27, 2017, 08:03:48 am »
fabstar81,

Check your other scenes that have LUUA code in them. I've noticed that occasionally, for some unknown reason, code gets corrupted.  Even if you didn't touch the other scenes. That might be your issue.

Offline Netzero

  • Sr. Newbie
  • *
  • Posts: 29
  • Karma: +0/-2
Re: Failed to save system configuration
« Reply #55 on: February 02, 2017, 01:33:15 pm »
This issue appears to be fixed, for me at least, with the beta version just released. I'm running veraedge.
Vera user since 2013
Currently running VeraEdge

Offline ember1205

  • Sr. Member
  • ****
  • Posts: 416
  • Karma: +5/-21
Re: Failed to save system configuration
« Reply #56 on: February 10, 2017, 07:29:09 pm »
fabstar81,

Check your other scenes that have LUUA code in them. I've noticed that occasionally, for some unknown reason, code gets corrupted.  Even if you didn't touch the other scenes. That might be your issue.

I had a bunch of LUA code get corrupted and was having this issue. I restored from backup and things seem fine now.

Offline markoe

  • Full Member
  • ***
  • Posts: 130
  • Karma: +4/-3
Re: Failed to save system configuration
« Reply #57 on: February 15, 2017, 11:58:36 pm »
This bug hit my system also. Vera plus and latest firmware. I can not disable A scene. I did an system restore to get Vera up and runnig. I start now holding my breath and wait for A fix.

Offline ember1205

  • Sr. Member
  • ****
  • Posts: 416
  • Karma: +5/-21
Re: Failed to save system configuration
« Reply #58 on: February 16, 2017, 05:49:22 pm »
Mine is corrupted again

Offline RichardTSchaefer

  • Master Member
  • *******
  • Posts: 10091
  • Karma: +763/-142
Re: Failed to save system configuration
« Reply #59 on: February 16, 2017, 06:10:02 pm »
Make sure you call customer support and/or facebook  ... since feedback on the forums is not an official channel.