Author Topic: Unable to install GCal3 V2.2  (Read 1029 times)

Offline possum

  • Sr. Newbie
  • *
  • Posts: 23
  • Karma: +0/-0
Unable to install GCal3 V2.2
« on: June 26, 2016, 11:28:21 am »
I am running a Vera Lite with UI5.

I have been running GCal3 V1.4 for many months but recently ran into a problem that you have apparently fixed (but haven't released yet). I discovered that in order to be able to incorporate this fix, it is necessary to upgrade to your latest version.

I created the Google calendar credentials a while ago and nothing has changed. I rechecked your latest installation instructions.

I have uninstalled V1.4, installed V2.2 and I consistently get an error message that says that "Startup Lua Failed". I have rebooted Vera multiple times and nothing seems to clear the problem. I copied the startup Log for the Gcal3 app and have attached it to this note. The log  file seems to indicate that it can't find a file dkjson.lua among other things.

Can you suggest anything?

Offline Stuart

  • Moderator
  • Hero Member
  • *****
  • Posts: 673
  • Karma: +68/-2
Re: Unable to install GCal3 V2.2
« Reply #1 on: June 26, 2016, 07:12:27 pm »
@possum

It looks like there is a problem with json.lua.  The file is there but it seems to be objecting to something.  I still have a UI5 vera that I test against and it works fine.   However there is no guarantee that the json.lua on your machine and the one on my machine are identical.

Do you have WINSCP or similar installed ?  If so - can you delete the file '/usr/lib/lua/json.lua' and  reboot.  GCal3 will then download the same json.lua file that I have used all along.

Let me know how you go.  If there is still a problem then we can dig deeper.

Also you could try uploading the two files here:

http://forum.micasaverde.com/index.php/topic,26692.msg284397.html#msg284397

I made some small changes to the startup sequence that may help if we need to debug further.

Offline possum

  • Sr. Newbie
  • *
  • Posts: 23
  • Karma: +0/-0
Re: Unable to install GCal3 V2.2
« Reply #2 on: June 28, 2016, 12:00:33 pm »
I deleted the file json.lua, restarted Vera, uninstalled V1.4, installed V2.2 and everything seems to be working fine.

I continue to be amazed at the knowledge/skill that is required to make this work.

thanks again for your help.

Offline Stuart

  • Moderator
  • Hero Member
  • *****
  • Posts: 673
  • Karma: +68/-2
Re: Unable to install GCal3 V2.2
« Reply #3 on: June 28, 2016, 01:37:07 pm »
Details matter sometimes.  Versions prior to 2.0 needed to be uninstalled prior to 2.0+ being installed -- although I'd be surprised if there was an interaction BUT ..... if you had both V1.4 and V2.2 installed at the same time then it's possible there was a conflict.

Sometimes the mysteries of vera seem best explained by the phases of the moon .......

I'd recommend the patched files (V2.3b) that I mentioned - as it handles "funny" situations a little more gracefully.  I'll get around to releasing V2.3 in a week or so (I'm not anticipating any changes).


Glad it's all up and running.