We have moved at community.getvera.com

Author Topic: Program Logic 8.19 (Next Gen) released  (Read 20936 times)

Offline Sender

  • Hero Member
  • *****
  • Posts: 973
  • Karma: +552/-467
  • Sr. manager of my Vera
Re: Program Logic 8.11 (Next Gen) released
« Reply #15 on: July 10, 2016, 09:41:19 am »
So the saving bug is also present in the next ui?
Good firmware is more important than good karma. (and this costed me lots of Karma)

Offline RichardTSchaefer

  • Moderator
  • Master Member
  • *****
  • Posts: 10091
  • Karma: +764/-143
Re: Program Logic 8.11 (Next Gen) released
« Reply #16 on: July 10, 2016, 09:47:28 am »
The saving bug has nothing to do with PLEG.

Offline Sender

  • Hero Member
  • *****
  • Posts: 973
  • Karma: +552/-467
  • Sr. manager of my Vera
Re: Program Logic 8.11 (Next Gen) released
« Reply #17 on: July 10, 2016, 09:49:36 am »
The saving bug has nothing to do with PLEG.

Thank you Richard
Good firmware is more important than good karma. (and this costed me lots of Karma)

Offline robertgabrielson

  • Sr. Newbie
  • *
  • Posts: 27
  • Karma: +0/-0
Re: Program Logic 8.11 (Next Gen) released
« Reply #18 on: July 10, 2016, 11:41:05 am »
Richard,

Mine went through the auto update and I get a 'startup lua failed' error.  Working fine until this event.

Here is what the log shows.

01   07/10/16 8:37:25.251   LuaInterface::CallFunction_Startup-1 device 49 function Initialize failed [string "module("L_ProgramLogicCEE", package.seeall)..."]:406: attempt to concatenate field '?' (a nil value) <0x77611520>
01   07/10/16 8:37:25.252   LuImplementation::StartLua running startup code for 49 I_ProgramLogicEG.xml failed <0x77611520>

Ive tried manually updating again and rolling back, same issue.  Any ideas?

Offline daemondazz

  • Jr. Member
  • **
  • Posts: 96
  • Karma: +4/-0
Re: Program Logic 8.11 (Next Gen) released
« Reply #19 on: July 10, 2016, 12:24:25 pm »
Richard,

Mine went through the auto update and I get a 'startup lua failed' error.  Working fine until this event.

Here is what the log shows.

01   07/10/16 8:37:25.251   LuaInterface::CallFunction_Startup-1 device 49 function Initialize failed [string "module("L_ProgramLogicCEE", package.seeall)..."]:406: attempt to concatenate field '?' (a nil value) <0x77611520>
01   07/10/16 8:37:25.252   LuImplementation::StartLua running startup code for 49 I_ProgramLogicEG.xml failed <0x77611520>

Ive tried manually updating again and rolling back, same issue.  Any ideas?

Have a look at http://forum.micasaverde.com/index.php/topic,38329.msg286575.html#msg286575

Offline RichardTSchaefer

  • Moderator
  • Master Member
  • *****
  • Posts: 10091
  • Karma: +764/-143
Re: Program Logic 8.11 (Next Gen) released
« Reply #20 on: July 10, 2016, 12:26:22 pm »
Quote
LuaInterface::CallFunction_Startup-1 device 49 function Initialize failed [string "module("L_ProgramLogicCEE", package.seeall)..."]:406: attempt to concatenate
That was a bug I introduced ... to make it worse it is only a debugging statement ... It's fixed in the next release.
You can patch your PLEGs as follows:

1) Refresh the browser (to get the latest data)
2) For each of your PLEG's do the following:
    a) Open the Advanced Tab
    b) In the Schedules variable, replace any null with two single quotes ''.
3) Restart your Vera.


Offline robertgabrielson

  • Sr. Newbie
  • *
  • Posts: 27
  • Karma: +0/-0
Re: Program Logic 8.11 (Next Gen) released
« Reply #21 on: July 10, 2016, 12:27:55 pm »
Got rid of the error by removing PLEG and reinstalling - but unfortunately lost my setup.  Any way to restore this?  Ive tried the 2 very old backup files i have and they both give me a 'Error Parsing Data'

Offline Sender

  • Hero Member
  • *****
  • Posts: 973
  • Karma: +552/-467
  • Sr. manager of my Vera
Re: Program Logic 8.11 (Next Gen) released
« Reply #22 on: July 10, 2016, 12:29:19 pm »
The saving bug has nothing to do with PLEG.

Richard, to be absolutely clear. If I currently experience the saving bug. Will installing pleg next ui and ui7 beta last release solve this saving bug?
Good firmware is more important than good karma. (and this costed me lots of Karma)

Offline RichardTSchaefer

  • Moderator
  • Master Member
  • *****
  • Posts: 10091
  • Karma: +764/-143
Re: Program Logic 8.11 (Next Gen) released
« Reply #23 on: July 10, 2016, 12:31:15 pm »
I do not know ... There is no way for me to test ... since I do not have the problem.

Offline Sender

  • Hero Member
  • *****
  • Posts: 973
  • Karma: +552/-467
  • Sr. manager of my Vera
Re: Program Logic 8.11 (Next Gen) released
« Reply #24 on: July 10, 2016, 03:51:42 pm »
I do not know ... There is no way for me to test ... since I do not have the problem.

Can I do something to help you test on my unit?
Good firmware is more important than good karma. (and this costed me lots of Karma)

Offline zedrally

  • Hero Member
  • *****
  • Posts: 1224
  • Karma: +15/-5
  • Black Cat Control Systems
Re: Program Logic 8.11 (Next Gen) released
« Reply #25 on: July 10, 2016, 06:17:41 pm »
Any new triggers I create do not work. anything prior to the update was OK.
Is there a solution to this?
Living in the Land of Oz, give me a vegemite sandwich. Home Seer, Vera Lite & Edge, Popp, Black Cat Smart Hub & Vera G, Black Cat Lite 1 & 2's a Black Cat Dimmer or 2, Fantem Tec and then some  Black Cat Cat's Eye PIR's & Door-Window Sensors, RFXComm, Broadlink RMPro & Mini plus a Z-UNO or 2.

Offline Versed

  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
Re: Program Logic 8.11 (Next Gen) released
« Reply #26 on: July 10, 2016, 07:33:35 pm »
As a new user ... you need to know that you should ALWAYS post a PDF of your Status report (There are plenty of free PDF printers out there to print an Web window into a PDF file).

Then in your message you should describe the problem in the context of the inputs and conditions you are having a problem with.

There very well could be a problem in Next-Gen ... It was a massive amount of code change, to both the UI and run-time.

Hi Richard,
My apologies , please see the attachment.
I don't receive any status changes of my motion sensors when using PLEG. (No last true or False).
The sensors works perfect when using the standard Vera app. (Movement is detected and I can switch on a Lamp).
Please let me know how I can receive the data in PLEG.

In the previous version it did work (at least for one sensor, I didn't use the other sensors at that time)

Kind regards

I have this exact same problem.  My motion detectors are not working as triggers for PLEG, but they work fine as triggers for regular Vera scenes.  I've attached a PDF that shows the motion detector with no 'last true' or 'last false'.

By the way, love the new editor!

guest141700

  • Guest
Re: Program Logic 8.11 (Next Gen) released
« Reply #27 on: July 10, 2016, 07:57:34 pm »
RTS is aware of the motion sensors triggering not working in 8.11, and has already setup a fix for it. (and other issues).I'm sure it will be released as soon as MCV reviews it. Everyone having problems with PLEG, please give RTS a little time to fix things. Unlike MCV he is very aware of user issues and responds quickly. Most of the problems with PLEG were caused by MCV. RTS is only trying to correct them. That is my observation anyway. If I did not have PLEG my Vera systems would be totally useless to me.

Offline zedrally

  • Hero Member
  • *****
  • Posts: 1224
  • Karma: +15/-5
  • Black Cat Control Systems
Re: Program Logic 8.11 (Next Gen) released
« Reply #28 on: July 10, 2016, 07:59:41 pm »
If I did not have PLEG my Vera systems would be totally useless to me.


Amen to that.
Living in the Land of Oz, give me a vegemite sandwich. Home Seer, Vera Lite & Edge, Popp, Black Cat Smart Hub & Vera G, Black Cat Lite 1 & 2's a Black Cat Dimmer or 2, Fantem Tec and then some  Black Cat Cat's Eye PIR's & Door-Window Sensors, RFXComm, Broadlink RMPro & Mini plus a Z-UNO or 2.

Offline paros

  • Full Member
  • ***
  • Posts: 205
  • Karma: +6/-1
Re: Program Logic 8.11 (Next Gen) released
« Reply #29 on: July 11, 2016, 02:41:51 am »
My PLEG was totaly reset with this new version (everything I have made with PLEG has dissappeared).
I have no custom backups for PLEG, need advise!

I got this message: Program Logic Event Generator : Install Program Logic Core Plugin
Then I uninstalled and reinstalled PLC.

UPDATE: It seems like the data is available under Advanced: ConditionMap / ObjectStatusMap / Actions / etc

How do I restore this and how do i get rid of the error message?
« Last Edit: July 11, 2016, 02:45:42 am by paros »