Author Topic: Fibaro FGS-223 second channel not working with Vera Edge  (Read 17150 times)

Offline rscheer

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
Fibaro FGS-223 second channel not working with Vera Edge
« on: August 27, 2016, 05:17:11 am »
I bought a new Vera Edge system and some devices. Everything seem to work properly, I have only one issue left. I have a Fibaro FGS-223 device which should be able to switch two independent lights. I connected the device and added it to my Vera system. I see a device and gave it a name. I also see an "_Appliance module" and an "_Appliance module 1" device. The first has altid e1, the seconds altid e2. Using google, it seems the first device is the master, the e1 is the slave for the first channel and e2 is the slave for the second channel. Using the master device, I can operate the first channel. Operating the e1 or e2 device in Vera does not have any effect, only in the Vera UI it shows the devices are on.
When I use the hardware interface of the FGS-223 device, I can switch the first light (Q1) using the S1 connector and the second light (Q2) using the S2 connector.

So my question: how can I control the second channel using the Vera UI?

Offline Jodelo

  • Newbie
  • *
  • Posts: 12
  • Karma: +0/-0
Re: Fibaro FGS-223 second channel not working with Vera Edge
« Reply #1 on: September 04, 2016, 02:59:48 pm »
I have exactly the same problem. i have no idea how i can fix this
have you got any solutions yet?

Offline RitterIwan

  • Sr. Newbie
  • *
  • Posts: 23
  • Karma: +0/-0
Re: Fibaro FGS-223 second channel not working with Vera Edge
« Reply #2 on: September 05, 2016, 03:50:44 am »
It's exactely the same to me. 2nd channel won't be triggered by VERA Edge.

Offline Jodelo

  • Newbie
  • *
  • Posts: 12
  • Karma: +0/-0
Re: Fibaro FGS-223 second channel not working with Vera Edge
« Reply #3 on: September 09, 2016, 05:17:44 pm »
i send a message to Vera support
Maybe you can do the same
maybe they give it more priority when there ar more messages

Offline RitterIwan

  • Sr. Newbie
  • *
  • Posts: 23
  • Karma: +0/-0
Re: Fibaro FGS-223 second channel not working with Vera Edge
« Reply #4 on: September 12, 2016, 08:32:30 am »
I already dropped a message to Vera support, too.

By having a closer look to the log of the z-wave commnunication between the Vera and the FGS-223 I found out this so far:

1)
The VERA uses the wrong command class to communication with the Fibaro. For the childs (2nd channel) it uses SWITCH_MULTILEVEL (0x26 / 38d) instead of SWITCH_BINARY (0x25 / 37d).

I conviced the VERA to use SWITCH_BINARY by removing the value 38 from the capabilities.
But then we have he next issue:

2)
Per default VERA includes the Fibaro in secure mode. Which makes sense for 5th GEN / ZWAVE device, generally.
But it sends the command to swich the 2nd channel without encryption. The fibaro - of course - expects an encryption command and doesn't move when getting commands the one-secure way.
In more detail:
To swich the 2nd channel the command class MULTI_CHANNEL and the command MULTI_CHANNEL_CMD_ENCAP (0x60 x0d) has to be used with a embedded SWITCH_BINARY. This in turn has to be encapsulated in a CLASS_SECURITY command to send it the encypted way.
But VERA transmits only a MULTI_CHANNEL / MULTI_CHANNEL_CMD_ENCAP  with a SWITCH_BINARY without the neccessary encryption.


From from my point of view there are two bugs.
Until these bugs a fixed I could imagine as a work-around it works when the FGS-223 will be included the non-secure way.
Does anybody know how the set the VERA into the non-secure inclusion mode?



Offline RitterIwan

  • Sr. Newbie
  • *
  • Posts: 23
  • Karma: +0/-0
Re: Fibaro FGS-223 second channel not working with Vera Edge
« Reply #5 on: September 19, 2016, 07:42:16 am »
I got the feedback from support that this device will be supported in "near future". The fixes will be included in one of the next firmware updated. But they don't know in which ne.

Offline Kullematz

  • Full Member
  • ***
  • Posts: 221
  • Karma: +2/-1
Re: Fibaro FGS-223 second channel not working with Vera Edge
« Reply #6 on: September 20, 2016, 12:15:10 pm »
The device is even not working on VeraLite/UI5/1.5.672.

Offline RitterIwan

  • Sr. Newbie
  • *
  • Posts: 23
  • Karma: +0/-0
Re: Fibaro FGS-223 second channel not working with Vera Edge
« Reply #7 on: September 21, 2016, 10:23:44 am »
I got my VERA already with UI7. So I'm not really familiar with UI5. Is UI5 able to handle ZWAVE+ (5th Gen) devices at all?

Offline Kullematz

  • Full Member
  • ***
  • Posts: 221
  • Karma: +2/-1
Re: Fibaro FGS-223 second channel not working with Vera Edge
« Reply #8 on: September 21, 2016, 11:39:23 am »
IIs UI5 able to handle ZWAVE+ (5th Gen) devices at all?

It's not fully compatable with Zwave+, but I have some Zwave+ devices and they do their jobs quite well and as said in the manual, this device is "Compatible with any Z-Wave or Z-Wave+ Controller".

Online Cor

  • Hero Member
  • *****
  • Posts: 1113
  • Karma: +4/-4
Re: Fibaro FGS-223 second channel not working with Vera Edge
« Reply #9 on: October 10, 2016, 03:52:29 pm »
Oh , that is great!

Just installed this relays , and now this problem. :-\

Hopefully it is quickly resolved

Cor

Offline RitterIwan

  • Sr. Newbie
  • *
  • Posts: 23
  • Karma: +0/-0
Re: Fibaro FGS-223 second channel not working with Vera Edge
« Reply #10 on: October 12, 2016, 10:02:24 am »
Hi guys,

has anybody got an answer from the support when the bug(s) that prevent the FGS-223 to work properly will be fixed?


Offline Sender

  • Hero Member
  • *****
  • Posts: 760
  • Karma: +532/-441
  • Sr. manager of my Vera
Re: Fibaro FGS-223 second channel not working with Vera Edge
« Reply #11 on: October 12, 2016, 02:03:31 pm »
I got the feedback from support that this device will be supported in "near future". The fixes will be included in one of the next firmware updated. But they don't know in which ne.

That is the standard answer from vera. And that can add up to over a year.
Good firmware is more important than good karma. (and this costed me lots of Karma)

Offline TheClown44

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
Re: Fibaro FGS-223 second channel not working with Vera Edge
« Reply #12 on: October 18, 2016, 02:19:59 am »
Hi guys.

I just sent a message to support too.
Same problem for me... of course.
 :-\


Offline RubbrDug

  • Newbie
  • *
  • Posts: 16
  • Karma: +0/-2
Re: Fibaro FGS-223 second channel not working with Vera Edge
« Reply #13 on: October 29, 2016, 11:37:42 am »
Just installed one of those and the next is on order. Ran into the same problem as everyone else and came here for help. :-[

[Edit] Sent a message to support as well [/Edit]
« Last Edit: October 29, 2016, 11:44:55 am by RubbrDug »

Offline Sender

  • Hero Member
  • *****
  • Posts: 760
  • Karma: +532/-441
  • Sr. manager of my Vera
Re: Fibaro FGS-223 second channel not working with Vera Edge
« Reply #14 on: October 29, 2016, 12:03:51 pm »
Most probably you will get this answer (as I did):

We are aware of this issue and actively working on this to reach a common ground on the specs of this device. And because we will have an intermediary firmware release which will contain some significant z-wave mesh mechanics, we can?t further work on FGS-223 until we have this firmware out first. Who knows, it might even work correctly after this intermediary firmware. But I can?t tell for sure.
If you are familiar with Luup code, PLEG and virtual switches. I have a temporary solution for you.
You can basically use these two Luup line codes, for turning the second child on/off . For ease of use you can include this code in a PLEG and to a virtual switch.


LUUP CODE Attached.

I asked when the new firmware will come out (since asking support will probablt not bash my karma :-) And the answer was in line with Vera's strategy:
A whole team is working on the new firmware.
As far as I know the quality assurance department is testing it at the moment and after that we will release a beta firmware.
I can?t offer you a ETA, but I think it should be released soon because our testers are already working on it.


BTW also the second channel has the "can't detect device" bug...

So tired of this all... A "team" usually is more than 1 person... but int this case I really doubt...
Good firmware is more important than good karma. (and this costed me lots of Karma)