Author Topic: Fibaro FGS-223 second channel not working with Vera Edge  (Read 19285 times)

Offline RubbrDug

  • Newbie
  • *
  • Posts: 16
  • Karma: +0/-2
Re: Fibaro FGS-223 second channel not working with Vera Edge
« Reply #15 on: October 29, 2016, 03:58:48 pm »
Well, I am no big coder, but that worked as a fix for me!

Thanks for posting this!

Offline Sender

  • Hero Member
  • *****
  • Posts: 762
  • Karma: +532/-441
  • Sr. manager of my Vera
Re: Fibaro FGS-223 second channel not working with Vera Edge
« Reply #16 on: November 03, 2016, 12:04:26 pm »
For the non-techies written down from A-Z:

Create 2 Virtual switches (via virtual switch app):
FGS-223-e2 VS
FGS-223-e1 VS

Lookup the altid of the master device created by vera for the real FGS-223 device (in my example 141)

Create 4 scene's: select ON or OFF on Virtual switch device as a trigger, in step 1 (Whenever VirtualSwitch?A device is turned on or off), skip on step2 by pressing next, and on step 3, choose Also, execute the following Luup code: and put the code for ON.

Virtual Switch: FGS-223-e2 VS
Scene triggered with virtual switch "FGS-223-e2 VS" ON
luup.call_action("urn:micasaverde-com:serviceId:ZWaveNetwork1", "SendData", {Node=141, Data="0x60 0xd 0x2 0x2 0x25 0x1 0x63"}, 1)

Scene triggered with virtual switch "FGS-223-e2 VS" OFF
luup.call_action("urn:micasaverde-com:serviceId:ZWaveNetwork1", "SendData", {Node=141, Data="0x60 0xd 0x2 0x2 0x25 0x1 0x0"}, 1)


Virtual Switch: FGS-223-e1 VS
Scene triggered with virtual switch "FGS-223-e1 VS" ON
luup.call_action("urn:micasaverde-com:serviceId:ZWaveNetwork1", "SendData", {Node=141, Data="0x60 0xd 0x1 0x1 0x25 0x1 0x63"}, 1)

Scene triggered with virtual switch "FGS-223-e1 VS"
luup.call_action("urn:micasaverde-com:serviceId:ZWaveNetwork1", "SendData", {Node=141, Data="0x60 0xd 0x1 0x1 0x25 0x1 0x0"}, 1)

Optionally you can hide the orignal device.

And the power consumption is not given.
Good firmware is more important than good karma. (and this costed me lots of Karma)

Offline barabasj65

  • Newbie
  • *
  • Posts: 18
  • Karma: +0/-1
Re: Fibaro FGS-223 second channel not working with Vera Edge
« Reply #17 on: November 20, 2016, 04:51:31 am »
Thanks Sender, great job, great guide!
The switch works, but the display in UI7 don't recognizes the state's change of the switch when use the S1 or S2 manual switch.
E.g.
FGS-223-E1 VS is OFF, via manual switch S1 I switch to ON, on the display of UI7 the VS still shows OFF.
In brief, the state of the VS shown in UI7 is not relevant.

Offline Sender

  • Hero Member
  • *****
  • Posts: 762
  • Karma: +532/-441
  • Sr. manager of my Vera
Re: Fibaro FGS-223 second channel not working with Vera Edge
« Reply #18 on: November 20, 2016, 06:33:06 am »
Hi, yes, I know... Vera also knows... and as always probably it will be fixed only if more than 50 people start complaining via support tickets.
Good firmware is more important than good karma. (and this costed me lots of Karma)

Offline Nailer00

  • Newbie
  • *
  • Posts: 11
  • Karma: +0/-2
Re: Fibaro FGS-223 second channel not working with Vera Edge
« Reply #19 on: November 23, 2016, 10:39:52 am »
Also having this issue, logging a ticket now  ::)

Offline save

  • Sr. Newbie
  • *
  • Posts: 26
  • Karma: +0/-0
Re: Fibaro FGS-223 second channel not working with Vera Edge
« Reply #20 on: December 05, 2016, 12:16:13 pm »
Hi,

I send this issue long time ago to mios support and We are still waiting the solution.  The aswer from mios was, it will be fixed in the next fiimware but there isn?t any new since months ago.

I have a customer with 10 Fibaro devices installed, At the moment the customer think  the system is a sheet and it's going kill me. Is there any way to change variables of the device in the VERA  to solve it?

Regards


Offline Sender

  • Hero Member
  • *****
  • Posts: 762
  • Karma: +532/-441
  • Sr. manager of my Vera
Re: Fibaro FGS-223 second channel not working with Vera Edge
« Reply #21 on: December 05, 2016, 12:49:02 pm »
I hate to say it... but that is what it is... Vera... I can point you to a lot of places on this forum where vera promises solutions...
Good firmware is more important than good karma. (and this costed me lots of Karma)

Offline MadsBrodersen

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
Re: Fibaro FGS-223 second channel not working with Vera Edge
« Reply #22 on: December 05, 2016, 04:19:46 pm »
Hi guys, I'm just starting to look into this world of home automation and fell into this newbie pitfall of not doing my research well enough before buying. I'm also trying to use a FGS223 controlled by an Edge.

I've managed to get it working using the lua code in this thread but I just have one question: Are there any way to set up a trigger for the other switch (S2) as I would like to control it by both a wall switch connected to S1 and a motion detector connected to S2?

Btw. I've also written support telling them that I need them to fully support this device.

Regards.

Offline EyalLefler

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
Re: Fibaro FGS-223 second channel not working with Vera Edge
« Reply #23 on: December 11, 2016, 07:10:29 am »
Hi,
Is the new beta firmware version fix this issue?

Offline ceel

  • Newbie
  • *
  • Posts: 7
  • Karma: +0/-0
Re: Fibaro FGS-223 second channel not working with Vera Edge
« Reply #24 on: December 14, 2016, 01:35:51 pm »
Did anyone try the December 12 firmware Version 7.0.19 (1.7.902/1.7.2406/1.7.2414) with the FGS-223 yet?

Offline Sender

  • Hero Member
  • *****
  • Posts: 762
  • Karma: +532/-441
  • Sr. manager of my Vera
Re: Fibaro FGS-223 second channel not working with Vera Edge
« Reply #25 on: December 14, 2016, 01:44:38 pm »
Yes, nothing changed and case reopened without response.
Good firmware is more important than good karma. (and this costed me lots of Karma)

Offline gilcd85

  • Newbie
  • *
  • Posts: 6
  • Karma: +0/-0
Re: Fibaro FGS-223 second channel not working with Vera Edge
« Reply #26 on: December 15, 2016, 04:16:53 pm »
Hi All, I am seeing the issue of only one switch working with my Vera Plus and FGS-223 as well. As part of the initial testing I ran before I found this thread, I tried deleting two FGS-223 controllers I added to my network and wasn't able to unpair or delete any of the parent or child devices. Is anyone seeing the same issue? Is there a way around this without a factory reset?

Thanks!

Offline Sender

  • Hero Member
  • *****
  • Posts: 762
  • Karma: +532/-441
  • Sr. manager of my Vera
Re: Fibaro FGS-223 second channel not working with Vera Edge
« Reply #27 on: December 22, 2016, 03:04:16 am »
I think there is a solution! With the credits going to Alex from Vera. He tested and sent me a mail. I have changed some text and layout to make it better readable. Here it is and I can confirm it works!

Only 1 drawback, but not sure if the device is supposed to work this way: The power is only reported on the master device and not on the slaves. For me this is not an issue. I will try to reach Fibaro and ask if this is possible in the module design to report this for 2 sperate channels (slaves) per channel.

I was able to control the children devices via UI7 Web Interface by setting the following variable on each child device.
Click on the ">" button of the device, go to Advanced → New service, enter the service id, variable, value and "Add". Then hit Reload Engine:
Service: urn:micasaverde-com:serviceId:ZWaveDevice1
Variable: SetTargetCommandClass
Value: 37

Device is controllable in Vera via the nomal way... but

BUMP
Mail sent to Vera support again...
I have to come back on below problem. My enthusiasm is dead again. I do not see any power usage. I use on of the 2 child devices for a lamp and the other as a 'virtual' switch to remotely switch the Christmas tree (toggle).
I did a physical swap of the 223 device with the 221 device.

1.   I do not see power usage on the device.
2.   Even BIGGER problem: I do not receive any status feedback to vera when I switch local. So I can't use input 2 to toggle another device as Vera does not see it.

Why is this such a problem to support this new (and only being sold 2x1.5Kw) switch module? What will happen with Vera if only these new type of devices come out but not support is in Vera? How long will or can it take to support it? This way Vera is getting useless in time?

Can you help me (and the community) to support this device asap?

BUMP2

Can't detect device after 15-20 minutes (device works though)
« Last Edit: December 22, 2016, 04:45:54 am by Sender »
Good firmware is more important than good karma. (and this costed me lots of Karma)

Offline zedrally

  • Hero Member
  • *****
  • Posts: 903
  • Karma: +3/-0
  • Black Cat Controllers & Control Systems
    • Black Cat Control Systems
Re: Fibaro FGS-223 second channel not working with Vera Edge
« Reply #28 on: December 22, 2016, 03:24:22 pm »

Why is this such a problem to support this new (and only being sold 2x1.5Kw) switch module?


It's not the only one being sold, so lets correct that misinformation.
Depending on region there are other double relays available and one in particular that does work with UI7.


Look for Philio in the EU, they are sold in the US, but I am not aware of the brand, in AUS use Black Cat
« Last Edit: December 22, 2016, 03:28:47 pm by zedrally »
Living in the Land of Oz, give me a vegemite sandwich. Home Seer, Vera Lite & Edge, Popp, Black Cat Smart Hub & Vera G, Black Cat Lite 1 & 2's a Black Cat Dimmer or 2, then some  Black Cat Cat's Eye PIR's & Door-Window Sensors, Broadlink RMPro & Mini plus a Z-UNO or 2.

Offline Sender

  • Hero Member
  • *****
  • Posts: 762
  • Karma: +532/-441
  • Sr. manager of my Vera
Re: Fibaro FGS-223 second channel not working with Vera Edge
« Reply #29 on: December 22, 2016, 03:27:06 pm »

Why is this such a problem to support this new (and only being sold 2x1.5Kw) switch module?


It's not the only one being sold, so lets correct that misinformation.
Depending on region there are other double relays available and one in particular that does work with UI7.


Look for Philio in the EU, they are sold in the US, but I am not aware of the brand, in AUS us Black Cat

I meant the only fibaro 2x1.5kw being sold. 221 and 222 are mostly out of stock... 233 is the current model.
Good firmware is more important than good karma. (and this costed me lots of Karma)