Author Topic: Fibaro FGS-223 second channel not working with Vera Edge  (Read 10473 times)

Offline Sender

  • Hero Member
  • *****
  • Posts: 742
  • Karma: +532/-436
  • Sr. manager of my Vera
Re: Fibaro FGS-223 second channel not working with Vera Edge
« Reply #30 on: December 23, 2016, 02:59:18 am »
Update from MCV:
Regarding power useage I was able to see it on the parent device but not on the children devices because they didn?t report power usage via Z-Wave.
If you dont?t see any power usage on the parent device you might have an issue with wiring so you can check the device manual or contact Fibaro.
Regarding instant status report on the inputs , our development team is currently working on it.
You can try to remove the value 38 from Capabilities (and reload the engine) on the parent device as well as on the inputs and see if this will work.
The issue with can?t detect device is also related to capabilities. The device reports that it support CC Switch Multilevel and Vera is using this command class to poll it instead of CC Switch Binary.
Our development team will try to fix the issue but I don't have an ETA.

For me the capabilties were:
Master
211,156,1,4,16,1,L,R,B,RS,|34,37S,50:3,86,89,90S,91S,94,96S:4,112S,113:5,114,115,117S,122,133S,134,142S,152,

child 1
211,156,1,4,16,1,L,R,B,RS,|37,38,50,89,94,133,134,142,239,

child 2
211,156,1,4,16,1,L,R,B,RS,|37,38,50,89,94,133,134,142,239,

I removed the 38 and I will monitor behaviour

UPDATE1: Only Q1 channel is power monitored. The power is displayed on the master device.

UPDATE2: Removing 38 is not possible... It just comes back. In the meantime I received another mail:
After you have removed 38 from Capabilites from both children did you also reload the engine after each removal ?
You can exclude and re-include the device.
Then on the parent and each children do the following : click on the ?>? button for each device , go to Advanced → Variables and under Capabilities remove the value 38 , go to New Service and hit Reload Engine.
After the engine reloads hit Ctrl+F5 on your keyboard and check if 38 was removed.
If this doesn?t work then we need to wait until the bug is solved.

So...  wait for Vera...  :( ::) :-X :'(

UPDATE3:
I have found a workaround for the can't detect device and Instant Status Report.
You should remove value 38 from the parent device from the variable called MultiChCapabilites (then go to New Service and hit Reload Engine) and also remove value 38 from each child device (and also reload the engine , each time you remove it).
(I removed it from Capabilities as there is no MultiChCapabilites in the childs)
Also you should add the following service id , variable and value for both children and also Reload the Engine :
urn:micasaverde-com:serviceId:ZWaveDevice1
BasicSetCapabilities
00=F0,FF=O0

Done and I will observe

« Last Edit: December 24, 2016, 07:13:36 am by Sender »
Good firmware is more important than good karma. (and this costed me lots of Karma)

Offline Sender

  • Hero Member
  • *****
  • Posts: 742
  • Karma: +532/-436
  • Sr. manager of my Vera
Re: Fibaro FGS-223 second channel not working with Vera Edge
« Reply #31 on: December 24, 2016, 07:30:57 am »
I can confirm it fully works now!

The FGS-223 is working like a charm following above. Status is given in Vera, can control it, power usage on first channel...

Not 100% sure the can't detect device stays away because that may take a while. Will keep posted.

Good firmware is more important than good karma. (and this costed me lots of Karma)

Offline Z-Waver

  • Master Member
  • *******
  • Posts: 4406
  • Karma: +241/-120
Re: Fibaro FGS-223 second channel not working with Vera Edge
« Reply #32 on: December 24, 2016, 08:06:16 am »
Small victories.  :)

Offline Sender

  • Hero Member
  • *****
  • Posts: 742
  • Karma: +532/-436
  • Sr. manager of my Vera
Re: Fibaro FGS-223 second channel not working with Vera Edge
« Reply #33 on: December 24, 2016, 08:36:50 am »
Can't Detect Device comes back though...
Good firmware is more important than good karma. (and this costed me lots of Karma)

Offline Slater

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
Re: Fibaro FGS-223 second channel not working with Vera Edge
« Reply #34 on: December 26, 2016, 04:45:37 pm »
Sender, you rule! Thanks to this my setup is working with this device! Thank you sir.

Offline Veera

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
Re: Fibaro FGS-223 second channel not working with Vera Edge
« Reply #35 on: January 01, 2017, 05:16:13 am »
Hi
Thanks for the guide! I have now got the Child units to be able to control the switch but they don?t get an update wether the switch is on or off. I am rather new on the vera UI, is it possible for someone to explain a little bit more in detail regarding the following:
"Also you should add the following service id , variable and value for both children and also Reload the Engine :
urn:micasaverde-com:serviceId:ZWaveDevice1
BasicSetCapabilities
00=F0,FF=O0"

In my new service tab i have the following fields:
"New Service"
"New Variable"
"New Value"

What shall I put into these fields?
« Last Edit: January 01, 2017, 05:30:28 am by Veera »

Offline pj

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
Re: Fibaro FGS-223 second channel not working with Vera Edge
« Reply #36 on: January 02, 2017, 03:26:09 pm »
Hi you guys,
I also have this problem that the second channel of the FGS-223-ZW5 v3.2 does not work. I tried the described solutions but with me it does not seem to work.
I also have two of the predecessors of this switch, FGS-222-EN-A-v1.00, where one works fine, and the other one does have the same problems as described.
The one that works fine though has manual switches connected and all other ones (old and new, that don't work) don't have manual switches connected, I only use the relays to switch on lamps.
So, to me it seems that the connected manual switches have something to do with it, although it can be coincidence.
I also had some troubles to get the devices of the new series connected to the network. I kept keeping messages like "Can't detect device" and "User configuration settings", although the devices seemed to work properly, except for the second channel.

If somebody could help me with this problem I would be much obliged, it seems to me a kind of 'configuration settings' problem.

Greetz, Peter-Jos

Offline John M.

  • Administrator
  • Sr. Member
  • *****
  • Posts: 402
  • Karma: +25/-3
    • getvera.com
Re: Fibaro FGS-223 second channel not working with Vera Edge
« Reply #37 on: January 02, 2017, 03:50:56 pm »
Hello Simons,

The above described procedures will only work for FGS 223. To my knowledge the predecessors FGS 222 should not have any problems, unless it's some kind of initial configuration issue, in which case, support would be able to check this out and point you to the correct solution.

Don't forget to also enable customer care remote access in the initial email, so things will go faster.
John.M. ▾ Senior Customer Care Advocate
Vera Control, Ltd. ▾ Smarter Home Control  ▾ support@getvera.com ▾www.getvera.com ▾ +1 (866) 966-2272

HOURS OF OPERATION (Pacific Time Zone, UTC -8 )
Monday - Friday   12:00 am ? 06:00 pm
Saturday - Sunday   04:00 am ? 06:00 pm

Offline Sender

  • Hero Member
  • *****
  • Posts: 742
  • Karma: +532/-436
  • Sr. manager of my Vera
Re: Fibaro FGS-223 second channel not working with Vera Edge
« Reply #38 on: January 02, 2017, 03:53:51 pm »
Hi
Thanks for the guide! I have now got the Child units to be able to control the switch but they don?t get an update wether the switch is on or off. I am rather new on the vera UI, is it possible for someone to explain a little bit more in detail regarding the following:
"Also you should add the following service id , variable and value for both children and also Reload the Engine :
urn:micasaverde-com:serviceId:ZWaveDevice1
BasicSetCapabilities
00=F0,FF=O0"

In my new service tab i have the following fields:
"New Service"
"New Variable"
"New Value"

What shall I put into these fields?

Yes in that order
Good firmware is more important than good karma. (and this costed me lots of Karma)

Offline Veera

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
Re: Fibaro FGS-223 second channel not working with Vera Edge
« Reply #39 on: January 02, 2017, 04:37:30 pm »
Like this?

"New Service" - urn:micasaverde-com:serviceId:ZWaveDevice1
"New Variable" - BasicSetCapabilities
"New Value" - 00=F0,FF=O0

Offline Sender

  • Hero Member
  • *****
  • Posts: 742
  • Karma: +532/-436
  • Sr. manager of my Vera
Re: Fibaro FGS-223 second channel not working with Vera Edge
« Reply #40 on: January 02, 2017, 04:44:45 pm »
Like this?

"New Service" - urn:micasaverde-com:serviceId:ZWaveDevice1
"New Variable" - BasicSetCapabilities
"New Value" - 00=F0,FF=O0

Yes in that order
Good firmware is more important than good karma. (and this costed me lots of Karma)

Offline pj

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
Re: Fibaro FGS-223 second channel not working with Vera Edge
« Reply #41 on: January 03, 2017, 07:16:22 am »
Hi John M,

what do you mean with "Don't forget to also enable customer care remote access in the initial email, so things will go faster." ???



Offline Sender

  • Hero Member
  • *****
  • Posts: 742
  • Karma: +532/-436
  • Sr. manager of my Vera
Re: Fibaro FGS-223 second channel not working with Vera Edge
« Reply #42 on: January 03, 2017, 07:45:20 am »
Hi John M,

what do you mean with "Don't forget to also enable customer care remote access in the initial email, so things will go faster." ???

In your vera under the settings enable customer care and copy the given string to vera in a support email. This way they can access you device.
Good firmware is more important than good karma. (and this costed me lots of Karma)

Offline pj

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
Re: Fibaro FGS-223 second channel not working with Vera Edge
« Reply #43 on: January 03, 2017, 11:05:08 am »

In your vera under the settings enable customer care and copy the given string to vera in a support email. This way they can access you device.

got you, thanks !

Offline TheRedPill

  • Full Member
  • ***
  • Posts: 109
  • Karma: +0/-0
Re: Fibaro FGS-223 second channel not working with Vera Edge
« Reply #44 on: January 07, 2017, 07:17:04 am »
I also cant get this to work with the procedure described above. I can control the children from the UI, but status reporting does not work. I cant believe how long it is taking for Vera to include this popular new device - 3 firmware versions on with all kinds of functionality included that I am pretty sure nobody will trust a Vera to manage (like security) and pretty much NO new device support.