We have moved at community.getvera.com

Author Topic: Vera 3 upgrade failed .. power LED is flashing orange and green... need help  (Read 6301 times)

Offline pstoian

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0

After the latest firmware update for Vera 3, the unit power LED is flashing orange and green. I've tried several times to reset or unplug the power....but after the reboot the power LED is still flashing orange and green. I sent an email to support but no respond yet.

It is there a way to reset the unit to factory defaults or how I should get rid of this issue? The unit is unreachable from Internet or locally. I did saved the unit backup/configurations.

Your advice/help is much appreciated.


Offline leonmegens

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
I became from Vera the next solution, this helps for me. After i did this , you must connect the wan interface to the internet.

How To restore Vera 3
1. Connect your computer directly into the LAN1 port on the Vera3 unit
2. Plug the power adapter in Vera and when the power led starts blinking red (amber), press and release the reset button.
This is the most important step because it puts the unit into flashing mode. If this is successful you will see the the power light blink red/green faster.
3. Put a static IP on your computer ( and the gateway
4. Open a command prompt and telnet into the unit: telnet (with putty)
Run these commands:
flash_eraseall -j /dev/mtd7
echo b > /proc/sysrq-trigger
Note: If you cannot telnet to the unit you will need to install the telnet client.
Windows 7 : From Control Panel > Programs and Features > Turn Windows Feature On or Off >and check the Telnet Client box to install it .
Another method is to use Putty and select telnet when you connect to the IP address.
Now the Vera unit should reboot and you should see it booting up. It might take a couple of
seconds, first the LED should be solid red, then green, red and after that it should boot up
6. Change your IP address back on automatically or and gateway
7. Check that the Dashboard loads on after all the LEDs are on and solid green

Good luck

Offline strohlde

  • Sr. Newbie
  • *
  • Posts: 30
  • Karma: +0/-0
Thanks! Worked for me.

Offline Greybeardvacationrental

  • Jr. Member
  • **
  • Posts: 98
  • Karma: +1/-0
And if you just did a remote update because it brought me right to the update page when I logged on and now I'm down and it's 325 miles away?  What then?  Hello Micasaverde!?#%$^$%&^%

Offline HouseBot

  • Full Member
  • ***
  • Posts: 210
  • Karma: +1/-1
Mine was also bricked by last update!
Your instructions worked for me!
Thank good! Almost ruined the whole X-mas!!

Offline bconrey

  • Newbie
  • *
  • Posts: 11
  • Karma: +1/-0
Mine was bricked by the last update, and unfortunately these steps did not work. Just spent 90 minutes on the phone with support trying to recover my Vera Lite and no luck. I get to start over with a new unit. As you might imagine, I'm not very happy about this!

Offline paresseuxdan

  • Newbie
  • *
  • Posts: 7
  • Karma: +0/-0
Pressing the reset button doesn't do anything for me. Tried holding it down, repeated pressing, holding it while restarting the unit. Not real happy about this. Have contacted support, have had to wait over a week in the past for a response...

Offline baxy_AU

  • Sr. Member
  • ****
  • Posts: 269
  • Karma: +5/-0
I am the same situation, except in my case tech support INITIATED THE UPGRADE, not happy.... This was today BTW
« Last Edit: December 30, 2016, 09:55:23 pm by baxy_AU »

Offline a-lurker

  • Hero Member
  • *****
  • Posts: 872
  • Karma: +66/-8
I've had this happen twice during a firmware upgrade on a Vera 3:

1) power LED flashing orange and green and no others lit
2) no access on the WAN or LAN ports including on the default

I used this technique - however it requires the usage of a Windows XP computer. Tried it on Win 10 and it claimed it needed some weird driver, so I chickened out on that one. But it worked great on XP and got my Vera 3 going again.


MCV - isn't about time to update this Win XP utility?
« Last Edit: December 31, 2016, 01:29:15 am by a-lurker »

Offline Greybeardvacationrental

  • Jr. Member
  • **
  • Posts: 98
  • Karma: +1/-0
When I had support get me going again they used my Win7 laptop to flash the new firmware.  They had to download a couple of programs on my laptop to do it though I don't know what those programs were.