We have moved at community.getvera.com

Author Topic: openLuup: ZWay plugin for ZWave.me hardware  (Read 12921 times)

Offline rafale77

  • Community Beta
  • Hero Member
  • ******
  • Posts: 1749
  • Karma: +101/-27
  • HA ≠ IoT as a blue sky is cloudless.
Re: openLuup: ZWay plugin for ZWave.me hardware
« Reply #105 on: July 25, 2018, 11:23:18 am »
 :) glad to hear. Will give me time to get more familiar with zway
openLuup (79 devices, 141 scenes, 19 apps) master to VeraPlus (142 zwave nodes, 8 Zigbee nodes, 221 devices,  20 scenes , 2 apps) +  Hubitat (15 Zigbee nodes) + Home-Assistant (API Integrations). Bridged to Siri and Alexa. Homewave. VeraPlus ExtRooted and mios server independent.

Offline ramwal

  • Newbie
  • *
  • Posts: 7
  • Karma: +1/-0
Re: openLuup: ZWay plugin for ZWave.me hardware
« Reply #106 on: July 28, 2018, 07:44:56 am »
After a few years not giving attention to the development of openLuup and ALTUI, I recently discouvered a tremendous progress of these applications. It has become must more user friendly, although there is still a lot to learn in how to use all these nice things. Impressive what akbooer and amg0 are doing with this environment.
To get acquainted with the Z-Way plugin I installed openLuup (development) on a new RaspB3+ (no vera bridge). Installed Z-Way plugin; configured the plugin; the z-way server is running on another Pi with the RaZberry card. Everything looks OK, the startup log gives no errors, except in the scheduler - startup jobs I get the following:

Startup Jobs, Sat Jul 28 12:59:58 2018 
    #  date       time        device     status[n]  info 
    1  2018-07-28 09:25:18         2       Done[1]  job#1 :plugin openLuup 
    2  2018-07-28 09:25:18         3       Done[1]  job#2 :plugin Alternate UI 
    3  2018-07-28 09:25:18         4       Done[1]  job#3 :plugin Alternate App Store 
    4  2018-07-28 09:25:20         5       Done[1]  job#4 :plugin Netatmo 
    5  2018-07-28 09:25:20        17      Abort[1]  job#5 :plugin Z-Way ./L_ZWay.lua:998: attempt to index local 'd' (a nil value)

So, something is not going well with L_ZWay.lua. I have one Fibaro switch included in the Razberry Pi to test, but it does not appear as a device. I looked into L_ZWay.lua, but is above my understanding what is happening there.
What is going wrong here?

Thanks in advance for helping out.

Offline akbooer

  • Moderator
  • Master Member
  • *****
  • Posts: 6387
  • Karma: +292/-70
  • "Less is more"
Re: openLuup: ZWay plugin for ZWave.me hardware
« Reply #107 on: August 25, 2018, 02:59:23 am »
So sorry for having missed your post for nearly a month!  ... just never saw it.

What would be useful is a complete startup log, since I need to check the version you've used and a few other things.

________________

Edit: I've checked the source code and it's clear that the problem is that because you have not bridged to Vera and copied device files across, the relevant ones for the Fibaro (binary light, dimmer, etc...) are missing.

You could copy these files over manually if you don't want to bridge (bridging to Vera does no harm at all to the Vera, it doesn't even know that it's happening.)  If you need a full list of which files they are, then I could provide same, but the easiest thing is to copy everything.
« Last Edit: August 25, 2018, 03:03:37 am by akbooer »
3x Vera Lite-UI5/Edge-UI7, 25x Fibaro, 23x TKB, 9x MiniMote, 2x NorthQ Power, 2x Netatmo, 1x Foscam FI9831P, 9x Philips Hue,
Razberry, MySensors Arduino, HomeWave, AltUI, AltHue, DataYours, Grafana, openLuup, ZWay, ZeroBrane Studio.

Offline ramwal

  • Newbie
  • *
  • Posts: 7
  • Karma: +1/-0
Re: openLuup: ZWay plugin for ZWave.me hardware
« Reply #108 on: August 25, 2018, 07:22:29 am »
Hallo @akbooer,

No offence; I imagine you have a lot on your mind. Anyhow, I discovered very soon after sending the message, what the problem was. Indeed bridging my Vera Light (UI5) and getting all the files from there, gave the solution. Most of  the non-zwave dependent things I have brought over to openLuup. I am very satisfied with that.

I still have two cameras (Foscam FI8919w and a D-Link DCS-932L) working on the Vera Light, but not in openLuup. I will place a message about that on the thread concerned.

There is something not clear about what is the rule to do a Reload Luup Engine or/and refresh the browser (Safari on Macbook), or restart openLuup. I have successfully installed the Mysensors plugin on openLuup, but had to restart openLuup after discovering the nodes, to get them visible. Discovering the nodes is still a bit of trial and error.

Further I hope that you will continue with the development of openLuup. I have red on this forum about the polemics of the acquisition of Vera; a lot of sales talk and I am not sure what they will accomplish. It will take a long breath. In the meantime I am glad there is openLuup and ALTUI!

Thanks

Offline akbooer

  • Moderator
  • Master Member
  • *****
  • Posts: 6387
  • Karma: +292/-70
  • "Less is more"
Re: openLuup: ZWay plugin for ZWave.me hardware
« Reply #109 on: August 25, 2018, 07:52:37 am »
Most of  the non-zwave dependent things I have brought over to openLuup. I am very satisfied with that.

That's great.  Good to hear.

Quote
I still have two cameras (Foscam FI8919w and a D-Link DCS-932L) working on the Vera Light, but not in openLuup. I will place a message about that on the thread concerned.

I have a Foscam, 9831 IIRC, that works fine and triggers a motion sensor via email.  I don't imagine there should be a problem with yours, but you need to use the openLuup implementation file.  I'll watch for the other thread.

Quote
There is something not clear about what is the rule to do a Reload Luup Engine or/and refresh the browser (Safari on Macbook), or restart openLuup. I have successfully installed the Mysensors plugin on openLuup, but had to restart openLuup after discovering the nodes, to get them visible. Discovering the nodes is still a bit of trial and error.

In terms of actually booting the whole openLuup machine, this is usually not necessary.  There is almost nothing that a Luup reload won't do, although, indeed, just sometimes you'll need a browser refresh too.

Quote
Further I hope that you will continue with the development of openLuup. I have red on this forum about the polemics of the acquisition of Vera; a lot of sales talk and I am not sure what they will accomplish. It will take a long breath. In the meantime I am glad there is openLuup and ALTUI!

+1 for the use of the word "polemics", one of my favourites.  You are not wrong with all those sentiments.  I do slightly worry that this may mean a lot of work to keep openLuup compatible, but then they will have a backward compatibility problem too.  "The user doth protest too much, methinks."
3x Vera Lite-UI5/Edge-UI7, 25x Fibaro, 23x TKB, 9x MiniMote, 2x NorthQ Power, 2x Netatmo, 1x Foscam FI9831P, 9x Philips Hue,
Razberry, MySensors Arduino, HomeWave, AltUI, AltHue, DataYours, Grafana, openLuup, ZWay, ZeroBrane Studio.

Offline d55m14

  • Sr. Member
  • ****
  • Posts: 449
  • Karma: +8/-1
Re: openLuup: ZWay plugin for ZWave.me hardware
« Reply #110 on: November 23, 2018, 09:52:42 am »
Hi akbooer,

I've many code running in your fantastic openluup/DY/lua enviroment on rpi hw and some lua code running on several Vera/lua systems tha interact with zwave devices.

What's the best way to move the Vera-lua systems to a razberry/zway_plugin/openluup/lua enviroment with low impact on  rewriting  the lua code now present on Vera ?

I  don't need the ALTUI interface.

tnks

donato

Offline akbooer

  • Moderator
  • Master Member
  • *****
  • Posts: 6387
  • Karma: +292/-70
  • "Less is more"
Re: openLuup: ZWay plugin for ZWave.me hardware
« Reply #111 on: November 26, 2018, 10:47:47 am »
I've many code running in your fantastic openluup/DY/lua enviroment on rpi hw and some lua code running on several Vera/lua systems tha interact with zwave devices.

Thanks for that.  Yes, it's been some time now since we started discussing your application.

Quote
What's the best way to move the Vera-lua systems to a razberry/zway_plugin/openluup/lua enviroment with low impact on  rewriting  the lua code now present on Vera ?

That rather depends on the ZWave devices that you want the front end to interface to.  Have you tested a ZWay board or UZB stick to ensure that it works successfully?
3x Vera Lite-UI5/Edge-UI7, 25x Fibaro, 23x TKB, 9x MiniMote, 2x NorthQ Power, 2x Netatmo, 1x Foscam FI9831P, 9x Philips Hue,
Razberry, MySensors Arduino, HomeWave, AltUI, AltHue, DataYours, Grafana, openLuup, ZWay, ZeroBrane Studio.

Offline d55m14

  • Sr. Member
  • ****
  • Posts: 449
  • Karma: +8/-1
Re: openLuup: ZWay plugin for ZWave.me hardware
« Reply #112 on: November 26, 2018, 11:01:06 am »
Hi akbooer,

I've a RPI with a razberry2 board installed but I haven't tested any devices at the moment. I'll test a zwave switch and a thermostat next days.

Do you asked me about zway board because you know problems or instability ?

tnks

donato

Offline akbooer

  • Moderator
  • Master Member
  • *****
  • Posts: 6387
  • Karma: +292/-70
  • "Less is more"
Re: openLuup: ZWay plugin for ZWave.me hardware
« Reply #113 on: November 26, 2018, 11:11:16 am »
Do you asked me about zway board because you know problems or instability ?

No, not at all.  I think it's good, although I believe it has some problems with security devices like locks.
3x Vera Lite-UI5/Edge-UI7, 25x Fibaro, 23x TKB, 9x MiniMote, 2x NorthQ Power, 2x Netatmo, 1x Foscam FI9831P, 9x Philips Hue,
Razberry, MySensors Arduino, HomeWave, AltUI, AltHue, DataYours, Grafana, openLuup, ZWay, ZeroBrane Studio.

Offline jswim788

  • Hero Member
  • *****
  • Posts: 809
  • Karma: +58/-2
Re: openLuup: ZWay plugin for ZWave.me hardware
« Reply #114 on: November 26, 2018, 12:10:21 pm »
I'm giving up on Zway.  My latest problem is that it decided to stop running every couple of weeks.  The server just quits.  Nothing appears to be wrong, nothing in the log files, just stops running.  So then I upgraded to the very latest code, and now my locks stopped reporting status.  And support for Zway is spotty at best.  I'm moving over to openHAB.  The Z-wave support there has dramatically improved.  I'll still use openLuup as there is a REST interface on openHAB and I can easily have it access the openLuup server as needed.

Offline rafale77

  • Community Beta
  • Hero Member
  • ******
  • Posts: 1749
  • Karma: +101/-27
  • HA ≠ IoT as a blue sky is cloudless.
Re: openLuup: ZWay plugin for ZWave.me hardware
« Reply #115 on: November 26, 2018, 02:32:44 pm »
I too have grown frustrated with Zway support (or lack thereof) and have moved to home assistant as my backup to the vera. As I am getting more familiar with python, I likely will move my zigbee devices over as well.
openLuup (79 devices, 141 scenes, 19 apps) master to VeraPlus (142 zwave nodes, 8 Zigbee nodes, 221 devices,  20 scenes , 2 apps) +  Hubitat (15 Zigbee nodes) + Home-Assistant (API Integrations). Bridged to Siri and Alexa. Homewave. VeraPlus ExtRooted and mios server independent.