Author Topic: Veraplus doesn't pair with Kwikset 910  (Read 1287 times)

Offline web-dept

  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
Veraplus doesn't pair with Kwikset 910
« on: November 18, 2016, 05:04:45 pm »
I have recently purchased a Veraplus http://a.co/4ZrHL8q and a Kwikset 910 Signature Series http://a.co/grmwKIo. I selected the Kwikset because this forum indicated they were compatible with Vera. And I already had a Kwikset lock. I have followed the instructions for pairing and I get absolutely nothing. No recognition under Locks > Kwikset or Z-Wave Generic. Has anyone had any success with this lock, Kwikset 910 Signature Series http://a.co/grmwKIo, and Veraplus?

Thanks for any help.

Offline Hutchca

  • Jr. Member
  • **
  • Posts: 54
  • Karma: +3/-0
Re: Veraplus doesn't pair with Kwikset 910
« Reply #1 on: November 20, 2016, 08:45:42 pm »
I have a Kwikset 910 but NOT the "signature" series. Mine has the keypad.
https://www.amazon.com/gp/product/B004F1B24I/
No problem pairing or operating with Vera Plus.

Let us know if you get it to work. I'm thinking about getting these for the back doors were I don't need a keypad.

Offline shallowearth

  • Hero Member
  • *****
  • Posts: 984
  • Karma: +46/-9
Re: Veraplus doesn't pair with Kwikset 910
« Reply #2 on: November 21, 2016, 12:27:31 am »
I would just call QuickSet maybe you got a bad unit or missed something in the install.

Offline web-dept

  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
Re: Veraplus doesn't pair with Kwikset 910
« Reply #3 on: November 24, 2016, 08:39:16 am »
Actually, it doesn't pair initially. You have to select Retry, hit the A button on the lock to remove the device and then it paired immediately.

Offline okeefe

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
Re: Veraplus doesn't pair with Kwikset 910
« Reply #4 on: March 02, 2018, 09:07:41 pm »
I just replaced a failed Kwikset lock with a new 910.  It looked like VeraPlus included it on the first try, but the device did not show up.  Tried the usual trial and error process, repeatedly excluding, including, factory reset, etc. but nothing worked.  Power-cycled my VeraPlus, and the device showed up, and it works fine.