Author Topic: UI7 - Saving Vera Alerts Configuration Prior to UI 7.19  (Read 6486 times)

Offline RichardTSchaefer

  • Moderator
  • Master Member
  • *****
  • Posts: 10091
  • Karma: +763/-142
Re: UI7 - Saving Vera Alerts Configuration Prior to UI 7.19
« Reply #30 on: January 09, 2017, 08:57:37 pm »
Something is messed up in your configuration ....

Login via ssh
     cd /etc/cmh-ludl
     rm -i *VeraAlert*

Reboot (power cycle) your vera.
If it does not reload the Plugin files ... Update the plugin manually.


Offline dklinkman

  • Full Member
  • ***
  • Posts: 129
  • Karma: +1/-0
Re: UI7 - Saving Vera Alerts Configuration Prior to UI 7.19
« Reply #31 on: January 09, 2017, 10:25:21 pm »
I did as you suggested including rebooting the vera.

It looks like the plugin reloaded just fine.  But the same error persists as before.
VeraPlus, UI7, ALTUI on Chrome, Lots of devices and plugins including MQTT and MySensors.  Also playing around with openLuup

Offline dklinkman

  • Full Member
  • ***
  • Posts: 129
  • Karma: +1/-0
Re: UI7 - Saving Vera Alerts Configuration Prior to UI 7.19
« Reply #32 on: January 11, 2017, 08:54:29 pm »
I see in the logs that apparently user data format changed leading to the current firmware version.  Could that be a factor?

I'm still stuck here with no functioning VeraAlerts.  Main vera is still hosed though MCV is trying to fix that.  Months of backups and none of them work.
VeraPlus, UI7, ALTUI on Chrome, Lots of devices and plugins including MQTT and MySensors.  Also playing around with openLuup

Offline RichardTSchaefer

  • Moderator
  • Master Member
  • *****
  • Posts: 10091
  • Karma: +763/-142
Re: UI7 - Saving Vera Alerts Configuration Prior to UI 7.19
« Reply #33 on: January 12, 2017, 07:57:34 pm »
I do not know what to say ... other than to remove all scenes (and startup LUA)  and notifications ... and start over.

Offline dklinkman

  • Full Member
  • ***
  • Posts: 129
  • Karma: +1/-0
Re: UI7 - Saving Vera Alerts Configuration Prior to UI 7.19
« Reply #34 on: January 12, 2017, 08:06:07 pm »
Ok...  Except....  Am I talking to the wall?....  I have no scenes, no startup Lua...  ONE z-device and ONE notification that I have added and removed at least a few times.  Does the use case get any simpler?  What am I looking for?

I would try to troubleshoot your code except that you encrypted it.

What?
VeraPlus, UI7, ALTUI on Chrome, Lots of devices and plugins including MQTT and MySensors.  Also playing around with openLuup

Offline RichardTSchaefer

  • Moderator
  • Master Member
  • *****
  • Posts: 10091
  • Karma: +763/-142
Re: UI7 - Saving Vera Alerts Configuration Prior to UI 7.19
« Reply #35 on: January 13, 2017, 09:25:53 am »
Turn on debug ... reload ... and do a send alert from the editor ... check the log file ...



Offline Spanners

  • Sr. Member
  • ****
  • Posts: 257
  • Karma: +16/-5
Re: UI7 - Saving Vera Alerts Configuration Prior to UI 7.19
« Reply #36 on: January 19, 2017, 05:55:01 am »
I'm back to being stuck.

Don't get notifications updated when I go into VeraAlerts, but if I try to edit one I get the "Failed to save system configuration." error on exit and sometimes a "Failed to save msgoverride" pop up in the VeraAlerts editor.

Disabling/Enabling notifications doesn't resolve it.




Offline RichardTSchaefer

  • Moderator
  • Master Member
  • *****
  • Posts: 10091
  • Karma: +763/-142
Re: UI7 - Saving Vera Alerts Configuration Prior to UI 7.19
« Reply #37 on: January 19, 2017, 09:46:44 am »
Do you have other scenes with LUA code or startup LUA ?

Offline Spanners

  • Sr. Member
  • ****
  • Posts: 257
  • Karma: +16/-5
Re: UI7 - Saving Vera Alerts Configuration Prior to UI 7.19
« Reply #38 on: January 20, 2017, 06:27:07 am »
Do you have other scenes with LUA code or startup LUA ?


Yes, but all the scenes are set up with VeraAlerts notifications so they should be getting encoded properly. I have 2 lines in startup LUA.

Code: [Select]
emoncode = require("EnergyMonitor")
emoncode.EnergyMonitorOnTimer()

Offline RichardTSchaefer

  • Moderator
  • Master Member
  • *****
  • Posts: 10091
  • Karma: +763/-142
Re: UI7 - Saving Vera Alerts Configuration Prior to UI 7.19
« Reply #39 on: January 20, 2017, 06:40:21 am »
You may have to remove the startup lua ... let Vera alerts upgrade the scenes .. then add the startup lua back later.

MCV software will only update one thing at a time ... and fail if there are any other that are not updated.
Also Vera has the option for Scene Level LUA and Trigger Level LUA ... the Vera Alerts will only only update the Scene Level Lua code.
So it may not work for you and you may need to wait for a MCV fix.