Author Topic: Remote builder errors  (Read 3142 times)

Offline Richard

  • Sr. Newbie
  • *
  • Posts: 34
  • Karma: +0/-0
Remote builder errors
« on: July 11, 2011, 08:05:05 am »
When I try to use remote builder, I see some php errors from the mios server.

To reproduce:
Go to a scene
Select the remote tab
Select "create remote"

You'll get a popup from http://download1.mios.com/remote_builder.php?ap=16124
with the error: Notice: Undefined index: redirect_url in /var/www/vhosts/download.mios.com/lib/functions.php on line 335

Fill out the inital details.
On the next screen you'll get the error:
Notice: Undefined variable: _SESSION in /var/www/vhosts/download.mios.com/lib/functions.php on line 619

Then in the remote screen there are no devices selectable in the "Send command to device" drop down.

Offline OtisPresley

  • Full Member
  • ***
  • Posts: 144
  • Karma: +2/-1
Re: Remote builder errors
« Reply #1 on: July 11, 2011, 09:08:27 am »
This is a known issue.  I have been working with MCV since early May trying to get this working.  They have a partial fix that allows you to specify the devices to send commands to in the drop-down, but when you try to run the scene in the Smartphone Web interface, it does not forward you to the remote control page you created and sometimes gives you a Handler Error.  Please see my post here for details:
http://forum.mios.com/index.php?topic=6475.0

I first contacted MCV via email and have a recently opened ticket on it, per MCV request, as well.

Offline Richard

  • Sr. Newbie
  • *
  • Posts: 34
  • Karma: +0/-0
Re: Remote builder errors
« Reply #2 on: July 12, 2011, 09:23:22 pm »
Thanks for the info.

I hope they fix it soon.
I'll post a followup to that thread.