Author Topic: Alerts stopped coming through  (Read 4025 times)

Offline bwoods113

  • Jr. Member
  • **
  • Posts: 74
  • Karma: +1/-0
Alerts stopped coming through
« on: December 05, 2016, 12:28:55 pm »
I have been using Vera Alerts for a couple years now and everything has worked very well. All the sudden about 2 weeks ago I stopped getting alerts. I went in and did the test and it comes through just fine. I tried to re register as well as got a new key for pushbulet. Anyone else having issues with this? Any help would be much appreciated.

Online mvader

  • Sr. Member
  • ****
  • Posts: 396
  • Karma: +29/-74
Re: Alerts stopped coming through
« Reply #1 on: December 05, 2016, 01:09:42 pm »
mine is still working fine as of this morning. (VA and pushbullet)

Offline Vreo

  • Sr. Member
  • ****
  • Posts: 336
  • Karma: +6/-4
Re: Alerts stopped coming through
« Reply #2 on: December 05, 2016, 04:16:36 pm »
Try to unregister and register again, that happened to me last week. If that doesn't works (that didn't for me) then, take note of your ID and clear the cache and all data of the app and then register again introducing your previous ID in the settings prior to registering.

Do you have a Samsung and entered to UltraPowerSaving Mode?

Offline RichardTSchaefer

  • Moderator
  • Master Member
  • *****
  • Posts: 9820
  • Karma: +742/-136
    • RTS Services Plugins
Re: Alerts stopped coming through
« Reply #3 on: December 05, 2016, 11:02:33 pm »
Many folks have had no problems ... until they tried to add a new Notification, or modify one.

Then you run into the problem saving data that has been a problem in Vera for quite some time.

The latest Beta is the first time all of my test cases work ...

See:
http://forum.micasaverde.com/index.php/topic,40474.0.html


Offline bwoods113

  • Jr. Member
  • **
  • Posts: 74
  • Karma: +1/-0
Re: Alerts stopped coming through
« Reply #4 on: December 07, 2016, 07:17:49 am »
I have upgraded to the firmware and uploaded the file and I still do not get any alerts. It was working perfect 2 weeks ago the only thing that changed was my phone. I checked my pushbullet profile online and the notifications just stopped. Any other ideas would be very much appreciated.

Offline RichardTSchaefer

  • Moderator
  • Master Member
  • *****
  • Posts: 9820
  • Karma: +742/-136
    • RTS Services Plugins
Re: Alerts stopped coming through
« Reply #5 on: December 07, 2016, 10:57:51 am »
Did you you check the "Notification Configuration" after installing .... followed by the Vera Reload?

Email me the output of the Report command.

Offline cpmilez

  • Newbie
  • *
  • Posts: 19
  • Karma: +1/-0
Re: Alerts stopped coming through
« Reply #6 on: December 09, 2016, 01:09:15 pm »
I've also started experiencing the same issue with Pushbullet this week.  The last message received was Tuesday.  I've made no changes.  I tested I can send messages ok by making a curl request as per their API using the same token I had setup in Vera, I also made the curl request directly from the Vera Plus via SSH.  I've now upgraded to the Beta to see if this makes any difference but unfortunately not.

I set debug to 1 in the advanced settings and i've attached the log file output from a test message.  You will see the result is showing as "closed", if I compare this to a working alert using pushover the response contains 200 (I presume the http status) and the JSON response from the API call so something definitely not right with the API call to Pushbullet.

Offline bwoods113

  • Jr. Member
  • **
  • Posts: 74
  • Karma: +1/-0
Re: Alerts stopped coming through
« Reply #7 on: December 09, 2016, 05:19:09 pm »
I went in and did the same (i think) here is the log that I got.

Online mvader

  • Sr. Member
  • ****
  • Posts: 396
  • Karma: +29/-74
Re: Alerts stopped coming through
« Reply #8 on: December 09, 2016, 09:05:46 pm »
I've also started experiencing the same issue with Pushbullet this week.  The last message received was Tuesday.  I've made no changes.

my last message was also on Tuesday.
so i think something has changed.
« Last Edit: December 09, 2016, 11:12:05 pm by mvader »

Offline cpmilez

  • Newbie
  • *
  • Posts: 19
  • Karma: +1/-0
Re: Alerts stopped coming through
« Reply #9 on: December 10, 2016, 03:45:03 am »
@bwoods113 are you able to check the log again? your text file attachment is empty.

Offline hek

  • Hero Member
  • *****
  • Posts: 714
  • Karma: +60/-1
Re: Alerts stopped coming through
« Reply #10 on: December 10, 2016, 08:59:47 am »
Same problem here... using pushbullet and messages stopped a few days ago..

Here's the log:

Code: [Select]
08 12/10/16 14:39:17.664 JobHandler_LuaUPnP::HandleActionRequest device: 113 service: urn:richardgreen:serviceId:VeraAlert1 action: SendAlert <0x2e08b680>
08 12/10/16 14:39:17.664 JobHandler_LuaUPnP::HandleActionRequest argument DeviceNum=113 <0x2e08b680>
08 12/10/16 14:39:17.664 JobHandler_LuaUPnP::HandleActionRequest argument serviceId=urn:richardgreen:serviceId:VeraAlert1 <0x2e08b680>
08 12/10/16 14:39:17.664 JobHandler_LuaUPnP::HandleActionRequest argument action=SendAlert <0x2e08b680>
08 12/10/16 14:39:17.665 JobHandler_LuaUPnP::HandleActionRequest argument Recipients=Hejsan!!!!!!!!!!!!!!!!!!!!!!!!! henrikekblad Pushbullet_Hek <0x2e08b680>
08 12/10/16 14:39:17.665 JobHandler_LuaUPnP::HandleActionRequest argument rand=0.6004519660799583 <0x2e08b680>
50 12/10/16 14:39:17.669 luup_log:113: VeraAlert:113:SendAlert:Msg: <0x2acd5000>
50 12/10/16 14:39:17.671 luup_log:113: VeraAlert:113:ExpandRecipients:Checking:Hejsan!!!!!!!!!!!!!!!!!!!!!!!!! <0x2acd5000>
50 12/10/16 14:39:17.672 luup_log:113: VeraAlert:113:ExpandRecipients:Not a user or profile:Hejsan!!!!!!!!!!!!!!!!!!!!!!!!! <0x2acd5000>
50 12/10/16 14:39:17.673 luup_log:113: VeraAlert:113:ExpandRecipients:Checking:henrikekblad <0x2acd5000>
50 12/10/16 14:39:17.673 luup_log:113: VeraAlert:113:ExpandRecipients:Adding User Specified Profile:Pushbullet_Hek <0x2acd5000>
50 12/10/16 14:39:17.674 luup_log:113: VeraAlert:113:ExpandRecipients:Checking:Pushbullet_Hek <0x2acd5000>
50 12/10/16 14:39:17.674 luup_log:113: VeraAlert:113:ExpandRecipients:Adding Requested Profile <0x2acd5000>
50 12/10/16 14:39:17.675 luup_log:113: VeraAlert:113:ExpandRecipients:Duplicate <0x2acd5000>
50 12/10/16 14:39:17.675 luup_log:113: VeraAlert:113:SendAlert:Sending to:Pushbullet_Hek <0x2acd5000>
50 12/10/16 14:39:17.676 luup_log:113: VeraAlert:113:MessagePrefix:Initial:  <0x2acd5000>
50 12/10/16 14:39:17.677 luup_log:113: VeraAlert:113:MessagePrefix:Result:  <0x2acd5000>
50 12/10/16 14:39:17.677 luup_log:113: VeraAlert:113:PushbulletSend:Body:type=note&title=Vera%20Alert%20from%3A30104189&body= <0x2acd5000>
50 12/10/16 14:39:17.729 luup_log:113: VeraAlert:113:PushbulletSend:Result:closed Resp:nil <0x2acd5000>
06 12/10/16 14:39:17.730 Device_Variable::m_szValue_set device: 113 service: urn:richardgreen:serviceId:VeraAlert1 variable: LastMsgSent was: 14:33:21 Sat Dec 10 now: 14:39:17 Sat Dec 10 #hooks: 0 upnp: 0 v:0x10d78d0/NONE duplicate:0 <0x2acd5000>
50 12/10/16 14:39:17.805 luup_log:113: VeraAlert:113:SendAlert:Memory:489094 <0x2acd5000>
04 12/10/16 14:39:17.807 <Job ID="258" Name="" Device="113" Created="2016-12-10 14:39:17" Started="2016-12-10 14:39:17" Completed="2016-12-10 14:39:17" Duration="0.140505000" Runtime="0.137382000" Status="Successful" LastNote=""/> <0x2acd5000>

Running UI5, VeraAlerts 6.43

Offline RichardTSchaefer

  • Moderator
  • Master Member
  • *****
  • Posts: 9820
  • Karma: +742/-136
    • RTS Services Plugins
Re: Alerts stopped coming through
« Reply #11 on: December 10, 2016, 02:52:45 pm »
I think they tightened the API. Previously the accepted arguments in the a URL encoded format... now they only accept JSON format ... I will have to make some changes.

Sent from my SAMSUNG-SM-G935A using Tapatalk


Offline hek

  • Hero Member
  • *****
  • Posts: 714
  • Karma: +60/-1
Re: Alerts stopped coming through
« Reply #12 on: December 10, 2016, 04:13:07 pm »
Will this mean I'd lose vera alert support? I would rather not update to UI7 (no one want hell break lose during x-mas ;) )

Or would you consider backport it to a pre UI7 release?
« Last Edit: December 10, 2016, 04:18:52 pm by hek »

Offline RichardTSchaefer

  • Moderator
  • Master Member
  • *****
  • Posts: 9820
  • Karma: +742/-136
    • RTS Services Plugins
Re: Alerts stopped coming through
« Reply #13 on: December 11, 2016, 12:07:33 pm »
I will do a u i5 port as well.

Sent from my SAMSUNG-SM-G935A using Tapatalk


Offline hek

  • Hero Member
  • *****
  • Posts: 714
  • Karma: +60/-1
Re: Alerts stopped coming through
« Reply #14 on: December 11, 2016, 03:00:49 pm »
Thanks Richard!