Author Topic: Alerts stopped coming through  (Read 2167 times)

Offline fuzzysb

  • Sr. Newbie
  • *
  • Posts: 30
  • Karma: +0/-1
Re: Alerts stopped coming through
« Reply #15 on: December 12, 2016, 01:03:48 pm »
just saw this, was pulling my hair out trying to figure out why it stopped.

any timeline on when a new version will be available?

Regards

Stuart Buchanan

Offline fuzzysb

  • Sr. Newbie
  • *
  • Posts: 30
  • Karma: +0/-1
Re: Alerts stopped coming through
« Reply #16 on: December 13, 2016, 02:04:50 pm »
pushbullet said that they have not changed their API, at least not intentionally. I told them to look at this thread. And he came back with the following.

I just ran this command: curl https://api.pushbullet.com/v2/pushes -u <access token>: -d type="note" -d title="A simple title" -d body="A message" -X POST

and it worked, and that uses url encoded parameters, so I suspect it is some other issue, not the JSON request bodies.

-Chris
Co-Founder, Pushbullet

Offline RichardTSchaefer

  • Moderator
  • Master Member
  • *****
  • Posts: 9282
  • Karma: +697/-128
    • RTS Services Plugins
Re: Alerts stopped coming through
« Reply #17 on: December 13, 2016, 02:46:16 pm »
pushbullet said that they have not changed their API, at least not intentionally. I told them to look at this thread. And he came back with the following.

I just ran this command: curl https://api.pushbullet.com/v2/pushes -u <access token>: -d type="note" -d title="A simple title" -d body="A message" -X POST

and it worked, and that uses url encoded parameters, so I suspect it is some other issue, not the JSON request bodies.

-Chris
Co-Founder, Pushbullet
It might be there SSL security. When doing a post to there website from LUA (We are limited to a very old version With Vera) the connection closes. Same arguments work fine in curl. This is new behavior.

Sent from my SAMSUNG-SM-G935A using Tapatalk


Offline cpmilez

  • Newbie
  • *
  • Posts: 19
  • Karma: +1/-0
Re: Alerts stopped coming through
« Reply #18 on: December 13, 2016, 02:59:51 pm »
It looks like SSL could be related, their SSL cert has recently been renewed as its got a valid from date of ‎01 ‎December ‎2016.

Do you think you will be able to look at this soon?  It would be good to know if not so I can look at alternative solutions.

Offline RichardTSchaefer

  • Moderator
  • Master Member
  • *****
  • Posts: 9282
  • Karma: +697/-128
    • RTS Services Plugins
Re: Alerts stopped coming through
« Reply #19 on: December 14, 2016, 08:32:02 am »
It would not be the Cert.   It would be something like the set of allowed encryption connection protocols that is negotiated when a  SSL link is established.
Vera uses old Linux and LUA sofware and may not have the most modern secure connection protocols.
Push Bullet may no longer accept the protocols that the the MCV Version of LUA supports. (A trade off when you try to harden the security of a website.)
curl on Vera can talk to Pushbullet, so I will likely have to make some additional code changes.
 

Offline fuzzysb

  • Sr. Newbie
  • *
  • Posts: 30
  • Karma: +0/-1
Re: Alerts stopped coming through
« Reply #20 on: December 15, 2016, 08:18:49 am »
chris from Pushbullet sent me the following info. so it looks like unless the version of openwrt vera uses is updated then this will start happening with more and more providers in the future


Quote
That is more likely. There were two things that changed, it now uses a SHA256 root CA, which chrome will require soon, and it uses SSL SNI which our provider required, but which is supported by about every SSL thing made in the last few years. Is the developer using TLSv1 instead of SSLv3? SSLv3 is definitely broken: https://security.googleblog.com/2014/10/this-poodle-bites-exploiting-ssl-30.html

Offline fuzzysb

  • Sr. Newbie
  • *
  • Posts: 30
  • Karma: +0/-1
Re: Alerts stopped coming through
« Reply #21 on: December 15, 2016, 11:20:30 am »
i've been looking at other methods for picture messages as i was sending a picture to Pushbullet via veraalerts and this picture would be in my Android notifications and withing the Pushbullet notification on my PC and would also show the picture on my Gear S2 which was awesome when someone rang my doorbell.

but now its stopped that only leaves VeraAlert on android for receiving messages. but it does not show the picture on the notification screen and in fact doesn't appear at all and gives a notification that it cannot connect to vera, but the picture is in the log directory. any ideas and what other options do we have for picture messages?

Regards

Stuart Buchanan

Offline RichardTSchaefer

  • Moderator
  • Master Member
  • *****
  • Posts: 9282
  • Karma: +697/-128
    • RTS Services Plugins
Re: Alerts stopped coming through
« Reply #22 on: December 19, 2016, 11:17:17 am »
I have released a Fix ... Plugin Version 7.21 to fix the pushpullet problems.

The problem was that Pushbullet changed some software on their server to protect certain types of security vulnerabilities.
This was actually mandated by their Web Server Provider.

The changes they made are NOT compatible with HTTPS posting in LUA  (Thats what is required to send the data to the Web Server).
The reason it is incompatible is because Vera users a VERY OLD version of OpenWRT  and LUA ... and they do not have recent security improvements.

Offline mvader

  • Sr. Member
  • ****
  • Posts: 337
  • Karma: +29/-70
Re: Alerts stopped coming through
« Reply #23 on: December 19, 2016, 02:15:01 pm »
I have released a Fix ... Plugin Version 7.21 to fix the pushpullet problems.

The problem was that Pushbullet changed some software on their server to protect certain types of security vulnerabilities.
This was actually mandated by their Web Server Provider.

The changes they made are NOT compatible with HTTPS posting in LUA  (Thats what is required to send the data to the Web Server).
The reason it is incompatible is because Vera users a VERY OLD version of OpenWRT  and LUA ... and they do not have recent security improvements.

Thanks for the fix.. what is the typical ETA before it shows up in the app store?
I'm still showing 7.15

Offline RichardTSchaefer

  • Moderator
  • Master Member
  • *****
  • Posts: 9282
  • Karma: +697/-128
    • RTS Services Plugins
Re: Alerts stopped coming through
« Reply #24 on: December 19, 2016, 03:52:20 pm »
It took two weeks for the last PLEG release.

Offline cpmilez

  • Newbie
  • *
  • Posts: 19
  • Karma: +1/-0
Re: Alerts stopped coming through
« Reply #25 on: December 19, 2016, 04:59:16 pm »
Is it possible you can provide files so we can manually update all?

Offline RichardTSchaefer

  • Moderator
  • Master Member
  • *****
  • Posts: 9282
  • Karma: +697/-128
    • RTS Services Plugins
Re: Alerts stopped coming through
« Reply #26 on: December 20, 2016, 07:28:32 am »
Sorry I can't deliver encrypted files.

Sent from my SAMSUNG-SM-G935A using Tapatalk


Offline hek

  • Hero Member
  • *****
  • Posts: 714
  • Karma: +60/-1
Re: Alerts stopped coming through
« Reply #27 on: December 21, 2016, 07:08:10 pm »
Did you send the backported version as well?

Offline hellovn

  • Full Member
  • ***
  • Posts: 210
  • Karma: +18/-46
Re: Alerts stopped coming through
« Reply #28 on: January 05, 2017, 05:03:33 am »
My pushbullet starts working again with v.21

Offline mvader

  • Sr. Member
  • ****
  • Posts: 337
  • Karma: +29/-70
Re: Alerts stopped coming through
« Reply #29 on: January 05, 2017, 09:38:10 am »
mine started to work again this morning as well.