We have moved at community.getvera.com

Author Topic: Error writing variable data using luup.log  (Read 702 times)

Offline NikV

  • Full Member
  • ***
  • Posts: 143
  • Karma: +2/-1
Error writing variable data using luup.log
« on: December 10, 2016, 10:28:00 am »


Using the following snippet in openLuup misc>test code

Code: [Select]
local mess ='Variable message in log'
luup.log (mess)
or
Code: [Select]
local mess ='Variable message in log'
luup.log mess

results in an error,

Running the first one on a veraedge works fine

any ideas of a workaround to get non constant data into the log from a scene

Offline akbooer

  • Moderator
  • Master Member
  • *****
  • Posts: 6387
  • Karma: +292/-70
  • "Less is more"
Re: Error writing variable data using luup.log
« Reply #1 on: December 10, 2016, 01:16:41 pm »
I assure you that the first version works correctly.

The second one is clearly a Lua syntax error.

I'd suggest you look closely at the log.  I might guess that the error message you posted was because you had previously made an error.
3x Vera Lite-UI5/Edge-UI7, 25x Fibaro, 23x TKB, 9x MiniMote, 2x NorthQ Power, 2x Netatmo, 1x Foscam FI9831P, 9x Philips Hue,
Razberry, MySensors Arduino, HomeWave, AltUI, AltHue, DataYours, Grafana, openLuup, ZWay, ZeroBrane Studio.

Offline NikV

  • Full Member
  • ***
  • Posts: 143
  • Karma: +2/-1
Re: Error writing variable data using luup.log
« Reply #2 on: December 10, 2016, 02:04:41 pm »
Well its true I was fiddling and had made a couple of errors prior to that  :).  I went and tried it again but still got the error!

So given your comment I reloaded OpenLuup and yes the first one now works.

Thanks