We have moved at community.getvera.com

Author Topic: 'Device Not Ready' after upgrade from 0.22 to 0.23d6  (Read 1596 times)

Offline Jim McGhee

  • Full Member
  • ***
  • Posts: 139
  • Karma: +5/-1
'Device Not Ready' after upgrade from 0.22 to 0.23d6
« on: December 13, 2016, 10:56:40 pm »
Everything seems OK when I install 0.22 from the App store.  :)
But when I download 0.22.b3 or 0.23.d6, unzip it and drop everything on the 'Update' button in 'Apps/Develp apps/LUUP Files' and reboot a few times I get 'Error: Device Not Ready' whenever I click on resync, set, debug, or anything.   :(
Am I doing something wrong?  Should I not be going directly from 0.22 to 0.23d6?

Offline dubbedout

  • Full Member
  • ***
  • Posts: 179
  • Karma: +3/-5
Re: 'Device Not Ready' after upgrade from 0.22 to 0.23d6
« Reply #1 on: December 14, 2016, 03:56:41 pm »
I'm having a similar issue, but keep getting a Files Mismatch error.  It showed more files first and so I re-uploaded them thinking maybe I missed some that doesn't seem to be the case.  I'm going to try to remove the plug-in and re-install.


Code: [Select]
Mismatched Files
D_Wink_Hub1.xml
I_Wink_Hub1.xml

Offline bigmonkey70

  • Jr. Member
  • **
  • Posts: 76
  • Karma: +1/-1
Re: 'Device Not Ready' after upgrade from 0.22 to 0.23d6
« Reply #2 on: December 16, 2016, 02:57:20 pm »
I did try to removed and reinstall and the Mismatched still there.
I tried to reused the 2 files from previous version and i got it to install ...

but I have another problem since version 22b13 that I cannot control the button
Since I installed the b14 and the latest, I got can't  detect device ... devices still work (minus the 2 relays)
Also forgot to mention that the luup keep restarting every couple minutes


I'm having a similar issue, but keep getting a Files Mismatch error.  It showed more files first and so I re-uploaded them thinking maybe I missed some that doesn't seem to be the case.  I'm going to try to remove the plug-in and re-install.


Code: [Select]
Mismatched Files
D_Wink_Hub1.xml
I_Wink_Hub1.xml
« Last Edit: December 16, 2016, 03:25:43 pm by bigmonkey70 »

Offline dubbedout

  • Full Member
  • ***
  • Posts: 179
  • Karma: +3/-5
Re: 'Device Not Ready' after upgrade from 0.22 to 0.23d6
« Reply #3 on: December 17, 2016, 10:49:54 pm »
Same here.  I just completely removed the Wink Connect plug-in.  I started playing around with a SmartThings hub that I picked up for $50 when they were on sale, thinking about going in that direction for both Zigbee and Zwave in one hub that also has some customization options unlike Wink.

Offline Chimpware

  • Sr. Member
  • ****
  • Posts: 426
  • Karma: +0/-0
Re: 'Device Not Ready' after upgrade from 0.22 to 0.23d6
« Reply #4 on: December 22, 2016, 08:55:05 pm »
Having the same problem, any resolution?

Offline tomtcom

  • Beta Testers
  • Hero Member
  • *****
  • Posts: 1050
  • Karma: +27/-31
Re: 'Device Not Ready' after upgrade from 0.22 to 0.23d6
« Reply #5 on: January 13, 2017, 12:07:24 pm »
Having the same problem, any resolution?

For mismatched files for .23d6, I used WinSCP to copy the 2 files from the download into the directory directly. You'll notice that when you add the files they are converted to .lzo using the Vera UI. If you use WinSCP to copy them, it doesn't convert them to .lzo (that I saw) and this is what allowed me to get past mismatched files.


Offline Jim McGhee

  • Full Member
  • ***
  • Posts: 139
  • Karma: +5/-1
Re: 'Device Not Ready' after upgrade from 0.22 to 0.23d6
« Reply #6 on: February 02, 2017, 09:26:24 pm »
I found my problem and a work around.
When I installed anything newer than the version 0.22 in the app store the Wink Connect app would get stuck in "Status:Configured..." after which anytime I try to change anything, I got "ERROR: Device not ready".
It turns out the problem only happens if 'Create Vera device for sensors' is enabled.
This is a Catch 22 since any attempt to turn it off gives a not ready error.
To get back up and running, I

Uninstalled Wink Connect

Logged in to the VeraPlus and typed the lines:   (Try this at your own risk!  :o :o)
   cd /etc/cmh-ludl
   rm *Wink*

Installed Wink Connect

and this time I didn't enable 'Create Vera device for sensors'.

Everything seens to be work fine now on 0.24 and I'm a happy camper.
FWIW, I have two leak sensors on the Wink that Wink Connect doesn't know what to do with and that might be confusing the app.
I LOVE this app and am sure thankful that I can now move to the latest updates!!!    :) :)

Offline RichardTSchaefer

  • Community Beta
  • Master Member
  • ******
  • Posts: 10091
  • Karma: +764/-143
Re: 'Device Not Ready' after upgrade from 0.22 to 0.23d6
« Reply #7 on: February 02, 2017, 11:09:28 pm »
Quote
cd /etc/cmh-ludl
   rm *Wink*

As long as you are in that directory when you do the remove ... you should be OK ... even if you delete an extra file ... Vera should detect it and re-install the corresponding software.
That works 90% of the time.  Occasionally apps dynamically create files that Vera does not know about and how they are related to a particular plugin. In that case it would not know how to detect/correct the problem.