Author Topic: Ping Sensor Recovery  (Read 1047 times)

Offline clippermiami

  • Hero Member
  • *****
  • Posts: 1391
  • Karma: +27/-6
Ping Sensor Recovery
« on: December 17, 2016, 11:15:35 am »
Does the Ping sensor report the change of state from down to up immediately on the first successful ping? Example:
- pinging a device every 60 seconds with a timeout of 600 seconds
- the pinged device goes away and the timeout trips, the ping sensor shows its down
- 30 minutes later the device comes back up.

Will the ping sensor report it up on the next regular 60 second ping or the next 600 second timeout period?
Two Vera Plus UI7 Linked via HTTP, 90+ Devices. PlugIns: PLEG, DSC, Blue Iris, MySensors,  AutoVera, ImperiHome, VeraAlerts, EventWatcher

Offline Mike Yeager

  • Hero Member
  • *****
  • Posts: 561
  • Karma: +9/-12
Re: Ping Sensor Recovery
« Reply #1 on: December 17, 2016, 06:57:54 pm »
It's immediate on the next successful ping...

Offline clippermiami

  • Hero Member
  • *****
  • Posts: 1391
  • Karma: +27/-6
Re: Ping Sensor Recovery
« Reply #2 on: December 18, 2016, 06:59:16 pm »
Actually I can confirm that it ISN'T the first successful ping, it's the completion of the full timeout cycle.

I have a ping sensor set to to ping the other Vera. If the ping times out (15 minutes) it turns the power off and then on to the other Vera. But when the second Vera comes back up it power cycles again almost immediately. And it keeps doing this until I intervene and disable the ping sensor. I have messages set to send when the ping falls and when it is restored and the restored message does not occur until the end of the full 15 minutes timeout.

The original ping sensor behaved "properly" I.e. It indicated UP on the first successful ping but this version does not.
Two Vera Plus UI7 Linked via HTTP, 90+ Devices. PlugIns: PLEG, DSC, Blue Iris, MySensors,  AutoVera, ImperiHome, VeraAlerts, EventWatcher

Offline Mike Yeager

  • Hero Member
  • *****
  • Posts: 561
  • Karma: +9/-12
Re: Ping Sensor Recovery
« Reply #3 on: December 19, 2016, 12:27:11 pm »
I don't have that issue. Mine goes to an active state as soon as the device answers a ping.