Author Topic: Can't create association with Leviton VRI06-1l  (Read 1060 times)

Offline JohnRob

  • Full Member
  • ***
  • Posts: 248
  • Karma: +11/-4
Can't create association with Leviton VRI06-1l
« on: December 22, 2016, 04:19:00 pm »

I'm trying to get a Leviton VRI06-1L (vizia RF+) to associate with a Linear WD500Z.

In my last attempt I:
  • excluded it from Vera
  • Factory Reset the VRI06
  • Located it ~ 2 feet from my VeraPlus
  • Included and verified basic function
  • Setup association using Group 1 to my WD500Z dimmer.
  • The "view" parameter showed the ID of the WD500Z dimmer
  • Results:  I get no response from the WD500Z dimmer
I tried updating neighbors.... no change
I looked at the advanced parameters and found the target dimmer ID was listed
I added an association to a closer Leviton dimmer module (within 10 feet of the VRI06)..... no luck


I was able to use instant status with this dimmer with no issues at all. 


Is there an step I am not aware of?


Ultimately I plan on going to a VRMX1 but only if the I can get associations to work.  Anybody have success with the VRMX1?


Thanks



Before including into the network, I performed a factory reset.  So I'm pretty sure my association issue is not old settings lingering in the dimmer.

It currently on my desk, included in my VeraPlus network.   I am trying to associate it with a WD500Z dimmer.
I can make the instant status function by creating scenes to trigger on the Leviton IS.  No issue here.

When I try to setup association with the WS500Z using Group 1,  Vera reports a successful association.  However the WD500Z does not respond to the Leviton association.
If I delete the Group 1 association and try a Group 2 association, as expected Vera reports an unsuccessful association.
The Leviton is "known" to support association,  the capabilities shown in advanced settings has the 133/134 for associations (209,12,0,4,17,4,L,R,RS,|38,39,43,44,114,115,119,133,134,145,).

Offline echino

  • Jr. Member
  • **
  • Posts: 94
  • Karma: +1/-0
Re: Can't create association with Leviton VRI06-1l
« Reply #1 on: December 22, 2016, 06:50:04 pm »
I just had a similar issue with different devices, association set up successfully, but not working. Turned out the commands were sent to associated device in secure mode and that device did not understand secure commands.

Two possible solutions: configure the master device to send commands to associated device in unsecure mode (if possible - it is not always configurable), or include both devices as unsecure, then they will communicate via unsecure channel.

That's one thought. You issue may be different though.

Offline JohnRob

  • Full Member
  • ***
  • Posts: 248
  • Karma: +11/-4
Re: Can't create association with Leviton VRI06-1l
« Reply #2 on: December 23, 2016, 06:01:44 pm »
@echino

Thanks for the suggestion :).  I'll repost once/if I get it sorted out.


Offline JohnRob

  • Full Member
  • ***
  • Posts: 248
  • Karma: +11/-4
Re: Can't create association with Leviton VRI06-1L (update)
« Reply #3 on: January 11, 2017, 07:20:04 pm »
My original problem was the inability to associate a Leviton RZI06-L (control) with a Linear WD500Z-1 (slave). :(  I could setup the association in Vera but there was no reaction by the WD500Z-1.

With the help of Vera Support I've found an incompatibility between the two devices.

Comparing the device Z-Wave Command Classes from the Z-Wave Certifications (http://products.z-wavealliance.org/products/) there is a difference between their supported communication methods.

The Levitons (both RLI06-1L and VRMX1) use the "Hail" method for Control Communication.  (see the Z-Wave Cert section "Controlled Command Classes")

Whereas the WD500Z-1 recognizes the "Basic" commanded class and does not support the "Hail" method. (see the Z-Wave Cert section "Supported Command Classes")

So the Levitons send out a "Hail" command for associated functions (in this case on & off) but the WD500Z-1 doesn't understand the Hail, it is looking for a command from the Basic command set.


Earlier I found the Cooper RF9540N can associate with the WD500Z-1.  As expected the Cooper uses the "Basic" Control Command Class which is supported by the WD500Z-1.

So I learned a first step for device compatibility is to check the Supported and Commanded classes of the devices one wishs to associate.  For me this was a little bit of a breakthrough as it gave me a tool to help understand the communications at the device level.  I hope this helps others.





Offline alekiv

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
Re: Can't create association with Leviton VRI06-1l
« Reply #4 on: July 12, 2018, 04:14:41 am »
I just had a similar issue with different devices, association set up successfully, but not working. Turned out the commands were sent to associated device in secure mode and that device did not understand secure commands.

Two possible solutions: configure the master device to send commands to associated device in unsecure mode (if possible - it is not always configurable), or include both devices as unsecure, then they will communicate via unsecure channel.

That's one thought. You issue may be different though.

How you can include device as unsecure?
By default Vera includes device as secure and user can't select "secure or unsecure"?