We have moved at community.getvera.com

Author Topic: iVera can not connect to local host under 1.1.1047  (Read 6677 times)

Offline wseverino

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 854
  • Karma: +0/-0
  • Da Man, Da Myth, Da Legend - in his own mind!
iVera can not connect to local host under 1.1.1047
« on: August 22, 2010, 08:54:55 am »
Just downloaded the 29.99 version of iVera and it connects via MIOS but not the local host. I have square connect and it connects fine. Anyone have any idea?
My ZWave Network: Too friggin big to list.....

Offline iVera

  • Moderator
  • Jr. Member
  • *****
  • Posts: 96
  • Karma: +0/-0
Re: iVera can not connect to local host under 1.1.1047
« Reply #1 on: August 22, 2010, 06:17:32 pm »
wseverino, here are couple of questions to try to troubleshoot what could be happening :

1) Did you have iVera Free previously installed on your iPhone? Did it work locally and remotely?

2) When you first started iVera and went to Settings menu, did iVera automatically detected the IP of your Vera in your local network?

3) Once your IP is in, do you have a green or a red dot to the right of the Username field? Also, are you set in AUTO or LOCAL (sounds obvious but if REMOTE is set, it won't connect locally).

4) Do you have "Require local http authentication"? If so, could you disable it and try again?

Thanks.
iVera ... control your house!
www.thinkiwi.com

Offline wseverino

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 854
  • Karma: +0/-0
  • Da Man, Da Myth, Da Legend - in his own mind!
Re: iVera can not connect to local host under 1.1.1047
« Reply #2 on: August 22, 2010, 08:11:37 pm »
wseverino, here are couple of questions to try to troubleshoot what could be happening :

1) Did you have iVera Free previously installed on your iPhone? Did it work locally and remotely? No, Bought the full version.

2) When you first started iVera and went to Settings menu, did iVera automatically detected the IP of your Vera in your local network? No it could not locate it.

3) Once your IP is in, do you have a green or a red dot to the right of the Username field? Also, are you set in AUTO or LOCAL (sounds obvious but if REMOTE is set, it won't connect locally). I have it set for local. It works perfectly with remote (cp.mios.com)

4) Do you have "Require local http authentication"? If so, could you disable it and try again? No local authentication.

Thanks.

What are the specific ports iVera is looking I will try opening them up on my router.
My ZWave Network: Too friggin big to list.....

Offline iVera

  • Moderator
  • Jr. Member
  • *****
  • Posts: 96
  • Karma: +0/-0
Re: iVera can not connect to local host under 1.1.1047
« Reply #3 on: August 22, 2010, 08:15:50 pm »
3480 in local
49451 in remote
iVera ... control your house!
www.thinkiwi.com

Offline wseverino

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 854
  • Karma: +0/-0
  • Da Man, Da Myth, Da Legend - in his own mind!
Re: iVera can not connect to local host under 1.1.1047
« Reply #4 on: August 22, 2010, 08:56:11 pm »
OK, for some reason my dLink router was blocking the port access on my wife's iPhone. Weird since I use SquareConnect on my iPod touch with no problems. All is well in the world. One thing you may want to check is how you are reading the lock status. I noticed that iVera shows the locks inverse of what vera states. Example. All my lock show locked in Vera but in iVera they show unlocked.
« Last Edit: August 22, 2010, 09:01:04 pm by wseverino »
My ZWave Network: Too friggin big to list.....

Offline iVera

  • Moderator
  • Jr. Member
  • *****
  • Posts: 96
  • Karma: +0/-0
Re: iVera can not connect to local host under 1.1.1047
« Reply #5 on: August 23, 2010, 09:44:30 am »
Strange indeed but very glad to hear all is working now. WRT door lock status, I will check those again (as apparently something must have changed) and fix with next release. Thanks for the feedback wseverino!
iVera ... control your house!
www.thinkiwi.com

Offline wseverino

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 854
  • Karma: +0/-0
  • Da Man, Da Myth, Da Legend - in his own mind!
Re: iVera can not connect to local host under 1.1.1047
« Reply #6 on: August 23, 2010, 04:49:29 pm »
After I posted this I thought about it. So the way it looks on my screen the unlocked button is blue which I took as unlocked. Did you guys code it to mean if you want this state to press the unlock button?
My ZWave Network: Too friggin big to list.....

Offline iVera

  • Moderator
  • Jr. Member
  • *****
  • Posts: 96
  • Karma: +0/-0
Re: iVera can not connect to local host under 1.1.1047
« Reply #7 on: August 25, 2010, 01:15:59 am »
When it is blue (down), it means the action is set but I guess Unlock/Lock would be more appropriate and consistent with other cells.
iVera ... control your house!
www.thinkiwi.com

Offline zean

  • Jr. Member
  • **
  • Posts: 70
  • Karma: +0/-0
Re: iVera can not connect to local host under 1.1.1047
« Reply #8 on: August 30, 2010, 02:12:03 am »
just finished upgrade to vera 2 and UI4. ivera won't connect locally. works remotely. when i enter local ip address get message "connection error: found no vera server at "xx.xxx.xxx.xxx" on your local network". i am using vera as a gateway.

suggestions?
vera 2 + 3; (2) tz43; (2) vrp03-1lw; (10) vrI06-1lx; ivera

Offline iVera

  • Moderator
  • Jr. Member
  • *****
  • Posts: 96
  • Karma: +0/-0
Re: iVera can not connect to local host under 1.1.1047
« Reply #9 on: August 30, 2010, 08:09:10 pm »
Hello,

   Could you try to go to Settings->Advanced and click on Reset All Settings? iVera should automatically detect your local IP (if you are already on the local network of course).
iVera ... control your house!
www.thinkiwi.com

Offline zean

  • Jr. Member
  • **
  • Posts: 70
  • Karma: +0/-0
Re: iVera can not connect to local host under 1.1.1047
« Reply #10 on: August 31, 2010, 02:33:39 am »
Ok working now. Don't know what problem was.
vera 2 + 3; (2) tz43; (2) vrp03-1lw; (10) vrI06-1lx; ivera

Offline achalhoub

  • Jr. Member
  • **
  • Posts: 83
  • Karma: +0/-0
Re: iVera can not connect to local host under 1.1.1047
« Reply #11 on: December 22, 2010, 03:55:22 am »
Hello,

I have purchased the full version of ivera (1.1.1.047) as well but I am not able to make it work locally. It is working remotely.

I cant go past the following step:

"3) Once your IP is in, do you have a green or a red dot to the right of the Username field? Also, are you set in AUTO or LOCAL (sounds obvious but if REMOTE is set, it won't connect locally)."

the IP Address in ->Settings->Description shows IP Address : Not Available.

how can I set the LOCAL option? I searched everywhere and I am not able to see it.

I can connect via ivera on the internet.

Thank you




Offline iVera

  • Moderator
  • Jr. Member
  • *****
  • Posts: 96
  • Karma: +0/-0
Re: iVera can not connect to local host under 1.1.1047
« Reply #12 on: January 09, 2011, 09:25:26 pm »
Achalhoub, Are you still having issues connecting locally?

Note that iVera's latest version is 1.0.3 (1.1.1047 is your UI4 version from MCV) and the instructions you are reporting are referring to a previous version of iVera. Can you make sure you have the latest version of iVera installed on your device - it's written at the bottom of the Settings window.
iVera ... control your house!
www.thinkiwi.com

Offline achalhoub

  • Jr. Member
  • **
  • Posts: 83
  • Karma: +0/-0
Re: iVera can not connect to local host under 1.1.1047
« Reply #13 on: January 10, 2011, 03:12:08 am »
Hi ,

yes i am still having the issue. I am sorry about the previous mixup. yes the version of iVera is 1.0.3. I am still stuck at the same place .

Thank you for your support.

Offline javene

  • Newbie
  • *
  • Posts: 18
  • Karma: +0/-0
Re: iVera can not connect to local host under 1.1.1047
« Reply #14 on: January 17, 2011, 06:34:58 am »
I have the same issue, Vera not found!!

//Dennis