We have moved at community.getvera.com

Author Topic: Vera Alerts no longer working, ERROR : Error in lua for scenes and events  (Read 862 times)

Offline mtx123

  • Jr. Member
  • **
  • Posts: 93
  • Karma: +2/-1
I added a notification to a new device, and after that performed a message override in Vera Alerts.
Now the alerts stopped working. I see a blue bar in the screen (Vera Edge UI7) with an error message: ERROR : Error in lua for scenes and events

If I try to send a testmessage directly from the Vera Alerst page, it does arrive.

In the apps screen I see that I have version 7.21

How to solve this ?

Offline RichardTSchaefer

  • Moderator
  • Master Member
  • *****
  • Posts: 10091
  • Karma: +764/-143
Are you on the latest vera firmware ? 

Offline mtx123

  • Jr. Member
  • **
  • Posts: 93
  • Karma: +2/-1
Are you on the latest vera firmware ?

I just checked, I am not at the latest Vera firmeware:
Running Version    1.7.2043
Latest Version            1.7.2406

Usually I try not to be the first in upgrading to new releases (because of possible bugs), but if this is related to my alerts problem, I will update.

Offline RichardTSchaefer

  • Moderator
  • Master Member
  • *****
  • Posts: 10091
  • Karma: +764/-143
You can also restore from a backup before 7.21 was updated ... and turn off auto updates.

Offline mtx123

  • Jr. Member
  • **
  • Posts: 93
  • Karma: +2/-1
I tried several backups, but all had Vera alerts 7.21, so to avoid to go too far back in time,
I decided to upgrade Vera. It it seems to work now !

Is the version 7.21 not compatible with older Vera versions ?
And how can I prevent this type of mismatch in the future ?

Offline RichardTSchaefer

  • Moderator
  • Master Member
  • *****
  • Posts: 10091
  • Karma: +764/-143
Turn off auto update  and only update when you are sure you want the latest software ... and yes ... as MCV keeps making changes that are NOT backwards compatible ...  there are often plugin versions that are tied to firmware versions.