We have moved at community.getvera.com

Author Topic: UI7 Version 7.0.20b  (Read 13372 times)

Offline wezley69

  • Sr. Member
  • ****
  • Posts: 289
  • Karma: +6/-6
Re: UI7 Version 7.0.20b
« Reply #15 on: February 02, 2017, 08:24:54 pm »
Applied the second beta and it works.  I had to revert firmware and backup prior to last beta.  Looks ok.  I have never had any devices or scenes recognized until now.  I can confirm there are no crashes on the latest beta "for me".

Offline BOFH

  • Sr. Hero Member
  • ******
  • Posts: 2409
  • Karma: +112/-140
Re: UI7 Version 7.0.20b
« Reply #16 on: February 02, 2017, 10:11:40 pm »
Seconded. No need to do a zwave backup, run firmware upgrade back to factory settings and restore backup like i Had to do the last 2 firmware versions on my Vera 3. Which cost me my panels and my multiswitch. This one ran right through and found all my eligible devices and scenes. Which Alexa discovered.

Major improvement on this beta vs the last... Great job GetVera developers. You earned yourself another paintball bout.  8)
Vera3 UI5 UI7 Edge Plus
Trane TZEMT400AB32 | Schlage BE369 FE599 | GE 45601 45602 45603 45604 45606 45609 45631 | Intermatic HA01C HA03C HA05C HA07C CA600 CA3000 | Aeon DSC06106 | Telguard GDC1 | Foscam FI8910W FI8905W FI9821W | D-Link 930L | Wanscam JW0011 | ZModo ZPIBH13W

Offline ggibeau

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
Re: UI7 Version 7.0.20b
« Reply #17 on: February 03, 2017, 08:39:56 am »
Have had my VeraLite for a few years now - and it has done everything I needed it to.  Was excited to see I could get it to work with my Echo.  d/l'ed the latest beta - and now I have a brick with a blue blinking light and a solid red one.  :o

Have tried all the tricks with trying to SSH into the device (I have it with the orange light blinking), set IP addressing to /24 on my PC (and it does recognize Network 10 (any other class C addressing schemes as referenced in other posts on the forums do not elicit a "network found")) but I cannot ping nor SSH into

Any thoughts??

...EDIT... - found another posting - and was able to get this to work as far as actually getting telnet into the device.  Still working on getting it back to life ;-).

1. Connect your computer directly into the LAN port on the Vera lite unit (really not needed.  As long as both units are hard wired to same switch you just need to change your pc IP, cannot do this wireless)
2. Put a static IP on your computer ( and the gateway . You Can find
more information about it at step 8.
3. Plug the power adapter in Vera and when the blue light starts blinking, press and release
the reset button - blue light should be blinking fast
4. Open a command prompt and telnet into the unit: telnet
Run these commands:
flash_eraseall -j /dev/mtd7
echo b > /proc/sysrq-trigger

....EDIT 2.....

Finally obtained solid blue light and solid red and blinking green.  Could not get back in via previous IP - but noticed the LAN light would at least engage when I plugged and unplugged the patch cable. 

Brought up Wireshark to see if I could see anything and noticed I was getting DHCP Discovery packets from an unknown MAC address - assumed it was VeraLite. 

Downloaded TFTPD64 and set up an impromptu DHCP server - Vera grabbed an address right away ( as this was the scope I setup) and now I can at least HTTP back into it. ;-)

Now I have a "Luup engine is taking longer to reload" screen

Will do some more digging and see what happens...

...UPDATE 3...

After a bit more fiddling - put it back on the home network - let it boot - and now I can HTTP into it - although most of my devices are missing (had to leave - so maybe it is syncing).

 I do have a backup I created before attempting the update - - may try to update again and then restore backup.  Keeping fingers crossed ;-)



« Last Edit: February 03, 2017, 11:38:16 am by ggibeau »

Offline Nobber

  • Jr. Member
  • **
  • Posts: 53
  • Karma: +0/-0
Re: UI7 Version 7.0.20b Issues
« Reply #18 on: February 03, 2017, 08:49:33 am »
Oh dear since updating firmware I am now getting cant detect device issues across my network,has anyone else experienced these, looks like I'm rolling back

Offline antrock

  • Sr. Newbie
  • *
  • Posts: 40
  • Karma: +1/-0
Re: UI7 Version 7.0.20b
« Reply #19 on: February 03, 2017, 09:02:02 am »
Bricked my VeraLite as well. Blue light blinking... Not a good start to a weekend.

Offline Opt2bout

  • Jr. Member
  • **
  • Posts: 59
  • Karma: +3/-0
Re: UI7 Version 7.0.20b
« Reply #20 on: February 03, 2017, 12:03:24 pm »
2558 on veraplus unit updated...had to physically power down/up after the update.  Then the problems with 2552 started (Luup reloads and reloads).  I did another factory reset, six times on the reset switch...firmware stays with the most recent updated version (2558) and I set it back up again.  Did a restore, ... Vera's NEST plugin needs reauthorizing...this time though after being authorized, it works unlike 2552.  But door locks and sensors are all gone...deleted even though they were in the backup I restored from.

So I tried again...factory reset...connected to vera to add the controller back...set it up...skipped the wizard and restored...made sure to select Zwave in the restore.  Protected devices are back.  Scenes started running normally (I have a fan on a heat stove that runs based on NEST room temp, etc. that didn't work in 2552 at all...kept looping on/off/on/off).

Now like a few have reported, I get several devices that aren't connecting.  They come and go.  I can turn the light/device on/off and it works, but after a few minutes the UI7 interface says that the device is not responding again.

Just a note to anyone else...This beta may or may not have any direct affect on the Alexa Skill...but I was able to get the Alexa skill (updated) to work on an older firmware device.  Most of the fixes for Alexa are external to the units themselves...before their Alexa skill update (alexa.getvera.com) I would get no devices and tech support would keep repeating "...make sure you device, room and scenes do not include any special characters and then reboot..." (must have been a canned response).  As soon as Vera announced the update to their skill, all I did was follow the activate link (again, without changing firmware) and all of my devices and scenes showed up!  This tells me that the changes/fixes are on their web app (skill) not all in the firmware (?)

Offline rcc1123

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
Re: UI7 Version 7.0.20b
« Reply #21 on: February 03, 2017, 02:02:13 pm »
Same problem and error with my VeraLite

Offline Aaron

  • Hero Member
  • *****
  • Posts: 1985
  • Karma: +61/-193
Re: UI7 Version 7.0.20b
« Reply #22 on: February 03, 2017, 06:36:51 pm »
Last night installed VP fw 1.7.2558 and now getting an error I've never seen before...   "cannot write user data - System error"  see attached screenshot.

Offline fuzzysb

  • Sr. Newbie
  • *
  • Posts: 30
  • Karma: +0/-1
Re: UI7 Version 7.0.20b
« Reply #23 on: February 04, 2017, 08:07:19 am »
i have had this plenty of times, the root fs is 98% full makes you think you have space, but you don't, use standard linux tools to look for whats taking up the space. usually its down to the backups, i delete all 5 then take a fresh backup. its because one of thos backups is way larger than it should be

Offline tt55du

  • Full Member
  • ***
  • Posts: 211
  • Karma: +0/-0
Re: UI7 Version 7.0.20b
« Reply #24 on: February 19, 2017, 10:35:40 pm »
Last night installed VP fw 1.7.2558 and now getting an error I've never seen before...   "cannot write user data - System error"  see attached screenshot.

I'm getting the same error and it's drivibg me batty, all LUA scripts shuts down until I reload LUUP
@ Arron what files did you yo remove?  do you have a How-To Link?  I've been trying to find it.

I also found this post that says that a full /rom and /mios is okay.

Here is my df output

root@MiOS_xxxxxxxx:~# df
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/root                 4608      4608         0 100% /rom
tmpfs                    31240      1672     29568   5% /tmp
tmpfs                      512         0       512   0% /dev
/dev/mtdblock7           11264      5356      5908  48% /overlay
overlayfs:/overlay       11264      5356      5908  48% /
/dev/mtdblock8            6144      6144         0 100% /mios

I opened up a ticket, support said they cleaned up some files, but the error continues
« Last Edit: March 05, 2017, 10:47:46 am by tt55du »