Author Topic: Pool and Spa Heater Control??  (Read 583 times)

Offline Sammy2

  • Sr. Member
  • ****
  • Posts: 433
  • Karma: +1/-3
Pool and Spa Heater Control??
« on: March 30, 2017, 10:48:59 am »
With the generous assistance of others on this forum I now have my new VS pump controlled with relays and Vera. I know that everything else in my Jandy Panel is controlled with relays or sets of relays. The only thing that isn't, from what I can see, is the Pentair heater, which is controlled by a two-wire data cable connected directly to the my iAqualink Panel. I will post the heater model number when I am home to read it but am interested in controlling it via Vera if that is a possibility. The missing links would be connecting that data cable to something that connects to Vera and the logic to control it.

The reason for this inquiry is that currently I use Autelis with the Vera Plugin to bridge the gap but my Autelis unit is on the fritz for whatever reason, I'm currently troubleshooting it but they're OOS for warranty replacement. Because of this, I'm back to controlling everything but pump speed selection from the wired RS OneTouch (really more than one touch, that's a misnomer) panel on the wall next to the door from the family room into the back yard.

I've come to realize that even though Autelis works great it may not be the best solution for the long haul and incorporating the pool completely into Vera seems to be the way to go because I can change out equipment as required without having to worry about inter-operability with my Jandy Panel; of course there's the inter-operability with Vera to replace that.

Has anyone done this?

Any suggestions?

Is this worth the effort even?

TIA

Offline rstrouse

  • Hero Member
  • *****
  • Posts: 769
  • Karma: +25/-6
Re: Pool and Spa Heater Control??
« Reply #1 on: March 30, 2017, 11:07:45 am »
Sammy,

It is probably a MiniMax or MasterTemp depending on its age.  Doesn't your iAqualink control this heater?
1xVera3 1.7.619, 4xLinear WT00Z, 3xLinear WS15Z, 1xLeviton VRCZ4, 10xCooper RF9540, 1xLeviton VRFI10, 1xLeviton VP00R, 2xLinear GD00Z-4, 1xGE/Jasco 45612, 1xGE/Jasco 45610,  4xGE/Jasco 45605, 2xYale YRD220-ZW-619, 1xCaddx NX584, Autelis Intellitouch Pool Control, OpenSprinkler

Offline Sammy2

  • Sr. Member
  • ****
  • Posts: 433
  • Karma: +1/-3
Re: Pool and Spa Heater Control??
« Reply #2 on: March 30, 2017, 11:30:37 am »
Sammy,

It is probably a MiniMax or MasterTemp depending on its age.  Doesn't your iAqualink control this heater?

Thanks for your quick reply, Robert. And thanks for all your assistance with getting the MIMO2+ switching changed from momentary to latched!

AFAIK, the heater was installed with the pool which was in 2003. By Google search, the image returned is most definitely the Master Temp.

The iAqualink does control the heater and it is connected with a 2-wire data cable. My problem right now is with the Autelis unit. It will power up and connect to my local network but it is not talking to my iAqualink panel right now for whatever reason. This weekend I should have the time to troubleshoot continuity on the cable connecting the two devices but I feel that is not the problem but rather the problem is with the Autelis itself.

After getting the VS pump installed Autelis was not talking to Jandy so I re-connected the RS One Touch panel and it works just fine. I'm glad I hadn't the time to remove that panel yet so I don't have to go outside to control the pool in service mode. I was going to affix a cheap android tablet where the RS One Touch is so I could control Vera from there actually but need to get power there to keep the tablet powered so that little project is on the long list.
« Last Edit: March 30, 2017, 11:32:47 am by Sammy2 »

Offline rstrouse

  • Hero Member
  • *****
  • Posts: 769
  • Karma: +25/-6
Re: Pool and Spa Heater Control??
« Reply #3 on: March 30, 2017, 11:41:03 am »
You know that you can have any number of panels, including the one touch hooked up in conjunction with the Autelis.   If the connections are good between the panel and the green terminal block is properly seated on the Autelis, I would say that the Autelis is indeed having a problem.  However, the circuit is very simple on the 485 bus and a loose connection is a very likely suspect.  If you have your wire running through conduit under the pad, make sure the conduit is not full of water.
1xVera3 1.7.619, 4xLinear WT00Z, 3xLinear WS15Z, 1xLeviton VRCZ4, 10xCooper RF9540, 1xLeviton VRFI10, 1xLeviton VP00R, 2xLinear GD00Z-4, 1xGE/Jasco 45612, 1xGE/Jasco 45610,  4xGE/Jasco 45605, 2xYale YRD220-ZW-619, 1xCaddx NX584, Autelis Intellitouch Pool Control, OpenSprinkler

Offline Sammy2

  • Sr. Member
  • ****
  • Posts: 433
  • Karma: +1/-3
Re: Pool and Spa Heater Control??
« Reply #4 on: March 30, 2017, 12:15:34 pm »
You know that you can have any number of panels, including the one touch hooked up in conjunction with the Autelis.   If the connections are good between the panel and the green terminal block is properly seated on the Autelis, I would say that the Autelis is indeed having a problem.  However, the circuit is very simple on the 485 bus and a loose connection is a very likely suspect.  If you have your wire running through conduit under the pad, make sure the conduit is not full of water.

My Autelis is in a waterproof electrical enclosure box that is 12" square x 6" deep and attached directly to the back of the Jandy Control Subpanel. This box was not opened at all during pump installation. The MIMO2+'s are in here too now along with a receptacle to power them and the WiFi Bridge for the Autelis. The connection between the Jandy Board and the Autelis is via a direct burial 5-wire 16 gage sprinkler control wire with the white colored insulation cable not used and the blue one used in place of black but all other colors match and are connected per Autelis instructions. This control wire is sealed where it enters and exits each box and is not wet or corroded. This has been working fine for six months now.

I tightened all the terminal lugs at both the Autelis and the Jandy 4-wire terminal block. I recently added back in the 22 gage control wires to the RS8 so I could get back that control at least. This weekend, when I can work in light, I am going to run continuity tests on the cable connecting the two to see if somehow it is the cable but I seriously doubt that it is. The Autelis gets power but not data from the Jandy.


After this testing is done I can report back to Autelis the status and complete the RMA but they are OOS right now so even if I do send it in, who knows when I will be able to replace it. Hence the search for something more universal so to speak.

Offline AntRib

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-2
Re: Pool and Spa Heater Control??
« Reply #5 on: May 04, 2017, 04:28:43 am »
Reading this I realize how poor my system was when I rented the house in Cote d'Azur without home control.  ;D :-\
Now the guests are 100% satisfied with plugs, pool, sauna etc. It brought less expenses.
« Last Edit: May 05, 2017, 12:09:55 pm by AntRib »