Author Topic: Ecolink Garage Tilt Sensor, Vera Plus, UI7  (Read 280 times)

Offline Eastside

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
Ecolink Garage Tilt Sensor, Vera Plus, UI7
« on: April 06, 2017, 03:20:00 pm »
I am trying to add an Ecolink Garage Door Tilt Sensor (Z-Wave Plus version) to my Vera Plus Controller.  I have Excluded the Device to start, then included it (several times).  it always gets added as two devices as shown in this picture:

http://s50.photobucket.com/user/EastsideGuy01/media/Garage%20Sensor%20Device_zpsb45slnqq.jpg.html

I have seen other posts (http://forum.micasaverde.com/index.php/topic,38657.msg289291.html#msg289291) that suggest there is a well defined set of steps to solve the problem of the device registering as a motion sensor versus a tilt sensor.  The parameters settings are already set to the suggested settings:

(http://i50.photobucket.com/albums/f307/EastsideGuy01/Garage%20Sensor%20Device_zpsb45slnqq.jpg)

The difference is on the Variables page.  The settings that are suggested to change, NodeInfo and PollingState and ChangeState don't exist on my installation.

(http://i50.photobucket.com/albums/f307/EastsideGuy01/Garage%20Sensor%20Variables_zpswwymvuq4.jpg)

My current situation is the device is added, it shows as two devices and does not show any change state when the device is tilted and I can't seem update the settings based on other posts to fix the problem.  Anyone have any suggestions?
« Last Edit: April 06, 2017, 04:52:03 pm by Eastside »

Offline Don Phillips

  • Hero Member
  • *****
  • Posts: 517
  • Karma: +11/-4
Re: Ecolink Garage Tilt Sensor, Vera Plus, UI7
« Reply #1 on: April 07, 2017, 07:56:04 pm »
I do not have those devices, however, this may be of help: http://wiki.micasaverde.com/index.php/Luup_Device_Categories.
Vera 3, UI7 1.7.919, CT101 t-stat, Everspring motion detector, GE/Jasco switch, Leviton outlet, AeonLabs door sensor, Insteon garage control, Blue Iris, Sricam SP011, iPhone locator, APCUPSD, VeraMate, VeraAlerts, PLEG, House Modes, Countdown Timer, DVR, Virtual & Multi Switch, Weather, Sys. Mon.

Offline davidlee

  • Jr. Member
  • **
  • Posts: 54
  • Karma: +0/-0
Re: Ecolink Garage Tilt Sensor, Vera Plus, UI7
« Reply #2 on: April 14, 2017, 03:14:18 pm »
Exact same observations / problem.

I added directly at the Vera3 because I did not see the device listed in the add devices menu.

You would think that for a device that has been available since 2014 that it would work properly in Vera by now.

When tilted I get a push notification from the generic IO, nothing from the door / window sensor.  Nothing on the devices page updates to indicate tripped.

I also don't get the manufacturerinfo info in vera, it shows as 330,4,3 the info from Ecolink shows Manufacturer ID of 0x014A ( 330 dec ), Product Type 0x0001, Device Product ID 0x03 ( tilt sensor ), so I would expect to see a 330,1,3, but I'm no expert.
So Vera should be able to properly identify the device as an Ecolink Tilt Sensor and display it as a single device, but it does not.

Offline Don Phillips

  • Hero Member
  • *****
  • Posts: 517
  • Karma: +11/-4
Re: Ecolink Garage Tilt Sensor, Vera Plus, UI7
« Reply #3 on: April 14, 2017, 07:04:22 pm »
I have been using this plug-in - makes controlling the garage door much easier: http://apps.mios.com/plugin.php?id=2998
Vera 3, UI7 1.7.919, CT101 t-stat, Everspring motion detector, GE/Jasco switch, Leviton outlet, AeonLabs door sensor, Insteon garage control, Blue Iris, Sricam SP011, iPhone locator, APCUPSD, VeraMate, VeraAlerts, PLEG, House Modes, Countdown Timer, DVR, Virtual & Multi Switch, Weather, Sys. Mon.

Offline JTBERR

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
Re: Ecolink Garage Tilt Sensor, Vera Plus, UI7
« Reply #4 on: May 05, 2017, 09:48:33 pm »
I have the exact same problem as the original OP.  Does anyone have an answer?