Author Topic: Is it working on Vera Plus with firmware 1.7.2608?  (Read 1256 times)

Offline ausf

  • Newbie
  • *
  • Posts: 7
  • Karma: +0/-0
Is it working on Vera Plus with firmware 1.7.2608?
« on: April 11, 2017, 02:19:59 am »
Hello Vera users,

a couple of months ago I tested this plugin (last version, 1.4) on my Vera Plus and it was working perfectly, including the discovery feature. Now that I have time to work again on the configuration of my Vera (and it has updated the firmware a couple of times, if I'm not wrong...) the plugin doesn't work anymore. The discovery feature doesn't work and I can't control a player also setting manually the configuration (I have tried with more than one player that were previously working). I've looked into the Vera log, but I can't identify any evident failure point. Before starting to look into the plugin code, I'm asking if someone has any experience using this plugin with the very last firmware version.

Thank you!

Offline Zoro

  • Full Member
  • ***
  • Posts: 154
  • Karma: +14/-3
Re: Is it working on Vera Plus with firmware 1.7.2608?
« Reply #1 on: April 11, 2017, 06:09:08 am »
Hello Vera users,

a couple of months ago I tested this plugin (last version, 1.4) on my Vera Plus and it was working perfectly, including the discovery feature. Now that I have time to work again on the configuration of my Vera (and it has updated the firmware a couple of times, if I'm not wrong...) the plugin doesn't work anymore. The discovery feature doesn't work and I can't control a player also setting manually the configuration (I have tried with more than one player that were previously working). I've looked into the Vera log, but I can't identify any evident failure point. Before starting to look into the plugin code, I'm asking if someone has any experience using this plugin with the very last firmware version.

Thank you!

Hi --

  Not sure what plugin you're talking about.

Z

Offline RichardTSchaefer

  • Master Member
  • *******
  • Posts: 10091
  • Karma: +763/-142
Re: Is it working on Vera Plus with firmware 1.7.2608?
« Reply #2 on: April 11, 2017, 08:20:37 am »
Most likely the DLNA Media Controller plugin  ... since this is the forum for that plugin.

Offline ausf

  • Newbie
  • *
  • Posts: 7
  • Karma: +0/-0
Re: Is it working on Vera Plus with firmware 1.7.2608?
« Reply #3 on: April 11, 2017, 08:23:10 am »
Yes, I'm talking about the plugin discussed in this section of the forum, the "DLNA Media Controller".

Thanks!

Offline RichardTSchaefer

  • Master Member
  • *******
  • Posts: 10091
  • Karma: +763/-142
Re: Is it working on Vera Plus with firmware 1.7.2608?
« Reply #4 on: April 11, 2017, 08:32:44 am »
DLNA uses many not so common network protocols that place restrictions on your router and LAN.

In particular it use UDP sockets and multi-casting.
Some times you need to configure your router and/or switches to support multi-casting.
Note some multi-casting (PlugAndPlay) devices have caused problems with Vera and required Vera to be placed on it's own LAN.
The motivation was to keep Vera from receiving the multi-casts .... because there were to many for it to keep up with.
But once moved Vera and (DLNA Plugin) could no longer communicate with those PlugAndPlay devices.


Offline ausf

  • Newbie
  • *
  • Posts: 7
  • Karma: +0/-0
Re: Is it working on Vera Plus with firmware 1.7.2608?
« Reply #5 on: April 11, 2017, 08:50:12 am »
Thank you for the reply RichardTSchaefer! My problem is that I have not changed anything in the topology of my home LAN. Since the only thing that changed from the setup in which the DLNA plugin was working is the version of the firmware of the Vera Plus, I was thinking to an incompatibility introduced in the last version. So I was trying to check on the forum if someone has the plugin working with firmware 1.7.2608...

Offline Don Phillips

  • Hero Member
  • *****
  • Posts: 1306
  • Karma: +34/-32
Re: Is it working on Vera Plus with firmware 1.7.2608?
« Reply #6 on: April 11, 2017, 07:07:49 pm »
I do not use that plug-in but have you tried uninstalling and reinstalling the plug-in?
Vera 3, 1.7.1030, CT101, Everspring motion sensor, GE/Jasco switch, Leviton outlet, AeonLabs sensor, NuTone garage door, Blue Iris, Sricam SP011, iPhone locator, APCUPSD, VeraMate, VeraAlerts, PLEG, House Modes, Countdown Timer, DVR, Virtual/Multi Switch, Weatherunderground, LB60Z-1 bulb, Hue, Alexa

Offline ausf

  • Newbie
  • *
  • Posts: 7
  • Karma: +0/-0
Re: Is it working on Vera Plus with firmware 1.7.2608?
« Reply #7 on: April 12, 2017, 02:26:55 am »
Thanks Don for your reply. Yes I've tried to uninstall and re-install the plugin, but nothing changes...

Yesterday I focused my attention on the detection of the UPnP players on the network, putting a few log commands in the Lua code. It fails with a "timeout" error message. I've tried to extend the original 5 seconds timeout value on the UDP messages reception, but without success. I have verified, using a tool on a PC that the players on the network are correctly publishing their presence, so it's something related to the Vera Plus. Enabling the "detection patch" included in the plugin doesn't help.

Offline ausf

  • Newbie
  • *
  • Posts: 7
  • Karma: +0/-0
Re: Is it working on Vera Plus with firmware 1.7.2608?
« Reply #8 on: April 18, 2017, 02:42:00 am »
Is there someone who can check on his Vera Plus with the last firmware if the DNLA media controllerPlugin is able to send UDP messages to the wired network? I have used a  messages tracer on the network and I can't see M-SEARCH messages coming from the Vera IP when I start the devices search function... Or maybe a Linux network expert could help me to check if the configuration in my Vera is OK (but I've not directly changed any parameter)...

Thank you for your help. I can use the Squeezebox control plugin with a piCorePlayer device, but the DNLA media controller was able to manage also to my Samsung TVs and an Eminent WiFi streamer EM7410...

Offline ausf

  • Newbie
  • *
  • Posts: 7
  • Karma: +0/-0
Re: Is it working on Vera Plus with firmware 1.7.2608?
« Reply #9 on: April 24, 2017, 04:47:27 am »
OK, I'm officially going crazy. Today I've tested again the DLNA plugin and it works again! The Vera Plus firmware is still at 1.7.2608 and I've NOT changed any system or LAN configuration. The only thing that I've done is to start using the Squeezebox control plugin to manage a PiCorePlayer, but I think that this is totally unrelated with the issue on UPnP. Now the players in the home network are detected again and - of course - I can see the M-SEARCH message issued by the Vera spying the UDP traffic.

I'd really understand what happened to the Vera Plus with UPnP!!!