We have moved at community.getvera.com

Author Topic: Vera Alerts UI not Loading  (Read 1472 times)

Offline kyle.dawson

  • Full Member
  • ***
  • Posts: 153
  • Karma: +1/-1
Vera Alerts UI not Loading
« on: April 19, 2017, 11:55:56 am »
When I try to add/modify new alerts, the screen keeps clocking, but nothing shows up for data. I get main UI but no data. I get data on all tabs of UI except the "Configure Notifications"


I see this on main screen:

Error executing function vaInit(): String contains an invalid character


I am on UI 7 and Vera Alerts 7.21 with auto update.

I do get alerts for any existing alert I setup but I can not see, modify or add new alerts. 

« Last Edit: April 19, 2017, 02:14:52 pm by kyle.dawson »
VeraPlus(1), Sonos(3), GE Switch(30), GE Dimmer(5), GE Zwave Outlet(3), MimoLight Garage Door(1),Neo Motion(6), Door Sensors(3) Camera(9), Honeywell Thermostat(2), Google Home(4), Alexa(4), Google Chrome Cast(5)  - Driven via ALTUI

Offline RichardTSchaefer

  • Moderator
  • Master Member
  • *****
  • Posts: 10091
  • Karma: +764/-143
Re: Vera Alerts UI not Loading
« Reply #1 on: April 19, 2017, 03:10:02 pm »
That should have been fixed in 7.21

Can you check  Apps -> Develop Apps -> Luup Files
How many and what are the files that start with:

J_VeraAlert
« Last Edit: April 19, 2017, 03:18:55 pm by RichardTSchaefer »

Offline kyle.dawson

  • Full Member
  • ***
  • Posts: 153
  • Karma: +1/-1
Re: Vera Alerts UI not Loading
« Reply #2 on: April 19, 2017, 03:17:17 pm »
Thanks for reply, do you have ETA?
VeraPlus(1), Sonos(3), GE Switch(30), GE Dimmer(5), GE Zwave Outlet(3), MimoLight Garage Door(1),Neo Motion(6), Door Sensors(3) Camera(9), Honeywell Thermostat(2), Google Home(4), Alexa(4), Google Chrome Cast(5)  - Driven via ALTUI

Offline RichardTSchaefer

  • Moderator
  • Master Member
  • *****
  • Posts: 10091
  • Karma: +764/-143
Re: Vera Alerts UI not Loading
« Reply #3 on: April 19, 2017, 03:19:19 pm »
I updated my message

Offline kyle.dawson

  • Full Member
  • ***
  • Posts: 153
  • Karma: +1/-1
Re: Vera Alerts UI not Loading
« Reply #4 on: April 19, 2017, 03:23:20 pm »
I already have 7.21, is this same issue or I should edit some files to fix manually?

I have 5 files, screen file attached.

VeraPlus(1), Sonos(3), GE Switch(30), GE Dimmer(5), GE Zwave Outlet(3), MimoLight Garage Door(1),Neo Motion(6), Door Sensors(3) Camera(9), Honeywell Thermostat(2), Google Home(4), Alexa(4), Google Chrome Cast(5)  - Driven via ALTUI

Offline kyle.dawson

  • Full Member
  • ***
  • Posts: 153
  • Karma: +1/-1
Re: Vera Alerts UI not Loading
« Reply #5 on: April 19, 2017, 03:35:05 pm »
Here is what files I have:

/# ls -alrt /etc/cmh-ludl/J_VeraAler*
-rw-r--r--    1 root     root         18315 May 17  2016 /etc/cmh-ludl/J_VeraAlert-UI7.js.lzoenc
-rw-r--r--    1 root     root                 0 May 17  2016 /etc/cmh-ludl/J_VeraAlert-UI6.js.lzoenc
-rw-r--r--    1 root     root                 0 May 17  2016 /etc/cmh-ludl/J_VeraAlert-UI5.js.lzoenc
-rw-r--r--    1 root     root         26179  Jan  5 13:05 /etc/cmh-ludl/J_VeraAlerts.js.lzo
-rw-r--r--    1 root     root                 7  Jan  5 13:05 /etc/cmh-ludl/J_VeraAlertProfileTemplates.js.lzo
lrwxrwxrwx    1 root     root            25 Feb 22 14:03 /etc/cmh-ludl/J_VeraAlert.js.lzoenc -> J_VeraAlert-UI7.js.lzoenc
VeraPlus(1), Sonos(3), GE Switch(30), GE Dimmer(5), GE Zwave Outlet(3), MimoLight Garage Door(1),Neo Motion(6), Door Sensors(3) Camera(9), Honeywell Thermostat(2), Google Home(4), Alexa(4), Google Chrome Cast(5)  - Driven via ALTUI

Offline RichardTSchaefer

  • Moderator
  • Master Member
  • *****
  • Posts: 10091
  • Karma: +764/-143
Re: Vera Alerts UI not Loading
« Reply #6 on: April 19, 2017, 04:30:33 pm »
Remove all but the last.
You in particular you need to delete the file J_VeraAlerts.js.lzo witch is an old parch that is being loaded in preference to the last file.

Offline wmichael3

  • Newbie
  • *
  • Posts: 6
  • Karma: +0/-0
Re: Vera Alerts UI not Loading
« Reply #7 on: April 19, 2017, 07:21:10 pm »
The same problem happened to me today - alerts stopped sending and the UI will no longer open.  Now there are just three tabs - Control, Edit, Advanced, and if I click on Edit, I get "Opening vaInit..." perpetually.  I'm using a VeraLite on UI5.  I checked for the files mentioned in this thread and removed them.  No change.  Then I uninstalled VeraAlerts completely, then removed all J_VeraAlert* files then reinstalled the app - 7.21.  No change.  Incidentally, I noticed that rts-services.com appears to be down - taking too long to respond error.  Related?

Here is what I have right now.  Help!

-rw-r--r--    1 root     root             7 Apr 19 17:11 /etc/cmh-ludl/J_VeraAlertProfileTemplates.js.lzo
-rw-r--r--    1 root     root         26179 Apr 19 17:11 /etc/cmh-ludl/J_VeraAlerts.js.lzo

Offline wmichael3

  • Newbie
  • *
  • Posts: 6
  • Karma: +0/-0
Re: Vera Alerts UI not Loading
« Reply #8 on: April 19, 2017, 07:46:24 pm »
A "never-mind" message to my last message - found a thread that says new version incompatible with UI5 and another old message that had a link to install an old version.  Working on it now.  Foiled by auto-update.

This is the link I used to pull down a UI5 version:
http://YourVeraIPAddress:3480/data_request?id=action&serviceId=urn:micasaverde-com:serviceId:HomeAutomationGateway1&action=CreatePlugin&PluginNum=3008&Version=30461

Dialog seems restored, says version is 6.43.  Now working on setting it up again.  The Notification Configuration screen is blank however - I don't remember that from before.

Offline RichardTSchaefer

  • Moderator
  • Master Member
  • *****
  • Posts: 10091
  • Karma: +764/-143
Re: Vera Alerts UI not Loading
« Reply #9 on: April 20, 2017, 10:35:47 am »
It would be best if you restored from a backup before things were corrupted.

Offline kyle.dawson

  • Full Member
  • ***
  • Posts: 153
  • Karma: +1/-1
Re: Vera Alerts UI not Loading
« Reply #10 on: April 24, 2017, 12:31:09 pm »
I got further, but new error:




VeraPlus(1), Sonos(3), GE Switch(30), GE Dimmer(5), GE Zwave Outlet(3), MimoLight Garage Door(1),Neo Motion(6), Door Sensors(3) Camera(9), Honeywell Thermostat(2), Google Home(4), Alexa(4), Google Chrome Cast(5)  - Driven via ALTUI

Offline RichardTSchaefer

  • Moderator
  • Master Member
  • *****
  • Posts: 10091
  • Karma: +764/-143
Re: Vera Alerts UI not Loading
« Reply #11 on: April 24, 2017, 12:33:15 pm »
That message indicated it found a scene that was corrupted ... marked as encoded but it was not ... no problem Vera Alerts will fix it!

Offline kyle.dawson

  • Full Member
  • ***
  • Posts: 153
  • Karma: +1/-1
Re: Vera Alerts UI not Loading
« Reply #12 on: April 24, 2017, 01:21:03 pm »
I have reboot the device and still have same issue.  Does not appear to have fixed, how I can fix it manually?  Which scene is bad?  I did not see scene name in error.




VeraPlus(1), Sonos(3), GE Switch(30), GE Dimmer(5), GE Zwave Outlet(3), MimoLight Garage Door(1),Neo Motion(6), Door Sensors(3) Camera(9), Honeywell Thermostat(2), Google Home(4), Alexa(4), Google Chrome Cast(5)  - Driven via ALTUI

Offline kyle.dawson

  • Full Member
  • ***
  • Posts: 153
  • Karma: +1/-1
Re: Vera Alerts UI not Loading
« Reply #13 on: April 27, 2017, 01:24:27 pm »
Richard,

   Any suggestion on corruption?  It was not fixed by VeraAlerts.
VeraPlus(1), Sonos(3), GE Switch(30), GE Dimmer(5), GE Zwave Outlet(3), MimoLight Garage Door(1),Neo Motion(6), Door Sensors(3) Camera(9), Honeywell Thermostat(2), Google Home(4), Alexa(4), Google Chrome Cast(5)  - Driven via ALTUI

Offline kyle.dawson

  • Full Member
  • ***
  • Posts: 153
  • Karma: +1/-1
Re: Vera Alerts UI not Loading
« Reply #14 on: June 04, 2017, 06:59:44 pm »
Richard,

    I have rebooted several times but still unable to get UI to show up.  Unable to use the plugin at all now, without the ability to see or edit anything, any help would be grateful.
VeraPlus(1), Sonos(3), GE Switch(30), GE Dimmer(5), GE Zwave Outlet(3), MimoLight Garage Door(1),Neo Motion(6), Door Sensors(3) Camera(9), Honeywell Thermostat(2), Google Home(4), Alexa(4), Google Chrome Cast(5)  - Driven via ALTUI