Author Topic: Debug your Configuration  (Read 3431 times)

Offline Juupjuup

  • Newbie
  • *
  • Posts: 19
  • Karma: +0/-0
Re: Debug your Configuration
« Reply #45 on: September 09, 2017, 12:55:06 pm »
OK, I deleted the database file and now the dashboard shows my Vera along with all the devices however when I ask GH to tell VC to do something it tells me that its not connected to my account even though VC site and Google show the app connected to my account.  Any suggestions?

Offline RichardTSchaefer

  • Moderator
  • Master Member
  • *****
  • Posts: 9734
  • Karma: +737/-136
    • RTS Services Plugins
Re: Debug your Configuration
« Reply #46 on: September 09, 2017, 08:50:19 pm »
On your mobile device ...
Open Google Home app.
Ask it "talk to vera concierge"
There should be a memu entry ... "About Vera Concierge"
There there is a button to "Link" your account.

Offline Juupjuup

  • Newbie
  • *
  • Posts: 19
  • Karma: +0/-0
Re: Debug your Configuration
« Reply #47 on: September 09, 2017, 10:11:18 pm »
I just tried that and it answered verbally:

'I'm really sorry about this but Vera Concierge isn't set up to work on devices set up with Canadian English'.

I'm located in Toronto Canada.

Offline Juupjuup

  • Newbie
  • *
  • Posts: 19
  • Karma: +0/-0
Re: Debug your Configuration
« Reply #48 on: September 11, 2017, 03:16:46 pm »
OK, so I did some additional fiddling around and was able to get past the language issue by updating the language on all of my units from Canadian English to US English so I'm no longer getting the language error however I'm still not out of the woods yet.

I was able to get the Google Assistant on my phone (Android) to talk to the Vera Concierge but any queries that asked didn't go anywhere.  When I tried to ask my GH to speak to Vera Concierge, it said 'OK' and then there was total silence.   Any suggestions?


Offline RichardTSchaefer

  • Moderator
  • Master Member
  • *****
  • Posts: 9734
  • Karma: +737/-136
    • RTS Services Plugins
Re: Debug your Configuration
« Reply #49 on: September 11, 2017, 04:53:02 pm »
Have you successfully completed all the steps at the beginning of this thread ?

Offline ovinomis

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
Re: Debug your Configuration
« Reply #50 on: September 23, 2017, 04:07:19 am »
Hi Richard,

I am also trying to set up my Vera in the Java Vera Concierge Local Server app on a RPI but no luck. After trying multiple things I think it is related to my password containing special characters and the one causing the issue is i think "
I now removed that special character from my password and now it can connect. so definitely related to that character.

Tnx for another great service!


Offline TMC

  • Jr. Member
  • **
  • Posts: 59
  • Karma: +0/-0
Re: Debug your Configuration
« Reply #51 on: September 25, 2017, 07:27:11 am »
When I click Vera Connectivity in My Vera Concierge Account, I see {"VeraConnectivity": "null"}. If I press Local Concierge Server Connectivity nothing happens. In my Vera Edge, in Luup files I get ConciergeServer.lua. What do I have to do?
« Last Edit: September 25, 2017, 07:30:55 am by TMC »

Offline RichardTSchaefer

  • Moderator
  • Master Member
  • *****
  • Posts: 9734
  • Karma: +737/-136
    • RTS Services Plugins
Re: Debug your Configuration
« Reply #52 on: September 25, 2017, 10:37:00 am »
Did you try to disable the firewall where you are running the server (or preferably add the appropriate rules) ?

Offline TMC

  • Jr. Member
  • **
  • Posts: 59
  • Karma: +0/-0
Re: Debug your Configuration
« Reply #53 on: September 25, 2017, 10:50:11 am »
The firewall is disabled. What else can I do?

Offline Beefy

  • Newbie
  • *
  • Posts: 8
  • Karma: +0/-0
Re: Debug your Configuration
« Reply #54 on: September 29, 2017, 01:33:42 pm »
I had everything working fine on my vera lite but since upgrading to a plus I can't get the Google home to talk to concierge. Everything appears to be working server side...

{"VeraConnectivity":"50103340"}  - {"Name":"Kitchen Home","IPAddress":"192.168.1.128"}]}

{"Restart":false,"IP":"192.168.1.10","JVM":"1.8.0_144","Veras":[{"Name":"Home Plus","IPAddress":"192.168.1.14","

Should Restart:false be true? This is the only thing I'm unsure of.




Offline RichardTSchaefer

  • Moderator
  • Master Member
  • *****
  • Posts: 9734
  • Karma: +737/-136
    • RTS Services Plugins
Re: Debug your Configuration
« Reply #55 on: September 29, 2017, 08:50:20 pm »
When you changed Vera did you do the "Update Vera Concierge Cloud Information" at the bottom of the Local Concierge Server.
Do you still have your OLD vera connected ?
I think I have a bug if your change your Vera.
If you do ... try to say:
Use "Old Vera Name"
Use "New Vera Name"

If you do not, then delete ALL of the cloud info ... and re-create it.
 

Offline Beefy

  • Newbie
  • *
  • Posts: 8
  • Karma: +0/-0
Re: Debug your Configuration
« Reply #56 on: September 30, 2017, 03:28:04 am »
When you changed Vera did you do the "Update Vera Concierge Cloud Information" at the bottom of the Local Concierge Server. - YES
Do you still have your OLD vera connected ? - No (never connected at the same time)

The concierge account info is all correct, new Vera id is the right one and the google home ip address is also correct. I assume it's all connected but it no longer works on my android phone either. Can't link account like I could before.


Offline RichardTSchaefer

  • Moderator
  • Master Member
  • *****
  • Posts: 9734
  • Karma: +737/-136
    • RTS Services Plugins
Re: Debug your Configuration
« Reply #57 on: September 30, 2017, 11:37:34 am »
Like I said ... delete your information ...

1) Using your browser goto VeraConcierge.com
    Goto my account.
    DO NOT GET THERE BY USING UPDATE CLOUD INFORMATION!!!!!
2) Delete all of your Vera Info
3) Goto your Local Vera Concierge Server
4) Update Cloud Vera Info


If you just do 3 & 4, without doing 1 and 2, you do not delete some cached information which is causing you problems.

Offline TMC

  • Jr. Member
  • **
  • Posts: 59
  • Karma: +0/-0
Re: Debug your Configuration
« Reply #58 on: October 05, 2017, 02:47:34 pm »
I did the first 4 steps. Then nothing. What to do? I want to use the phone.

Offline GaryOkie

  • Sr. Newbie
  • *
  • Posts: 47
  • Karma: +3/-0
Re: Debug your Configuration
« Reply #59 on: October 06, 2017, 07:53:52 pm »
I'm also not getting any response to the Local Concierge Server Connectivity button or the remote Vera connectivity test button, other than "null".   I see nothing show up in the luup logs when these are clicked.

"OK Google, talk to Vera Concierge" works, so  at least that aspect of connectivity is working.

I've set up a Raspberry PI 3 server to run the Java app and the configuration is properly recognizing my Vera's and Google cast devices.  I've confirmed there is no firewall interfering.

EDIT:   Here are the only entries in the LuaUPnP log that are related to the conciergeserver that I could find...

Code: [Select]
13:02:53.598 Device_Service::MatchupUpnpServices no upnp service for urn:rts-services-com:serviceId:vcs <0x772ae320>
...
13:03:01.578 Device_Variable::m_szValue_set device: 1 service: urn:rts-services-com:serviceId:vcs variable: InitVersion was: 1.029 now: 1.029 #hooks: 0 upnp: 0 skip: 0 v:(nil)/NONE duplicate:1 <0x76c38520>
13:03:01.578 Device_Variable::m_szValue_set device: 1 service: urn:rts-services-com:serviceId:vcs variable: Version was: 1.029 now: 1.029 #hooks: 0 upnp: 0 skip: 0 v:(nil)/NONE duplicate:1 <0x76c38520>
13:03:01.579 luup_log:0: VCS:Version:1.029 Server:192.168.2.13 <0x76c38520>

(That is the correct static IP for the RasPi3 hosting the app).  I've read through this diagnostic thread many times and have followed every suggestion here and still can't determine why these tests are failing.

Thanks for any advice.
« Last Edit: October 08, 2017, 02:26:18 pm by GaryOkie »