Author Topic: Confusion around setup of this great plugin....  (Read 485 times)

Offline edentel

  • Newbie
  • *
  • Posts: 7
  • Karma: +0/-0
Confusion around setup of this great plugin....
« on: May 25, 2017, 08:33:44 pm »
So I linked my Elk alarm to Vera and started getting notifications out the wazoo.  A quick search here led me to VeraAlerts.  I had previously used Pushover with ISY so I was already setup.   Once I went to configure things I quickly was scratching my head....

I *thought* I would need to disable all notifications under the User & Account Info... User Info section.   What I found was that if I did this only test messages from the Editor Options... Send Message Now and messages that I directly triggered in a Scene would forward.  Nothing I setup under the device notifications section was working.

After I went back and forth testing for half an hour I tried turning back on push notifications, which went nowhere, under User & Account Info... User Info would allow notifications set under a device to come through.

So long story short, am I missing something obvious?  Does unchecking notifications under the User Info section disable some key part of the notification system preventing the messages from getting to VeraAlerts?

Thanks for any input!

Offline Don Phillips

  • Hero Member
  • *****
  • Posts: 1100
  • Karma: +25/-25
    • Worthington Engineering, Inc.
Re: Confusion around setup of this great plugin....
« Reply #1 on: May 25, 2017, 08:58:19 pm »
I am not sure how it works but VeraAlerts can be linked to different devices. I have mine linked to VeraMate so all alerts go to mine and my wife's iPhone. I have VeraAlerts send me system messages like Vera Rebooted or Vera Restarted.  All scenes are set up by VeraAlerts so you can customize your message. Lastly, in PLEG, you can send any message you want from an Action. That is why I disable all UI7 alerts - it had too much other junk that was useless to me. I had to play with it to understand it.
Vera 3, UI7 1.7.1017, CT101 t-stat, Everspring motion detector, GE/Jasco switch, Leviton outlet, AeonLabs door sensor, NuTone garage door, Blue Iris, Sricam SP011, iPhone locator, APCUPSD, VeraMate, VeraAlerts, PLEG, House Modes, Countdown Timer, DVR, Virtual & Multi Switch, Weather, Sys. Mon.

Offline RichardTSchaefer

  • Moderator
  • Master Member
  • *****
  • Posts: 9995
  • Karma: +755/-141
    • RTS Services Plugins
Re: Confusion around setup of this great plugin....
« Reply #2 on: May 25, 2017, 10:36:37 pm »
Have you looked at the Vera Alerts "REPORT" command.
This shows how messages are configured.

1) Device Notifications   are tagged  with a Vera User
2) When Vera detects the condition it sends the notification to Vera Alerts.
3) Vera Alerts looks up the profile(s) for that Vera User and sends the Alerts using that(those) profile(s).

You also have to enabled Notifications in the Settings tab.

Offline edentel

  • Newbie
  • *
  • Posts: 7
  • Karma: +0/-0
Re: Confusion around setup of this great plugin....
« Reply #3 on: May 26, 2017, 09:24:29 am »
Now I'm really scratching my head as I can't get any VeraAlerts notifications other than a test message or by directly calling it from a scene.  I have the standard Vera notifications on as well and Vera is reporting, but not Vera Alerts.

-I have Process Notifications check in settings
-I have my user associated with Pushover in the profile association
-Test messages from Send Message Now work
-Forcing a notificaiton as part of a scene work
-No notifications under Configure Notifications ever transmit

Everything LOOKS ok under the reports option you mentioned....


Offline edentel

  • Newbie
  • *
  • Posts: 7
  • Karma: +0/-0
Re: Confusion around setup of this great plugin....
« Reply #4 on: May 26, 2017, 12:29:37 pm »
A reboot of the Vera and all is working as expected.... thanks for the pointers!