Author Topic: Alexa Skill Scene Problem  (Read 228 times)

Offline Styxman

  • Newbie
  • *
  • Posts: 15
  • Karma: +0/-2
Alexa Skill Scene Problem
« on: June 20, 2017, 04:44:27 pm »
I have numerous scenes that turn on (and off) various A/V components....the scenes contain LUUP code.  All was working well until about a month ago when executing through Alexa.  Now, it seems that all the LUUP is executing except for one function (entire code below).  The TurnOnTV() is not executing when sent through Alexa, but does just fine when run from UI7.  Does anyone have any ideas on why this would be so?  Thanks

function TurnOnCable()
-- Turn On Bedroom DirectTV
iTachMediaCloset("sendir,1:1,1,39000,1,1,230,46,46,46,23,23,46,23,23,23,23,23,23,23,46,46,46,23,23,1159,115,46,46,46,23,23,46,23,23,23,23,23,23,23,46,46,46,23,23,1159,115,46,46,46,23,23,46,23,23,23,23,23,23,23,46,46,46,23,23,1627,96,23,24,23,48,23,48,23,48,23,24,23,48,23,24,23,48,23,24,23,24,23,24,23,24,975,\r")
end

function TurnOnDenon ()
iTachMediaClosetDVD("sendir,1:3,1,38000,1,1,10,30,10,70,10,30,10,30,10,30,10,30,10,30,10,30,10,70,10,30,10,30,10,70,10,70,10,30,10,30,10,1657,10,30,10,70,10,30,10,30,10,30,10,70,10,70,10,70,10,30,10,70,10,70,10,30,10,30,10,70,10,70,10,1657,\r")
end

function TurnOnTV()
os.execute([[curl --silent -XPOST http://192.168.1.103/sony/IRCC -H "X-Auth-PSK:1111" -d "<?xml version=\"1.0\"?><s:Envelope xmlns:s=\"http://schemas.xmlsoap.org/soap/envelope/\" s:encodingStyle=\"http://schemas.xmlsoap.org/soap/encoding/\"><s:Body><u:X_SendIRCC xmlns:u=\"urn:schemas-sony-com:service:IRCC:1\"><IRCCCode>"AAAAAQAAAAEAAAAuAw=="</IRCCCode></u:X_SendIRCC></s:Body></s:Envelope>" -H 'Content-Type: text/xml; charset=UTF-8' -H 'SOAPACTION: "urn:schemas-sony-com:service:IRCC:1#X_SendIRCC"']])
end

function wait(seconds)
   local _start = os.time()
   local _end = _start+seconds
   while (_end ~= os.time()) do
   end
end

TurnOnCable()
wait(2)
TurnOnDenon()
wait(2)
TurnOnTV()