Author Topic: Errors after upgrade  (Read 528 times)

Offline johnnyw55

  • Newbie
  • *
  • Posts: 15
  • Karma: +0/-0
Errors after upgrade
« on: June 24, 2017, 12:15:12 pm »
Hi,
    I just upgraded to the lastest firmware 1.7.947, which i had my troubles with.. but after a struggle or two I finally got the unit back up and running. everything is working except it doesnt see my dimmable lights or my humidity sensor. and it throws out these errors.

System error : Device: 29. Fail to load implementation file D_HumiditySensor1.xml
System error : Device: 66. Fail to load implementation file D_DimmableLight1.xml
System error : Device: 67. Fail to load implementation file D_DimmableLight1.xml
System error : Device: 68. Fail to load implementation file D_DimmableLight1.xml
System error : Device: 69. Fail to load implementation file D_DimmableLight1.xml
System error : Device: 70. Fail to load implementation file D_DimmableLight1.xml
System error : Device: 71. Fail to load implementation file D_DimmableLight1.xml
ZWave : Configuring Z-Wave devices in your system.
ERROR : Error in lua for scenes and events

I have tried to restore to an old back up but the same errors are present.. and if I look at the files it would seem that the D_DimmableLight1.xml and D_HumiditySensor1.xml File are not present in the list.. any ideas? Ive tried to exclude and reinclude the lights. but still nothing. The vera lights when in battery mode show the device being excluded and reincluded but when I hook it back up to the network, nothing.. any ideas would be greatly appreciated!

-John

Offline Juppers

  • Jr. Member
  • **
  • Posts: 72
  • Karma: +2/-1
Re: Errors after upgrade
« Reply #1 on: June 24, 2017, 12:29:00 pm »
Do a factory reset then restore your backup. That should replace the missing files.

Offline tomtcom

  • Hero Member
  • *****
  • Posts: 850
  • Karma: +20/-31
Re: Errors after upgrade
« Reply #2 on: June 24, 2017, 12:30:10 pm »
Did you only restore the backup file? Did you restore the z-wave network? There are 2 backups really so that could be a problem. If nothing has changed just prior to the upgrade and post the upgrade you could always try to restore the z-wave network backup. Maybe this will help but always proceed with caution or call support too.

Offline johnnyw55

  • Newbie
  • *
  • Posts: 15
  • Karma: +0/-0
Re: Errors after upgrade
« Reply #3 on: June 24, 2017, 01:38:53 pm »
I restored the z-wave network and the backup file.. I even went back to a back-up for a week ago and the files are still missing.. Should I factory reset then restore the back up? will that set the firmware back to the lastest or will I need to do the firmware upgrade again?

Offline John M.

  • Administrator
  • Hero Member
  • *****
  • Posts: 511
  • Karma: +39/-3
    • getvera.com
Re: Errors after upgrade
« Reply #4 on: June 24, 2017, 05:14:54 pm »
Hello Johnny,


It seems that some files got corrupted during the firmware upgrade. This could happen if the unit is interrupted in a very specific upgrade phase, where it's backing up these system files on a backup partition, with the purpose of restoring them, after the clean firmware image is written.


Our Customer Care can easily sort this out if contact them (see my signature)
John.M. ▾ Senior Customer Care Advocate
Vera Control, Ltd. ▾ Smarter Home Control  ▾ support@getvera.com ▾www.getvera.com ▾ +1 (866) 966-2272

HOURS OF OPERATION (Pacific Time Zone, UTC -8 )
Monday - Friday   12:00 am ? 06:00 pm
Saturday - Sunday   04:00 am ? 06:00 pm

Online Don Phillips

  • Hero Member
  • *****
  • Posts: 852
  • Karma: +18/-8
    • Worthington Engineering, Inc.
Re: Errors after upgrade
« Reply #5 on: June 24, 2017, 05:19:48 pm »
When I updated the firmware, this is what I did:
1) Did a full backup including z-wave (this takes about 10 minutes)
2) Restored to factory settings. Lost UI interface but waited until the unit was back up
3) Plugged the Vera into my router and restarted Vera
4) Logged into UI, updated firmware, reboot.
5) Logged into UI, set Wi-Fi, when told to unplug WAN, unplugged Vera to move back to its final place
6) After Vera restarted, restored from backup including z-wave (this takes about 10 minutes).

During the restore, Vera downloaded and restored the Plug-ins. Warning - Looks like I lost my Data Mine 2 data or at least it was not restored, including which variables I was watching and my saved graphs.
Vera 3, UI7 1.7.947, CT101 t-stat, Everspring motion detector, GE/Jasco switch, Leviton outlet, AeonLabs door sensor, Insteon garage control, Blue Iris, Sricam SP011, iPhone locator, APCUPSD, VeraMate, VeraAlerts, PLEG, House Modes, Countdown Timer, DVR, Virtual & Multi Switch, Weather, Sys. Mon.