Author Topic: Vera Edge is Always "Controller Offline"  (Read 1874 times)

Offline complexthings

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
Vera Edge is Always "Controller Offline"
« on: July 14, 2017, 05:03:21 pm »
My current troubles
I'm almost done with it, but I decided to give this one last shot.  When I bought my home in 2015 the previous owners had it configured with a vera lite.  Flash forward to 2016 and it got hit by lightening so I bought a vera edge.  I have never been able to have this edge work the way it's supposed to.  When I login to the dashboard on it is always showing as "controller offline".  When I open my iOS app, it's "controller offline".  I've managed to get around this in a few ways but today I'm off my rocker about it, I'm sick of it. I'll explain the ways I've dealt with it as well as the trouble shooting I've tried.  Please if anyone out there has any idea of a step I missed or what could be causing this let me know. 

Ways I've dealt with it.
  • I can get to the vera on my local network directly via the IP address from a desktop/laptop.  Unfortunately, I'm limited in some of the things I can do within the web app due to not being "logged in"
  • There's a glitch in the iOS app where you can refresh your controllers and hit the connect button before the status updates, this will allow me to log in even though the controller's status is "offline"

Troubleshooting Steps
  • Factory Reset w/ Zwave Devices Backed Up
  • Factory Reset from Scratch no devices
  • Connect via Ethernet
  • Connect via Wifi
  • Connect via Ethernet StaticIP
  • Connect via Wifi StaticIP
  • Disable Firewall in Vera
  • Enable Firewall in Vera
  • And on and on and on....

Strange things I've noticed.
It thinks there's an IP address of associated with it, I have no idea where it came from, the starting addresses for my router are, most of the ip addresses it gets from DCHP or I've assigned from static are or
Code: [Select]
=== IP Configuration ===
br-lan    Link encap:Ethernet  HWaddr E0:60:66:0C:1B:23 
          inet addr:  Bcast:  Mask:
eth0      Link encap:Ethernet  HWaddr E0:60:66:0C:1B:23 
eth0.1    Link encap:Ethernet  HWaddr E0:60:66:0C:1B:23 
          inet addr:  Mask:

=== Testing Gateway: ===
=== Testing DnsServer: ===
=== Testing DnsServer: ===
=== Testing External Servers ===
STA server: OK
EVT server: OK
TS server tunnel connection: OK
FWD server: OK
FWD server tunnel connection: OK
== DONE ==

Thank you in advance if you've seen or know how to diagnose/troubleshoot these types of issues.

Offline Sorin

  • Administrator
  • Hero Member
  • *****
  • Posts: 923
  • Karma: +77/-8
Re: Vera Edge is Always "Controller Offline"
« Reply #1 on: July 15, 2017, 10:14:53 am »
Hi there,

I'm sorry to hear about the troubles you've been having with your Vera. Have you ever tried to involve our support team as well ? If not I highly suggest doing that.

You don't have to worry about as this is your Vera's internal LAN, used for "local/on vera" services. It coincides with the last two groups of you MAC :1B:23 (12.23)

Giving your network troubleshooting output I can conclude that Outbound connections are going thru, but not the Inbound. Do you have any active firewalls of some sort ? Are you in an enterprise network ?

Please contact our CC team (see my signature) with all the details you've given here, and in addition please mention the exact model of your main router, enable customer care remote access, and pass them the generated code and the SN of your unit.

Sorin M. ▾ Community Manager
Vera Control, Ltd. ▾ Smarter Home Control  ▾ ▾ ▾ +1 (866) 966-2272

HOURS OF OPERATION for Customer Care Department - 24/7

Offline Z-Waver

  • Master Member
  • *******
  • Posts: 4437
  • Karma: +247/-120
Re: Vera Edge is Always "Controller Offline"
« Reply #2 on: July 16, 2017, 08:14:31 am »
I concur with @John M. This looks like a gateway firewall issue.

No SSH tunnels suggests that you've got something interfering with TCP port 232, the port Vera uses for SSH tunnels.

Also John tried to say but wasn't clear, unless you really understand how Vera works, the 192.168.12.x address(es) are default secondary interface addresses that you should simply ignore completely. They are irrelevant to your use of Vera or your issue at hand.

As John said, if you have not already engaged tech support, you should do so.