Author Topic: D-Link DCS-932L Live Video Doesn't Work Despite Preview Working  (Read 872 times)

Offline cjwhitsitt

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
I have a DCS-932LB1 that I've had added as a Generic IP Camera using "image.jpeg" as the URL. The image pulls in fine but this means that a "recording" will just be a single-image snapshot, not a video or series of images.

In a browser, I'm also able to go to http://{ip}/video.cgi and video the live video stream. When I use "video.cgi" in the URL field of the device on my Vera, the preview video stream works fine for about 10 seconds, but it freezes after a bit and the "Live" screen of the camera says "Not Connected".

All the threads I've read are asking how to install it and just use image.jpeg. My questions are specifically
1) Why does the preview video work briefly then freeze?
2) Is it possible to get the Live video stream working?

Offline gniknalu

  • Full Member
  • ***
  • Posts: 148
  • Karma: +3/-2
Re: D-Link DCS-932L Live Video Doesn't Work Despite Preview Working
« Reply #1 on: August 09, 2017, 08:12:13 pm »
I have a DCS-932LB1 that I've had added as a Generic IP Camera using "image.jpeg" as the URL. The image pulls in fine but this means that a "recording" will just be a single-image snapshot, not a video or series of images.

In a browser, I'm also able to go to http://{ip}/video.cgi and video the live video stream. When I use "video.cgi" in the URL field of the device on my Vera, the preview video stream works fine for about 10 seconds, but it freezes after a bit and the "Live" screen of the camera says "Not Connected".

All the threads I've read are asking how to install it and just use image.jpeg. My questions are specifically
1) Why does the preview video work briefly then freeze?
2) Is it possible to get the Live video stream working?

You might need to append username:password@ to the URL to get it to work. For example: http://username:password@<CamIP>/video.cgi

Offline g2ren

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
Re: D-Link DCS-932L Live Video Doesn't Work Despite Preview Working
« Reply #2 on: September 24, 2017, 06:58:09 pm »
I using Dlink  DCS-933L and have same issue as "cjwhitsitt". I need to use this setting under Camera/settings/variables URL = image/jpeg.cgi To be able to see a picture/video
I use wired and wifi for my cams. Have also issue with camera are unavailable, lost communication,. They drop in and out. Will we have a fix for this in the future?
I haven't tested "gniknalu" solution, will do when I am onshore.




« Last Edit: September 24, 2017, 07:33:39 pm by g2ren »

Offline Sorin

  • Administrator
  • Hero Member
  • *****
  • Posts: 857
  • Karma: +70/-7
    • getvera.com
Re: D-Link DCS-932L Live Video Doesn't Work Despite Preview Working
« Reply #3 on: September 25, 2017, 06:42:55 am »
Have also issue with camera are unavailable, lost communication,. They drop in and out. Will we have a fix for this in the future?


If the camera is on wifi, most probably has packets loss. This can be easily tested with a few minutes ping from a console, on the camera. If the ping time is inconsistent and spikes a lot, you might want to put camera on wire if possible.
Sorin M. ▾ Community Manager
Vera Control, Ltd. ▾ Smarter Home Control  ▾ support@getvera.com ▾www.getvera.com ▾ +1 (866) 966-2272

HOURS OF OPERATION for Customer Care Department - 24/7

Offline Forzaalfa

  • Full Member
  • ***
  • Posts: 107
  • Karma: +4/-0
Re: D-Link DCS-932L Live Video Doesn't Work Despite Preview Working
« Reply #4 on: October 09, 2017, 02:57:27 am »
I have the same problem with a d-link camera, it looks fine in preview for <10 seconds, if i open for a bigger picture, it says not connected. The connection is fine, as I can log on and look at the camera just fine using d-link web site.

The 2330L har 3 different streams for http, and i'm using the JPEG(Mpeg?) one, as vera can't use h264..
Vera Plus - RFXtrx433e

Offline Matsohl

  • Sr. Newbie
  • *
  • Posts: 30
  • Karma: +4/-1
Re: D-Link DCS-932L Live Video Doesn't Work Despite Preview Working
« Reply #5 on: April 15, 2018, 11:47:34 am »
Bump. Same problem here with the D-Link Camera. The snapshot works for <10 s, when I click on it, it shows "not connected"

Offline thief

  • Jr. Member
  • **
  • Posts: 78
  • Karma: +2/-0
Re: D-Link DCS-932L Live Video Doesn't Work Despite Preview Working
« Reply #6 on: April 16, 2018, 03:37:38 am »
I have also a DCS-5020L with same problem, tried for a week, tried all possible solutions I could find and no luck!
Tried with other camera brand, no luck.

So I came to the conclusion that if it's not detected by vera itself, it wont work!
Maybe... if you are lucky, but then with only a jpeg image that is updated = no good.