Author Topic: Fibaro KeyFob  (Read 637 times)

Offline Sierek

  • Sr. Newbie
  • *
  • Posts: 34
  • Karma: +0/-0
Fibaro KeyFob
« on: August 08, 2017, 02:45:25 pm »
Unfortunately, I am not able to set up the device to operate. Add a device and what's next? How for example, set direct roller shutter control?

EDIT: All the time I got the message "Waiting for wake up to configure device ..."  I used the white and green options. I've done many times command "Configure node right now" and "Replace failed" - no effect. I replaced the batteries with new ones, the two devices have the same problem.
« Last Edit: August 09, 2017, 03:32:04 am by Sierek »

Offline ninkasi

  • Sr. Newbie
  • *
  • Posts: 45
  • Karma: +5/-0
Re: Fibaro KeyFob
« Reply #1 on: August 09, 2017, 10:00:17 pm »
My keyfob is due to arrive tomorrow - I'll let you know in a couple of days how I go. :-)

Offline ninkasi

  • Sr. Newbie
  • *
  • Posts: 45
  • Karma: +5/-0
Re: Fibaro KeyFob
« Reply #2 on: August 10, 2017, 10:32:10 pm »
OK - success!

* Opened the package, removed the labels, cleaned the battery from sticky residue, closed it all.
* Went into devices on the Vera (GUI7), searched for 'keyfob' and chose the Fibaro (FGKF-601)
* When ready to include, clicked one of the buttons three times quickly then rested the thing on top of my Vera (past experience with a Fibaro door sensor was it had to be as close as possible to configure reliably)
* It seemed to add in ok, but then it went into "Waiting for wakeup to configure device"
* I then found a post where someone was saying that the remote would not stay awake for long enough - you need to put it in learning mode which keeps it awake for longer - this is by holding down circle & minus, then triangle once (green light), then plus. I'm not convinced that's the case - I think what's more likely is that a fair amount of data gets transferred initially, and that may take a few goes before it's complete. I tried it, but later I simply used the circle & plus method (or alternatively the circle & minus, then tap triangle until it goes to white, then plus to confirm. I basically made a minor change to a button, and then saved the change, woke the remote and placed it as quickly as possible on the Vera. Did that a few times and eventually it all came good.

It now accepts changes to the buttons really quickly. On the other hand my battery level has dropped from 75% to 47% in all this, but that is an estimate so I expect it will go up again in a while. Also keep in mind that when making any changes to it - you almost certainly need to place it near/on top of the Vera.

Confusingly the icon at the moment is for the Fibaro Button - the thing that looks like a mushroom.

Once it's added in properly, you go into the device itself, then "Select scenes for device buttons". In there you can assign house modes (eg night/day/etc) or a scene (eg turn on all lights) to the buttons. Each button has four possible actions (one, two, or three clicks plus press & hold) - so with six buttons there are 24 different possible commands you can program in. In theory there are another six (by using button combos) but frankly I'm going to be fine with the basic six. I have currently assigned one button for the garage door lock scene (single press to open - it automatically locks after a few seconds) and one button for the front door (press to run the unlock scene, double press for the lock scene).
« Last Edit: August 10, 2017, 10:36:07 pm by ninkasi »

Offline Sierek

  • Sr. Newbie
  • *
  • Posts: 34
  • Karma: +0/-0
Re: Fibaro KeyFob
« Reply #3 on: August 12, 2017, 08:25:25 am »
I did a dozen attempts, still without a positive effect. Keyfobs I put directly on Vera Plus.
What version of device do you have?
My two are FGKF-601 ZW5 v3.2. 04/03/2017

Offline ninkasi

  • Sr. Newbie
  • *
  • Posts: 45
  • Karma: +5/-0
Re: Fibaro KeyFob
« Reply #4 on: August 13, 2017, 12:30:41 am »
Mine  is dated 14/3/2017 but otherwise the same. Like I say, the way I did it was to:

1. Add it in as a new device - as soon as Vera is waiting to include it then wake the dang keyfob up and place it on the Vera - close to the back/power socket seemed to be best for me.
2. Once it appears, it may (as it did in my case) say that it is "waiting for wakeup". No amount of waking it up and placing it on the Vera, or telling the Vera to poll the keyfob every few seconds helped. What did help was:
3. Go into the new keyfob device, and configure something - eg assign an action for a button. As soon as you hit save, wakeup the keyfob (circle & minus, then tap triangle until it goes to white, then plus to confirm - all as quickly as possible) and put it on the Vera.
4. Repeat step 3 a few times and eventually (it probably took me six tries) I found it actually finished saving whatever it needed to do and from then on, making a change to the keyfob worked with one go. My only assumption is that with the first synch, Vera overwrites multiple settings - so with this first synch the keyfob goes to sleep before it's complete so needs to be repeated a few times. When it's is finally complete it, further updates only change what has actually changed..... at least that's my guess.

All the mucking around also appears to have sucked the life out of the battery - it's down to 35% now..... but will replace that soon and see how long it lasts. I will say - once you do get it working - it's pretty neat to have, so it's worth persisting. Good luck! :-)

Offline Sierek

  • Sr. Newbie
  • *
  • Posts: 34
  • Karma: +0/-0
Re: Fibaro KeyFob
« Reply #5 on: August 13, 2017, 05:13:20 am »
Thank you for the advice.

Unfortunately I'm not able to set up my keyfobs.
I applied for a support ticket, maybe I have something wrong with Vera.

Offline ninkasi

  • Sr. Newbie
  • *
  • Posts: 45
  • Karma: +5/-0
Re: Fibaro KeyFob
« Reply #6 on: August 13, 2017, 07:25:37 am »
Thank you for the advice.

Unfortunately I'm not able to set up my keyfobs.
I applied for a support ticket, maybe I have something wrong with Vera.

No problem - hope you manage to get it resolved. Like I said, it did take a while for me to get it to work. I deeply suspect it's not Vera as such but the keyfob is just tricky to setup. All I can suggest is not giving up, and keep trying.

Offline akyprianides

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
Re: Fibaro KeyFob
« Reply #7 on: August 14, 2017, 12:52:44 pm »
Still cannot get mine to work, even after following ninkasi's kind instructions. Anyone else / any ideas?

Offline Sierek

  • Sr. Newbie
  • *
  • Posts: 34
  • Karma: +0/-0
Re: Fibaro KeyFob
« Reply #8 on: August 16, 2017, 09:43:51 am »
Success!
I managed to configure the device by a "green" option. I had to repeat > 20 times, but 2 m to Vera.

Offline ninkasi

  • Sr. Newbie
  • *
  • Posts: 45
  • Karma: +5/-0
Re: Fibaro KeyFob
« Reply #9 on: August 17, 2017, 02:56:50 am »
Success!
I managed to configure the device by a "green" option. I had to repeat > 20 times, but 2 m to Vera.

Glad to hear it! Definitely a pain to setup (I also have setup a Fibaro door sensor that took a while to do) but is good now it's finally configured.

Offline Sierek

  • Sr. Newbie
  • *
  • Posts: 34
  • Karma: +0/-0
Re: Fibaro KeyFob
« Reply #10 on: August 17, 2017, 10:59:42 am »
I do not have good news. I repeat the procedure for the second device and no effect.
There must be an error in the Vera software. Fibaro Home Center and OpenHub users do not have similar problems.

EDIT:
Yesterday I made> 100 attempts, no effect. The battery dropped from 100% to 25%
Today's first attempt - success! I used "green" option, 2m distance from Vera.

It follows that acceptance of the remote command after waking is completely accidental.
« Last Edit: August 18, 2017, 06:29:17 am by Sierek »