Author Topic: Qubino flush thermostat On/Off does not switch on/off correctly  (Read 1362 times)

Offline lindstroem4

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
Hello,
I have installed Qubino flush thermostat on/off to replace a heating switch that controls Electric radiators (do not supply Power, just Controls the switch). I have connected the Qubino device with Vera Edge and got it to connect and show temperature. However it was not possible to turn on, I only have "Off" and the ability to set it to "Auto", but when I do this it reverts back to Off shortly thereafter without activating the switch.

I have now tried to install Imperihome where I have the manual setting to choose between Cool, Heat, Auto, Off. Here I got the device to activate the switch when selecting "HEAT". I succeeded in turning it on and then off once, but could not get it to turn on again. I tried pressing the S-button on the device and pulled the fuse to do a complete reboot. Again I was able to activate once or twice, but after that time i Could not get the switch to respond (in the last case it got stuck in On-mode).

Have you come across this Before and have you any recommendations? Or is the Product faulty?

Thanks!

Offline HouseBot

  • Full Member
  • ***
  • Posts: 210
  • Karma: +1/-1
Re: Qubino flush thermostat On/Off does not switch on/off correctly
« Reply #1 on: September 17, 2017, 02:33:06 pm »
That's a good question, since I have the same issue myself on Firmware 1.7.963.
I emailed the support today to see if there is any tricks not know to us to solve this.


Offline HouseBot

  • Full Member
  • ***
  • Posts: 210
  • Karma: +1/-1
Re: Qubino flush thermostat On/Off does not switch on/off correctly
« Reply #2 on: January 15, 2018, 02:20:18 am »
This is still not solved.
I just emailed them again to here if they can continue the discusison between Qubino and Mios.
Last official info from mios is:
"Based on manufacturer information, the device seems to be properly integrated, we will revise the integration, but I do not have any time or date of when the integration will be released/revise."

Offline Sorin

  • Administrator
  • Hero Member
  • *****
  • Posts: 946
  • Karma: +80/-9
Re: Qubino flush thermostat On/Off does not switch on/off correctly
« Reply #3 on: January 15, 2018, 09:25:29 am »
This kind of situation comes by when the samples we get from the manufacturers are revised after the integration.

In which case, we will gladly revise the integration with the new data, but it depends on a lot of factors as it's a "both ways" communication and sometimes it might take a little longer.

We look forward to having them sorted as fast as it stands in our hands to do so.
Sorin M. ▾ Community Manager
Vera Control, Ltd. ▾ Smarter Home Control  ▾ support@getvera.com ▾www.getvera.com ▾ +1 (866) 966-2272

HOURS OF OPERATION for Customer Care Department - 24/7

Offline HouseBot

  • Full Member
  • ***
  • Posts: 210
  • Karma: +1/-1
Re: Qubino flush thermostat On/Off does not switch on/off correctly
« Reply #4 on: January 25, 2018, 02:16:27 pm »
23rd Jan I received an email from Vera stating that they are reanalyzing this device and it will undergo new tests. One of the upcoming firmware release will support this, no exact mention of which at this point.
 :D

Offline kwieto

  • Hero Member
  • *****
  • Posts: 557
  • Karma: +27/-12
Re: Qubino flush thermostat On/Off does not switch on/off correctly
« Reply #5 on: February 12, 2018, 03:41:41 pm »
23rd Jan I received an email from Vera stating that they are reanalyzing this device and it will undergo new tests. One of the upcoming firmware release will support this, no exact mention of which at this point.
 :D

Any update?
I've bought such device convinced that it is fully supported (it is on the list in "add device" section) and I'm experiencing the same issue: thermostat turned into "auto mode" gets back to "off" in a couple of minutes.
Temperature sensor works and the switching module is also operational (when I've changed parameter 63 to "normaly close" attached heater started to work)

Offline kwieto

  • Hero Member
  • *****
  • Posts: 557
  • Karma: +27/-12
Re: Qubino flush thermostat On/Off does not switch on/off correctly
« Reply #6 on: February 12, 2018, 06:19:18 pm »
OK, so I did some tries (including trying to change device json file) and the only solution is to set thermostat into heat mode.
In my case it switches on and off without issues (tried couple of times, not much).
The heat mode can probably be set in Variables section (ModeTarget and ModeStatus as "HeatOn"), although I used third party app to do that.

I've added some configuration parameters to be monitored and at first found strange data in parameter 59 (Heating or Cooling mode). This should be either 0 or 1 and it was 260 at first. Changed to 0 (heating mode) and re-included device (this is requested in manual).

Offline HouseBot

  • Full Member
  • ***
  • Posts: 210
  • Karma: +1/-1
Re: Qubino flush thermostat On/Off does not switch on/off correctly
« Reply #7 on: February 25, 2018, 01:11:35 pm »
Sorry, no news so far..
Checked the latest Firmware release note, that I still have pending to be installed, but did not notice anything mention support for this.
So I guess we need to wait longer.

>(it is on the list in "add device" section)
Exactly same reason why I bought it... and it makes me feel like a fool...  >:(

Offline Sorin

  • Administrator
  • Hero Member
  • *****
  • Posts: 946
  • Karma: +80/-9
Re: Qubino flush thermostat On/Off does not switch on/off correctly
« Reply #8 on: February 26, 2018, 07:15:51 am »
Hey there,

The problem is caused by two different version of the Qubino Flush On/Off thermostat available on the market. Our integration was made based on the old version of the thermostat, which is incompatible with the latest Qubino thermostat version.

After discussion with Qubino, a decision was made by them, to re-release the newest version of the thermostat as it's own version, so it will no longer conflict with our implementation. We will receive a new version of the thermostat and work on integrating that.

We encourage that all existing customers with the issue to contact Qubino so they will fix the issue internally.
Sorin M. ▾ Community Manager
Vera Control, Ltd. ▾ Smarter Home Control  ▾ support@getvera.com ▾www.getvera.com ▾ +1 (866) 966-2272

HOURS OF OPERATION for Customer Care Department - 24/7

Offline HouseBot

  • Full Member
  • ***
  • Posts: 210
  • Karma: +1/-1
Re: Qubino flush thermostat On/Off does not switch on/off correctly
« Reply #9 on: February 27, 2018, 11:34:47 am »
Thanks for sharing the root cause.
http://forum.micasaverde.com is an amazing place and one of the reason why I back in the days decided to go with Vera and still is!

Offline Palmiholm

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
Re: Qubino flush thermostat On/Off does not switch on/off correctly
« Reply #10 on: April 22, 2018, 12:35:34 pm »
Is there any update on this. My qubino module still goes to Off in a couple of minutes...

Offline Ulf

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
Re: Qubino flush thermostat On/Off does not switch on/off correctly
« Reply #11 on: June 26, 2018, 05:54:53 pm »
I got 14 Qubino thermostats and have been in contact with both Qubino and Vera support several times without any progress. Due to this problem and cold winters only 4 of them is in use after almost two years of waiting for a solution.

However, it is possible to control them by configuring preset modes and selecting the temperature and "Heat" or "Off for each of the 4 modes ("Heat" is selectable in the UI when configuring modes). In the device section this is not possible, only "Off" and the automatic-self-turning-off "Auto" button.

Arming and disarming the house to set temperature does not feel ok for me, so in pure desperation I forced myself to learn some LUA to do a workaround that works for me. I am not a programmer...

Change the below code to match your setup (device and temperature etc). Create and put the code into selected scenes, then it will be possible to control the thermostats (also in the app) by executing a scene to set mode and temperature. Not a good solution and not so nice coding, but it works for me.

Code: [Select]
-- LUA TO SET HEAT SETPOINT ON QUBINO ON/OFF TERMOSTATS DUE TO CONTROLS CURRENTLY NOT NWORKING IN VERA UI AND APP:

-- function to set setpoint --
function setsetpoint(dID, degrees)

local currentmode = luup.variable_get("urn:upnp-org:serviceId:HVAC_UserOperatingMode1", "ModeStatus",dID)
local currentsetpoint = luup.variable_get("urn:upnp-org:serviceId:TemperatureSetpoint1", "CurrentSetpoint",dID)
luup.log( "THERMOSTAT-CONTROL: (" .. dID .. ") Mode on thermostat is " .. currentmode .. " setpoint " .. currentsetpoint .. " degrees" )

if (currentmode ~= 'HeatOn') then
luup.call_action("urn:upnp-org:serviceId:HVAC_UserOperatingMode1", "SetModeTarget", {NewModeTarget = "HeatOn"}, dID)
luup.log( "THERMOSTAT-CONTROL: (" .. dID .. ") Changing to HeatOn from " .. currentmode  .. " is " )
end
if (tonumber(currentsetpoint) ~= tonumber(degrees)) then
luup.call_action("urn:upnp-org:serviceId:TemperatureSetpoint1_Heat", "SetCurrentSetpoint", {NewCurrentSetpoint = degrees}, dID)
luup.call_action("urn:upnp-org:serviceId:TemperatureSetpoint1_Cool", "SetCurrentSetpoint", {NewCurrentSetpoint = degrees}, dID)
luup.log( "THERMOSTAT-CONTROL: (" .. dID .. ") Changing to setpoint " .. degrees .. " from " .. currentsetpoint .. " degrees")
end

end


commandArray = {}

-- Target setpoint for all thermostats
local setdegree="20.0" -- CHANGE to your temp
local DevId1=100 -- CHANGE to your device id
local DevId2=101 -- CHANGE to your device id, add more if needed

-- For each thermostat call setsetpoint(device-id:integer, degrees:string) add more calls if needed
setsetpoint(DevId1,setdegree)
setsetpoint(DevId2,setdegree)

-- Repeat to make sure the values apply
setsetpoint(DevId1,setdegree)
setsetpoint(DevId2,setdegree)

-- Repeat to make sure the values apply
setsetpoint(DevId1,setdegree)
setsetpoint(DevId2,setdegree)


return commandArray



« Last Edit: June 26, 2018, 06:22:16 pm by Ulf »

Offline kwieto

  • Hero Member
  • *****
  • Posts: 557
  • Karma: +27/-12
Re: Qubino flush thermostat On/Off does not switch on/off correctly
« Reply #12 on: June 27, 2018, 04:39:49 am »
For simple operation it is enough to have following code in scene:

Code: [Select]
luup.call_action( "urn:upnp-org:serviceId:HVAC_UserOperatingMode1", "SetModeTarget", {NewModeTarget = "HeatOn"}, dID)
where dID is your thermostat ID.
Then you can steer the setpoint from UI of choosing thermostat from devices list in the scene and choosing proper temperature, or manually via device panel in UI.

But I use the house modes for turning it on and off most of the time.
I assume that when I'm home I don't have the need to turn thermostat off completely and the main concern is to set proper temperature for specific period of time (i.e. different for night and daytime). This can be done via scene or UI without any additional coding (you just have to remember that if your UI presents both "auto" and "off" buttons grey, your thermostat works fine).

In my case the basic logic is:
Home mode = heat on, temp set to the daily temperature
Night mode = no change (there is no chance to go into "night" mode without going through "home mode" first, which will turn thermostat on. "No change" prevents the system to set different temparature than the one which was set manually or via the scene if night mode was set on later)
Away = heat on, temp set to temperature warm enough to keep it ready for use, but lower than the normal "daily" temp.
Vacation = heat off, then I have set antifreeze temperature via device parameters (by default it is 5C)

I consider "away" as the option when I leave home for short period of time (i.e. work, or maybe weekend), while "vacation" is used when I'm not at home for a longer time.

This way steering on/off via the scene is needed only for rooms which are not fitting with the house modes scenario (i.e guest rooms, which are usually empty regardless if I'm home or not)