Author Topic: Popp Z-Rain 700168  (Read 167 times)

Offline sorliden

  • Newbie
  • *
  • Posts: 15
  • Karma: +0/-0
Popp Z-Rain 700168
« on: September 17, 2017, 04:09:40 pm »
I start a new thread about the Popp Z-Rain 700168 since it doesn?t seem to be mentioned anywhere at the forum yet.

I bought a Popp Z-Rain by mistake. I got a 50% discount, couldn't  resist and forgot to check the compatibility chart (https://www.z-wave.se/comp/?search=POPE700168) for the Vera. It's not compatible. Instead of returning it I decided it was a challenge to get it to work anyway.

The Popp Z-Rain was easy to install on my Vera Edge. But it was not defined as a rain gauge. Two extra "_GET_LANG(generic_sensor,sensor)" devices was also created. I tried to remove them but that also removed the device with the rain level. So I made a reinstallation and kept the extra devices.

I have built some logic in PLEG to first of all filter the rain level value. I found that sometimes the rain device will have a value 1000 times higher than normal and sometimes the rain level value will be 0.
When I had a reliable rain level I added triggers to save the rain level values every 5, 20 minutes, every hour, day, week and every month. By comparing the last rain level with the current rain level I got statistics for rain the last 5, 20 minutes, last hour, day, week and month. This works fine now.
Please let me know if you are interested in the code.

However two problems are remaining.

The Vera show the error message "Can't Detect Device". Even if I reset CommFailure the error message is displayed again. No big problem but it would be nice to have the Vera happy face.

The second problem is worse. Every time it's raining the device gets tripped! So if we are not at home the alarm goes on. Not good.

I would be happy if i got some help with these problems.

Does any body else have experience the Popp Z-Rain device?
Does Mi Casa Verde have any plans to add support for the Popp Z-Rain device?

Best regards
  M?rten