Author Topic: 2.7 Release  (Read 457 times)

Offline CudaNet

  • Hero Member
  • *****
  • Posts: 1389
  • Karma: +41/-10
  • Chimichanga !
2.7 Release
« on: October 06, 2017, 11:48:41 am »
Many thanks to intveltr for putting out an update release so quickly. I can confirm the following:

1. Caption lines are no longer limited to a single line..
2. Philips Hue bulbs are working perfectly.

However, I am still having issues with the cameras (3 total). I sent a log this morning.. It's odd as I'm setting the toggle for direct LAN, saving... When I return to the config after a couple of minutes the option is disabled. Here's how I have my camera configured:

Camera IP address: 10.0.x.x
Image/MJPEG: /Streaming/channels/2/picture
Camera Username: xxxxxx
Password: xxxxxx
Use Request Streaming: (tried it on and off)
openLuup, AltUI, Zway and HomeWave, enough said...

Offline intveltr

  • Moderator
  • Hero Member
  • *****
  • Posts: 1679
  • Karma: +93/-5
Re: 2.7 Release
« Reply #1 on: October 07, 2017, 11:05:41 am »
Try with direct to lan and request streaming turned off.  That should have the cameras get their images the old way, through Vera
HomeWave is available in the App Store!  Turn your iPhone/iPad into an easy-to-use remote control for Vera.

Offline CudaNet

  • Hero Member
  • *****
  • Posts: 1389
  • Karma: +41/-10
  • Chimichanga !
Re: 2.7 Release
« Reply #2 on: October 07, 2017, 11:34:11 am »
Just tried again and nothing. Last night I grabbed another iPad and loaded HW to it and added 1 camera. Here's how I have it configured.

Control Properties:
Camera IP address: 10.0.x.31
Image/MJPEG path: /Streaming/channels/2/picture
Camera Username: xxxxxxx
Password: xxxxxx

Use Request Streaming: OFF
Connect directly to camera: ON

Vera Settings:
Camera refresh interval: 5s
Legacy URL for Cameras: OFF

I don't believe there are any other settings (unless I'm overlooking something). I verified within a browser that the IP/path, username and password are correct (shows an image from the camera). Outside of PCAP'ng the stream coming out of the iPad, not sure what else I can do (I can get more logs if you want).


Try with direct to lan and request streaming turned off.  That should have the cameras get their images the old way, through Vera
openLuup, AltUI, Zway and HomeWave, enough said...

Offline morgi23

  • Sr. Newbie
  • *
  • Posts: 27
  • Karma: +0/-0
Re: 2.7 Release
« Reply #3 on: October 07, 2017, 02:02:58 pm »
Thanks for the quick update.
My cams are back to work again (even without the direct lan...), text wrap been solved, dimming level been solved  ;D

Still having issues with the Today widget not showing all the devices...
Am I the only one here experiencing this?

Offline CudaNet

  • Hero Member
  • *****
  • Posts: 1389
  • Karma: +41/-10
  • Chimichanga !
Re: 2.7 Release
« Reply #4 on: October 07, 2017, 03:28:10 pm »
Can you please provide more details to how your cameras are setup. Are you communicating directly with a Vera, the camera's or perhaps a Blue Iris server? Also an overview of the config would be great, I'm just curious if its similar to what I posted above (albeit without direct LAN).

Thanks,
CN

Thanks for the quick update.
My cams are back to work again (even without the direct lan...), text wrap been solved, dimming level been solved  ;D

Still having issues with the Today widget not showing all the devices...
Am I the only one here experiencing this?
openLuup, AltUI, Zway and HomeWave, enough said...

Offline morgi23

  • Sr. Newbie
  • *
  • Posts: 27
  • Karma: +0/-0
Re: 2.7 Release
« Reply #5 on: October 07, 2017, 05:06:56 pm »
Hi,
I'm connecting to the camera directly and not through Blue Iris server.
For your request, here's my configurations:
:
Camera IP address: 192.0.x.100
Image/MJPEG path: image/jpeg.cgi
Camera Username: xxxxxxx
Password: xxxxxx

Use Request Streaming: ON
Connect directly to camera: OFF

Vera Settings:
Camera refresh interval: 5s
Legacy URL for Cameras: ON

Some strange things happe when I close the app the configuration sometimes changes and seems like it doesn't saved.
Sometimes when I open the app there are no picture through the cams and I need to change the settings again
« Last Edit: October 07, 2017, 05:36:26 pm by morgi23 »

Offline morgi23

  • Sr. Newbie
  • *
  • Posts: 27
  • Karma: +0/-0
Re: 2.7 Release
« Reply #6 on: October 07, 2017, 05:13:03 pm »
@intveltr
Another thing that I noticed, when saving configuration to DB, it doesn't saves the graphics, but only the settings. When saving locally to the iPhone memory, it do save the graphics. I usually set my iphone and then saves it to DB and share the settings with my wife iphone, but now it not possible.

Update- when enabling the "lock configuration" option while saving to DB, it do saves the graphics, but this way it disables the option to edit the screens at my wife's iPhone (some of them needs a bit of modification)
« Last Edit: October 07, 2017, 05:29:21 pm by morgi23 »

Offline CudaNet

  • Hero Member
  • *****
  • Posts: 1389
  • Karma: +41/-10
  • Chimichanga !
Re: 2.7 Release
« Reply #7 on: October 07, 2017, 07:56:14 pm »
Much appreciated, I may end up PCAP'ing the stream. I simply cannot see anything within the debug logs which concerns me. I see calls to the openLuup servers but nothing in regards to a URL, credentials etc...

Hi,
I'm connecting to the camera directly and not through Blue Iris server.
For your request, here's my configurations:
:
Camera IP address: 192.0.x.100
Image/MJPEG path: image/jpeg.cgi
Camera Username: xxxxxxx
Password: xxxxxx

Use Request Streaming: ON
Connect directly to camera: OFF

Vera Settings:
Camera refresh interval: 5s
Legacy URL for Cameras: ON

Some strange things happe when I close the app the configuration sometimes changes and seems like it doesn't saved.
Sometimes when I open the app there are no picture through the cams and I need to change the settings again
openLuup, AltUI, Zway and HomeWave, enough said...

Offline intveltr

  • Moderator
  • Hero Member
  • *****
  • Posts: 1679
  • Karma: +93/-5
Re: 2.7 Release
« Reply #8 on: October 09, 2017, 01:12:40 pm »
@intveltr
Another thing that I noticed, when saving configuration to DB, it doesn't saves the graphics, but only the settings. When saving locally to the iPhone memory, it do save the graphics. I usually set my iphone and then saves it to DB and share the settings with my wife iphone, but now it not possible.

Update- when enabling the "lock configuration" option while saving to DB, it do saves the graphics, but this way it disables the option to edit the screens at my wife's iPhone (some of them needs a bit of modification)

Anyone else noticed this? 
HomeWave is available in the App Store!  Turn your iPhone/iPad into an easy-to-use remote control for Vera.

Offline Broncswon

  • Sr. Newbie
  • *
  • Posts: 20
  • Karma: +0/-0
Re: 2.7 Release
« Reply #9 on: October 09, 2017, 03:28:37 pm »
Yes I am seeing the same issue with graphics.  In fact it won't even save the image locally, I choose image from dropbox or photo locally and it won't stick when choosing ok.

Offline morgi23

  • Sr. Newbie
  • *
  • Posts: 27
  • Karma: +0/-0
Re: 2.7 Release
« Reply #10 on: October 10, 2017, 05:18:18 am »
@intveltr
Another thing that I noticed, when saving configuration to DB, it doesn't saves the graphics, but only the settings. When saving locally to the iPhone memory, it do save the graphics. I usually set my iphone and then saves it to DB and share the settings with my wife iphone, but now it not possible.

Update- when enabling the "lock configuration" option while saving to DB, it do saves the graphics, but this way it disables the option to edit the screens at my wife's iPhone (some of them needs a bit of modification)

Anyone else noticed this?

Another update- yesterday I tried to save again the configuration to DB and it been saved with the graphics!
Don't know what's been changed but it works dor me now and graphics are back to my wife's iPhone 😄
Share some screen shots

Offline intveltr

  • Moderator
  • Hero Member
  • *****
  • Posts: 1679
  • Karma: +93/-5
Re: 2.7 Release
« Reply #11 on: October 13, 2017, 03:53:24 pm »
There is an issue with the images not being saved sometimes.  This is due to the new image cache which helps run the app on older devices with less memory (you'll notice if you have a lot of screens).

The next update will fix this.
HomeWave is available in the App Store!  Turn your iPhone/iPad into an easy-to-use remote control for Vera.

Offline morgi23

  • Sr. Newbie
  • *
  • Posts: 27
  • Karma: +0/-0
Re: 2.7 Release
« Reply #12 on: October 13, 2017, 04:02:44 pm »
Thanks for the update  :D
Did you manage to fix the Today widget as well?

Offline intveltr

  • Moderator
  • Hero Member
  • *****
  • Posts: 1679
  • Karma: +93/-5
Re: 2.7 Release
« Reply #13 on: October 16, 2017, 12:57:07 pm »
Still looking into the size of the Today widget.  As for the colors, they haven't changed.  The background was always transparent but the new OS has a lighter background. making things hard to read.  You can change the widget colors in the today widget menu.
HomeWave is available in the App Store!  Turn your iPhone/iPad into an easy-to-use remote control for Vera.

Offline morgi23

  • Sr. Newbie
  • *
  • Posts: 27
  • Karma: +0/-0
Re: 2.7 Release
« Reply #14 on: October 16, 2017, 03:57:31 pm »
Hi,
Thanks for the update.
I'm not yet updated to iOS 11 (still using the 10.3.3 in my old 5s device) but I pretty sure that the today's widget background for Homewave was "dark grey" and not "transparent white" before the 2.6 and 2.7 updates.
I think I found an answer for this over here (don't know if it ok tolink to another website...):
https://www.reddit.com/r/iOSProgramming/comments/57vcbb/how_to_use_dark_background_color_for_today_widget/