We have moved at community.getvera.com

Author Topic: [_CODE_] ADD - Alerter for Drowsy Devices V2.6  (Read 61427 times)

Offline mcvflorin

  • Administrator
  • Hero Member
  • *****
  • Posts: 1755
  • Karma: +11/-3
Re: Alerter for Drowsy Devices (ADD)
« Reply #90 on: March 28, 2011, 08:14:50 am »
Nice pictures, Ap15e.

Offline myhomeserver

  • Hero Member
  • *****
  • Posts: 874
  • Karma: +3/-5
  • http://www.MyZwave.net
Re: Alerter for Drowsy Devices (ADD)
« Reply #91 on: April 10, 2011, 07:54:42 am »
On ADD, Ive been running it for a few weeks with a new install on Vera2 1.1.1234

I'm wondering on the data collection with polling, and the chart of devices, nodes, polling, and fail %

Is this a collection of Historical data?  I was having an AEON HEM with 85% loss, so I moved it next to Vera and it's been there 2 days, but I still see a very high failure rate.  This seems that the data here is historical, how can I wipe out and start clean, so I can see a fresh report after 24 hours, this should give me a better indication on if the devices are working OK

Thanks!
MyZWave.net - See Our Z-Wave product Reviews
(formerly MyHomeServer)

Offline JOD

  • Hero Member
  • *****
  • Posts: 1973
  • Karma: +4/-0
Re: Alerter for Drowsy Devices (ADD)
« Reply #92 on: April 10, 2011, 10:54:28 am »
@Ap15e,

Thanks for looking into it, I'm surprised you were able to get neato and circo to work, in both of them you can still see my secondary controller node 91 and my ThinkStick node 7 circling like satellites.

I'm now up to 105 static nodes so fdp stopped working too, but the purpose of the App was for the battery reports which I am still getting every morning.
Thanks again,

JOD.
« Last Edit: April 10, 2011, 11:01:55 am by JOD »
I'm sorry, my responses are limited. You must ask the right questions.

Offline Ap15e

  • Beta Testers
  • Hero Member
  • *****
  • Posts: 1998
  • Karma: +12/-0
Re: Alerter for Drowsy Devices (ADD)
« Reply #93 on: April 10, 2011, 11:30:55 am »
@myhomeserver

Quote
This seems that the data here is historical, how can I wipe out and start clean, so I can see a fresh report after 24 hours, this should give me a better indication on if the devices are working OK

The data is stored in your configuration file. Go to the 'Advanced tab', set the variables PollOk, PollNoReply, PollTxFail to 0, SAVE your changes.

Yes, it would be nice (and easy, just a few lines of Lua code ...) to be able to reset the counters of all devices simultaneously.
Any volunteer?  :)

Offline huogas

  • Sr. Member
  • ****
  • Posts: 301
  • Karma: +0/-0
Re: Alerter for Drowsy Devices (ADD)
« Reply #94 on: May 07, 2011, 01:33:47 pm »
@Ap15e
What is supposed to be the end result ? An email at every interval the timer was setup ?

I'm asking because I didn't see any result. Is there a simple way to see what is going on ?

Thanks
Vera2 UI4(1.1.1245/3.2), Kwikset x1, HM-DW001 x1, ZRP100 x1, HA-04WD x1, ZDP100 x6, HSM100 x2, VRI06-1LX x8, ZW5301 x1, HM-FS001 x2, ZRW103W x1, GE 45606 x2, HA05C x1, TED5000 x1

Offline Ap15e

  • Beta Testers
  • Hero Member
  • *****
  • Posts: 1998
  • Karma: +12/-0
Re: Alerter for Drowsy Devices (ADD)
« Reply #95 on: May 07, 2011, 03:46:13 pm »
Quote
What is supposed to be the end result ? An email at every interval the timer was setup ?

Yes (but only if heartbeat is 1 ...).

Quote
I'm asking because I didn't see any result. Is there a simple way to see what is going on ?

Chances are that you've got your SMTP settings wrong.

Offline huogas

  • Sr. Member
  • ****
  • Posts: 301
  • Karma: +0/-0
Re: Alerter for Drowsy Devices (ADD)
« Reply #96 on: May 07, 2011, 03:56:11 pm »
Quote
What is supposed to be the end result ? An email at every interval the timer was setup ?

Yes (but only if heartbeat is 1 ...).
Yes it is.
Quote
I'm asking because I didn't see any result. Is there a simple way to see what is going on ?

Chances are that you've got your SMTP settings wrong.
Parameters seems right. If they are not, that would explained why I was unable to send email for the last months...Just kidding... ;)

What can I do to track what is wrong with my installation ?
Vera2 UI4(1.1.1245/3.2), Kwikset x1, HM-DW001 x1, ZRP100 x1, HA-04WD x1, ZDP100 x6, HSM100 x2, VRI06-1LX x8, ZW5301 x1, HM-FS001 x2, ZRW103W x1, GE 45606 x2, HA05C x1, TED5000 x1

Offline Ap15e

  • Beta Testers
  • Hero Member
  • *****
  • Posts: 1998
  • Karma: +12/-0
Re: Alerter for Drowsy Devices (ADD)
« Reply #97 on: May 07, 2011, 04:55:00 pm »
Run your ADD scene manually.

Run the ADD code from the 'Test Luup code (Lua)' window.

Check LuaUPnP.log for errors.

Offline huogas

  • Sr. Member
  • ****
  • Posts: 301
  • Karma: +0/-0
Re: Alerter for Drowsy Devices (ADD)
« Reply #98 on: May 07, 2011, 06:20:21 pm »
Run your ADD scene manually.
Just no error, but no email...
Run the ADD code from the 'Test Luup code (Lua)' window.
CodE failed
Check LuaUPnP.log for errors.
Where is that file ?
Vera2 UI4(1.1.1245/3.2), Kwikset x1, HM-DW001 x1, ZRP100 x1, HA-04WD x1, ZDP100 x6, HSM100 x2, VRI06-1LX x8, ZW5301 x1, HM-FS001 x2, ZRW103W x1, GE 45606 x2, HA05C x1, TED5000 x1

Offline Ap15e

  • Beta Testers
  • Hero Member
  • *****
  • Posts: 1998
  • Karma: +12/-0

Offline Henk

  • Hero Member
  • *****
  • Posts: 820
  • Karma: +3/-0
Re: Alerter for Drowsy Devices (ADD)
« Reply #100 on: May 08, 2011, 06:27:09 am »
Last night recapping the day i realized i made a typo in the LUUP code as far as my SMTP server was concerned.
Opening the scene and going to the code page this morning i was surprised. I found the original code as provided by Ap15e.

All my changes (of which im SURE i saved several times) were gone and i was back at square 1.
Is this something other users have experienced too?

Redid the whole thing this morning and will wait and see what happens!

Regards,

Henk
| Vera2 @ UI4 1.1.1350 / 3.20 | Vera Lite @ UI5 | Vera 3 @ UI5 | 2x Merten  504519 | 1x Duewi  064374 | 1x Everspring SM103 doorbell mod |1 Y-cam IP cam | various LUUP plugins |

Offline huogas

  • Sr. Member
  • ****
  • Posts: 301
  • Karma: +0/-0
Re: Alerter for Drowsy Devices (ADD)
« Reply #101 on: May 08, 2011, 06:45:03 am »

All my changes (of which im SURE i saved several times) were gone and i was back at square 1.
Is this something other users have experienced too?

I have to ask: how did you "save" ?
Vera2 UI4(1.1.1245/3.2), Kwikset x1, HM-DW001 x1, ZRP100 x1, HA-04WD x1, ZDP100 x6, HSM100 x2, VRI06-1LX x8, ZW5301 x1, HM-FS001 x2, ZRW103W x1, GE 45606 x2, HA05C x1, TED5000 x1

Offline Henk

  • Hero Member
  • *****
  • Posts: 820
  • Karma: +3/-0
Re: Alerter for Drowsy Devices (ADD)
« Reply #102 on: May 08, 2011, 06:48:48 am »
@huogas

ehm.... hitting the save code button at the bottom of the code page???
Then after that closing the scene and saving / reloading the LUA engine....

Was that wrong?

Yesterday i checked back several times and the changes were stil present....
| Vera2 @ UI4 1.1.1350 / 3.20 | Vera Lite @ UI5 | Vera 3 @ UI5 | 2x Merten  504519 | 1x Duewi  064374 | 1x Everspring SM103 doorbell mod |1 Y-cam IP cam | various LUUP plugins |

Offline huogas

  • Sr. Member
  • ****
  • Posts: 301
  • Karma: +0/-0
Re: Alerter for Drowsy Devices (ADD)
« Reply #103 on: May 08, 2011, 07:00:53 am »
...
I just had to remove "user = SMTP_AUTH_USER" and "password = SMTP_AUTH_PW" lines from smtp.send() call, as my local mail server doesn't require authentication for local senders... :)
Same thing here.

Works now. Thanks.
Vera2 UI4(1.1.1245/3.2), Kwikset x1, HM-DW001 x1, ZRP100 x1, HA-04WD x1, ZDP100 x6, HSM100 x2, VRI06-1LX x8, ZW5301 x1, HM-FS001 x2, ZRW103W x1, GE 45606 x2, HA05C x1, TED5000 x1

Offline Henk

  • Hero Member
  • *****
  • Posts: 820
  • Karma: +3/-0
Re: Alerter for Drowsy Devices (ADD)
« Reply #104 on: May 08, 2011, 09:12:35 am »
Same here, initially i had the auth lines empty (as in "") that didnt work.
Now i left the code intact but just commented the lines out with -- in front of the lines.

Email notification works now.

Only the urls included in the link give me an error 400 on the google api's like this;

400. That’s an error.
Your client has issued a malformed or illegal request.
The parameter 'chl=digraph' could not be parsed. Please check your syntax.
That’s all we know.

Any ideas? (browser= Chrome)

Henk
| Vera2 @ UI4 1.1.1350 / 3.20 | Vera Lite @ UI5 | Vera 3 @ UI5 | 2x Merten  504519 | 1x Duewi  064374 | 1x Everspring SM103 doorbell mod |1 Y-cam IP cam | various LUUP plugins |