Author Topic: Jandy Pool Control  (Read 5878 times)

Offline Sammy2

  • Hero Member
  • *****
  • Posts: 869
  • Karma: +5/-5
Re: Jandy Pool Control
« Reply #45 on: June 04, 2018, 01:18:37 pm »
Sammy,

I upgraded my Vera3 and Plus to the latest fw.  Not without having to reset to factory settings.  What a PITA and a crappy way to burn a Sunday.  Anyhow the I am not experiencing your issue on the Pentair or the mock Jandy system.  Could you please capture a log from the time it does a poll to Autelis and post it here?

I certainly can do that. What's that url again to get the log information? BTW, currently Pool Control is connected but it seems to go in and out of connection.

BTW, at least you have the skills to do what's necessary; I was on a two hour support phone call with Vera Support in a remote session on my laptop to get my VeraPlus responsive enough that I could "Enable Support" so they could restore all my devices and scenes. In addition to Pool Control I have a few devices that are not found.. I had to reset one of my MIMO2 + relays to control my pump speeds again via Vera.

About to ditch it and go with HomeSEER to tell the truth. It looks like HomeSEER has a Jandy Plugin but of course they charge for each one so it can get spendy quick so a better upgrade path is really what is needed from Vera above all.

Offline Sammy2

  • Hero Member
  • *****
  • Posts: 869
  • Karma: +5/-5
Re: Jandy Pool Control
« Reply #46 on: June 04, 2018, 01:20:01 pm »
Found it, I think..

<Vera Local IP>/cgi-bin/cmh/log.sh?Device=LuaUPnP

Offline rstrouse

  • Hero Member
  • *****
  • Posts: 834
  • Karma: +30/-9
Re: Jandy Pool Control
« Reply #47 on: June 04, 2018, 01:27:11 pm »
Yeah the shenanigans are getting a bit much.  I found that can't detect devices are a recipe for all kinds of downstream effects as the controller tries to catch up with each failure.  It takes longer to fail than to succeed.
1xVera3 1.7.619, 4xLinear WT00Z, 3xLinear WS15Z, 1xLeviton VRCZ4, 10xCooper RF9540, 1xLeviton VRFI10, 1xLeviton VP00R, 2xLinear GD00Z-4, 1xGE/Jasco 45612, 1xGE/Jasco 45610,  4xGE/Jasco 45605, 2xYale YRD220-ZW-619, 1xCaddx NX584, Autelis Intellitouch Pool Control, OpenSprinkler

Offline Sammy2

  • Hero Member
  • *****
  • Posts: 869
  • Karma: +5/-5
Re: Jandy Pool Control
« Reply #48 on: June 04, 2018, 04:27:51 pm »
Yeah the shenanigans are getting a bit much.  I found that can't detect devices are a recipe for all kinds of downstream effects as the controller tries to catch up with each failure.  It takes longer to fail than to succeed.

Not quite ready to spring for the HomeSEER.. I'm not sure but it looks like it is a software solution with a USB Z-Wave radio on a PC? I have a barely used ever NUC that I could re-purpose to run it but then I'm setting everything up again. For the most part my VeraPlus is working again but here's a log to look at. Hope you can find what you are looking for in it.


Offline Sammy2

  • Hero Member
  • *****
  • Posts: 869
  • Karma: +5/-5
Re: Jandy Pool Control
« Reply #49 on: June 06, 2018, 10:14:30 am »
I have a inkling that this may be a polling issue but am not sure how to ferret that out. Any advice?

Offline Sammy2

  • Hero Member
  • *****
  • Posts: 869
  • Karma: +5/-5
Re: Jandy Pool Control
« Reply #50 on: June 30, 2018, 01:55:36 pm »
Yeah the shenanigans are getting a bit much.  I found that can't detect devices are a recipe for all kinds of downstream effects as the controller tries to catch up with each failure.  It takes longer to fail than to succeed.

I have new issues where Pool Control say is is connected but nothing is being controlled and I cannot edit and/or save settings.

Screen grabs attached.

Log in the next post.


Offline Sammy2

  • Hero Member
  • *****
  • Posts: 869
  • Karma: +5/-5
Re: Jandy Pool Control
« Reply #51 on: June 30, 2018, 02:10:53 pm »
Here's the log for your reading enjoyment. This is two html log files taken a few minutes apart and zipped up since vera's forum doesn't allow large (as in log) files or zip format which is pretty much BS.

BTW, I still need to clear out some devices but Pool Control has been working fine actually so I haven't got to it yet.

https://drive.google.com/file/d/1M2YydZQc7ErdpBNCyq1puwuN45Qnu2wI/view?usp=sharing

https://drive.google.com/file/d/1z_j3ebtmaTThoxkPgi2wGDZe_xDJcZNS/view?usp=sharing

(PS, further investigating going to OpenLUA or better yet, HomeSEER if pool control works with the former and there's an Autelis plugin for the latter)
« Last Edit: June 30, 2018, 02:17:28 pm by Sammy2 »

Offline rstrouse

  • Hero Member
  • *****
  • Posts: 834
  • Karma: +30/-9
Re: Jandy Pool Control
« Reply #52 on: July 23, 2018, 05:13:01 pm »
Released v1.1 on the first message in this topic due to fw changes made in 7.0.27.
1xVera3 1.7.619, 4xLinear WT00Z, 3xLinear WS15Z, 1xLeviton VRCZ4, 10xCooper RF9540, 1xLeviton VRFI10, 1xLeviton VP00R, 2xLinear GD00Z-4, 1xGE/Jasco 45612, 1xGE/Jasco 45610,  4xGE/Jasco 45605, 2xYale YRD220-ZW-619, 1xCaddx NX584, Autelis Intellitouch Pool Control, OpenSprinkler

Offline Sammy2

  • Hero Member
  • *****
  • Posts: 869
  • Karma: +5/-5
Re: Jandy Pool Control
« Reply #53 on: July 23, 2018, 05:15:55 pm »
Released v1.1 on the first message in this topic due to fw changes made in 7.0.27.

Do you have a change log?

Mine is actually working right now or I think it is but I have not tried the shear descents, heater or spa since the latest f/w came out but the lights work so I'm perplexed.

Thanks!

Offline Sammy2

  • Hero Member
  • *****
  • Posts: 869
  • Karma: +5/-5
Re: Jandy Pool Control
« Reply #54 on: July 23, 2018, 05:19:46 pm »
BTW, only two files are current. Should I just drop those two and reload the engine / refresh the browser or should I do them all?

Thanks!

Offline rstrouse

  • Hero Member
  • *****
  • Posts: 834
  • Karma: +30/-9
Re: Jandy Pool Control
« Reply #55 on: July 23, 2018, 05:26:20 pm »
The only changes were in the L_ and the J_ files.  You can simply drop the 2.  This gets around the library changes made in fw 7.0.27
1xVera3 1.7.619, 4xLinear WT00Z, 3xLinear WS15Z, 1xLeviton VRCZ4, 10xCooper RF9540, 1xLeviton VRFI10, 1xLeviton VP00R, 2xLinear GD00Z-4, 1xGE/Jasco 45612, 1xGE/Jasco 45610,  4xGE/Jasco 45605, 2xYale YRD220-ZW-619, 1xCaddx NX584, Autelis Intellitouch Pool Control, OpenSprinkler

Offline Sammy2

  • Hero Member
  • *****
  • Posts: 869
  • Karma: +5/-5
Re: Jandy Pool Control
« Reply #56 on: July 23, 2018, 06:26:25 pm »
The only changes were in the L_ and the J_ files.  You can simply drop the 2.  This gets around the library changes made in fw 7.0.27

Thanks. I did this and will report back any issues. In this process I notice I have a few Pentair files in my system. I don't think I need them so if I don't, how do I remove them?

Thanks.

Offline rstrouse

  • Hero Member
  • *****
  • Posts: 834
  • Karma: +30/-9
Re: Jandy Pool Control
« Reply #57 on: July 23, 2018, 06:44:59 pm »
Did you install the Pentair plugin?  I use WinSCP to remove files.


1xVera3 1.7.619, 4xLinear WT00Z, 3xLinear WS15Z, 1xLeviton VRCZ4, 10xCooper RF9540, 1xLeviton VRFI10, 1xLeviton VP00R, 2xLinear GD00Z-4, 1xGE/Jasco 45612, 1xGE/Jasco 45610,  4xGE/Jasco 45605, 2xYale YRD220-ZW-619, 1xCaddx NX584, Autelis Intellitouch Pool Control, OpenSprinkler

Offline Sammy2

  • Hero Member
  • *****
  • Posts: 869
  • Karma: +5/-5
Re: Jandy Pool Control
« Reply #58 on: July 23, 2018, 07:26:04 pm »
Did you install the Pentair plugin?  I use WinSCP to remove files.

I think it got in there during early beta development of the Jandy Plugin.

I'll WinSCP or use PuTTy but WinSCP is easier. What directory are these found in?

Thanks.

Offline Sammy2

  • Hero Member
  • *****
  • Posts: 869
  • Karma: +5/-5
Re: Jandy Pool Control
« Reply #59 on: July 25, 2018, 11:34:11 pm »
Autelis is not talking to Vera through Pool Control.

I had to manually turn on my lights with the Autelis web GUI and Vera doesn't see it.