Author Topic: Upgrading firmware to 1.7.987 on Vera3  (Read 373 times)

Offline leonszarski

  • Newbie
  • *
  • Posts: 2
  • Karma: +1/-0
Upgrading firmware to 1.7.987 on Vera3
« on: October 14, 2017, 08:43:01 pm »
I upgraded the firmware to 1.7.987on my Vera3 but because I didn't have enough memory I had to reset to factory settings before the upgrade.
It all went well until I restored my backup - I had no devices showing.
I rebooted and restored the backup a number of times but to no avail.
I reset to factory settings again and restored the backup and wow, the devices came back.
BUT I couldn't communicate with any sensors. After trying for a while I gave up in disgust and went for a walk.
Lo and behold on returning all was working again.
So the lesson is to wait - the system takes a long time to re-stablish connections and there's no message that it's doing anything.

Offline ton1968

  • Newbie
  • *
  • Posts: 13
  • Karma: +0/-0
Re: Upgrading firmware to 1.7.987 on Vera3
« Reply #1 on: October 22, 2017, 12:22:17 pm »
Today I experienced almost the same with his upgrade. First , no devices showing at all. Then after repeatedly restoring backups and performing reboots, eventually all devices were showing, including PLEG instances (although empty, i.e. without code). Some restore and reboots later the code of the PLEG instances reappeared and the communication of the devices with serial ports began working again. Only the communication with all Z-wave devices was still failing (indicated by a 'Command failed' message briefly showing when trying to switch on a light from the UI). When I tried to do a Z-wave network heal from ALtUI (via More->Table controllers. I couldn't find the network heal command in the native UI anymore) I got a response indicating that vera's Z-wave radio was off, even though vera's Z-wave LED was solid green. I then tried to turn the radio on by setting vera into inclusion mode and let it time-out. After that I was able to control my Z-wave devices again. So I guess maybe in your case vera turned on the radio by itself after a while?
I'm now still getting errors indicating that vera has trouble polling Z-wave devices. Control of these devices works well however and upon issuing commands to the devices the error messages disappear.  But it looks like the frequency of these error messages is declining over the past couple of hours, so maybe the vera is learning. I'll wait and see how it evolves.

Offline MrRocco

  • Sr. Newbie
  • *
  • Posts: 35
  • Karma: +0/-0
Re: Upgrading firmware to 1.7.987 on Vera3
« Reply #2 on: October 27, 2017, 10:03:11 pm »
Glad to find this thread. I am experiencing the same thing after my upgrade tonight. Only 1 restore but several times of reboot/reload/update in the beginning. I did do some battery based inclusion / exclusion because some devices had changed. Big motivator for the fw update was a new Schlage lock that wouldn't include correctly. I'll go put it in inclusion mode while on AC power and see if that gets it chatting to the z-wave network. I'm in no rush as long as it eventually picks up where it left off. BTW this was a VeraLite for the keyword searches.