Author Topic: EUROtronic SPIRIT Z-Wave Plus working with Vera (Plus)?  (Read 617 times)

Offline Loeschnix

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
EUROtronic SPIRIT Z-Wave Plus working with Vera (Plus)?
« on: October 16, 2017, 07:03:55 am »
Hi,
has anyone experience with the new EUROtronic SPIRIT Z-Wave Plus radiator thermostat yet?

https://www.eurotronic.org/en/products/spirit-z-wave-plus.html

Is it working with Vera Plus?

Thanks Dirk

Offline kwieto

  • Sr. Member
  • ****
  • Posts: 347
  • Karma: +15/-10
Re: EUROtronic SPIRIT Z-Wave Plus working with Vera (Plus)?
« Reply #1 on: October 18, 2017, 04:42:45 am »

Offline nd

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
Re: EUROtronic SPIRIT Z-Wave Plus working with Vera (Plus)?
« Reply #2 on: November 30, 2017, 08:29:33 am »
I have the EUROtronic SPIRIT TRV working with Vera Lite firmware 1.7.987.

Setting the temperature set point works within a few second.

There is a small problem that you get 'Device NOT responding' followed by 'Device responding again' messages every few hours, even though the Vera Lite and TRV within 20cm of each other.


Offline Vinx

  • Sr. Newbie
  • *
  • Posts: 30
  • Karma: +0/-0
Re: EUROtronic SPIRIT Z-Wave Plus working with Vera (Plus)?
« Reply #3 on: December 09, 2017, 03:38:51 pm »
I've just installed two SPIRIT's as replacements for two of my Danfoss Living Connect radiator thermostat. Unfortunately Vera doesn't have the device in the list yet, so I went for generic device. It's recognized as thermostat, while my Danfoss devices were recognized as "heater". Not sure if that's going to be a problem, but it does give some extra buttons (heat, auto, cool, off) for which I have found no use (yet). If anyone has advise on this, I'm all ears.

The SPIRIT so far has major advantages over the Danfoss LC:
- Immediate response due to FLiRS technology (will have to see what that does with the battery)
- Z-wave Plus
- Shows actual temperature (not yet cross checked it, but at least it seems somewhat realistic, which is not bad considering it is next to the radiator)
- Much better user feedback, for example during installation (Danfoss actually totally sucked on that)
- Range seems better. Danfoss in our bedroom always had problems with connection, SPIRIT is flawless so far.
- Bigger screen, readable from above! (When trying to read the Danfoss I always break my back)
- Much better and responsive buttons (the Danfoss has something weird that the first 5 seconds it doesn't respond, all units have that so its not a defect)
- The SPIRIT is actually meant to be used as a Z-wave devices and documented as such

Things to consider:
- The SPIRIT is somewhat bigger than the Danfoss. It's not round even though it seems like that on pictures. Not a problem for me though.
- The supplied adapters are a joke. Cheap pieces of plastic that you have to find out yourself how to fix. I suggest buying real adapters. I re-used the adapters I already had for my Danfoss.
- If you change the temperature on the device itself, reporting back the setpoint to the Vera seems to take a long time, or it might never report it back (haven't waited long enough yet). This is only a problem is you want to see what the set point is through the interface. If anyone has a fix for this, I'd really like to hear.

Writing all this down, I just might find myself buying more replacements for the other Danfoss LC's pretty soon ...
« Last Edit: December 10, 2017, 06:32:07 am by Vinx »

Offline kwieto

  • Sr. Member
  • ****
  • Posts: 347
  • Karma: +15/-10
Re: EUROtronic SPIRIT Z-Wave Plus working with Vera (Plus)?
« Reply #4 on: December 11, 2017, 04:00:17 am »
It's recognized as thermostat, while my Danfoss devices were recognized as "heater". Not sure if that's going to be a problem, but it does give some extra buttons (heat, auto, cool, off) for which I have found no use (yet). If anyone has advise on this, I'm all ears.

I suppose this is due to the feature of reporting temperature back.
I have Danfoss, Comet (predecessor of Spirit) and a Devolo, which is mainly a Danfoss with added feature of reporting temp. to the controller.
Devolo is recognized same way as Comet (thermostat) while Danfoss appears as "heater" regardless that the only difference is (as far as I know) some tweak in firmware.
I've put it on "heat" by default.

- Shows actual temperature (not yet cross checked it, but at least it seems somewhat realistic, which is not bad considering it is next to the radiator)

As I said, I don't have Spirit but for comet the difference between measures reported by it and for example Netatmo sensor located in center of the room was about 0,5 C, for me acceptable.
I've compared also readings from Devolo, and it keeps the match. Knowing that Devolo is a clone of Danfoss, you should expect similar accuracy from Danfoss, even though it doesn't report readings to the controller.

Offline EricwithVera

  • Sr. Newbie
  • *
  • Posts: 28
  • Karma: +0/-0
Re: EUROtronic SPIRIT Z-Wave Plus working with Vera (Plus)?
« Reply #5 on: January 29, 2018, 11:07:56 am »
Good afternoon,

I have two Spirits.

Initially they worked very well. But they seem to go on stand by or something for some reason. After a while (have not checked after how long) they do not report the current temperature any more, and show up in the dashboard as "Can't Detect Device". They do not seem to respond very well to temp changes in the room any more (getting too cold / too hot in the room). After increasing / decreasing the temp (either manually, or by app) they are up and running again for some time.

Am I doing something wrong?

Offline EricwithVera

  • Sr. Newbie
  • *
  • Posts: 28
  • Karma: +0/-0
Re: EUROtronic SPIRIT Z-Wave Plus working with Vera (Plus)?
« Reply #6 on: February 12, 2018, 11:16:19 am »
Good afternoon,

I have two Spirits.

Initially they worked very well. But they seem to go on stand by or something for some reason. After a while (have not checked after how long) they do not report the current temperature any more, and show up in the dashboard as "Can't Detect Device". They do not seem to respond very well to temp changes in the room any more (getting too cold / too hot in the room). After increasing / decreasing the temp (either manually, or by app) they are up and running again for some time.

Am I doing something wrong?

Anybody?