Author Topic: Version 2.0 for Vera Concierge  (Read 2044 times)

Offline lammy

  • Newbie
  • *
  • Posts: 16
  • Karma: +0/-0
Re: Server on Raspberry Pi 3.0
« Reply #15 on: March 02, 2018, 06:09:20 am »
Help,

It doesn't work for me....  I'm certain I'm doing something wrong, but having trouble figuring out debug strategy.  I previously had it running on a Windows laptop....  I deleted the jar file from that system and am now trying to get it running on a Raspberry Pi 3.0.  I'm fairly familiar with linux in general, but am fairly new to the Pi world. 

I created a directory /home/pi/Vera and copied the jar file in there.  I ran /usr/bin/java -jar ConciergeServer.jar per the instructions, and it seemingly worked fine.  I installed the certificate so that the browser warning goes away (although https: is still crossed out and in red).  I put in my userid and password, and picked Ui6+ Case sensitive, and pressed Update and Restart, and none of my Vera's show up in the list (I have three, one master and two in outbuildings).

Here's a partial log:

23-Jan-2018 09:52:05 V:CSWebContainer:Config Cmd:/Query?Discovered=
23-Jan-2018 09:52:07 V:CSWebContainer:Cmd:/Log?
23-Jan-2018 09:52:12 V:CSWebContainer:Cmd:/Log?
23-Jan-2018 09:52:17 V:CSWebContainer:Cmd:/Log?

The 'lack' of anything after Discovered leads me to believe its not seeing the Vera units...

In another forum, someone suggested adding elinks, so I did that (apt-get install elinks) but no effect..  and I ran this also:

xdg-open https://localhost:8989, but no effect either (well, ok, it brought up a browser)

My first thought is it might be a firewall issue...  I'm a little rusty on linux firewalls, I'll start looking there first.

Any suggestions?

Kirby

also having this issue, however when i press update my log says:

Code: [Select]
02-Mar-2018 11:04:46 I:VeraConnect.VeraConnection:ClearCredentials
02-Mar-2018 11:04:47 V:CSWebContainer:Cmd:/Log?
02-Mar-2018 11:04:47 I:VeraConnect.VeraConnection:AddCredential:UI6 ? (MY USERNAME)
02-Mar-2018 11:04:47 E:CSWebContainer:handle:/Update?UpdateData=%5B%7B%22Name%22%3A+%22(USERNAME)%22%2C+%22Password%22%3A+%22(PASSWORD)%22%2C+%22Type%22%3A+%22UI6%2BCaseSensitiveUserName%22%7D%2C+%5D&Password=
Exception:java.lang.NullPointerException
java.lang.NullPointerException
at com.rtsservices.conciergeserver.SmartHome.StopPoll(SmartHome.java:137)
at com.rtsservices.conciergeserver.VeraService.Stop(VeraService.java:92)
at com.rtsservices.conciergeserver.Configuration.ValidCmd(Configuration.java:103)
at com.rtsservices.conciergeserver.CSWebContainer.handle(CSWebContainer.java:40)
at org.simpleframework.http.socket.service.RouterContainer.handle(RouterContainer.java:106)
at org.simpleframework.http.core.RequestDispatcher.dispatch(RequestDispatcher.java:121)
at org.simpleframework.http.core.RequestDispatcher.run(RequestDispatcher.java:103)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
at java.lang.Thread.run(Thread.java:745)

has anybody found the solution to this problem?

Offline RichardTSchaefer

  • Moderator
  • Master Member
  • *****
  • Posts: 10061
  • Karma: +759/-141
Re: Version 2.0 for Vera Concierge
« Reply #16 on: March 07, 2018, 11:43:49 am »
Have you checked the IP address of your Vera Concierge Server ?
By default you can't get the address ..
Need to make sure you have a static IP or static DHCP reserveration ... and then edit the /etc/hosts files  (as indicated in the debugging thread)