Author Topic: Dashboard wont load after new controller setup  (Read 106 times)

Offline automizer

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
Dashboard wont load after new controller setup
« on: November 07, 2017, 02:14:27 pm »
I have just setup my VeraPlus for the first time.
I got through the new controller setup just fine but when I clicked on go to dashboard all I get is the Vera logo on the left and a loading icon. It has been "loading" for over an hour.

Can I unplug the controller and try again? or is there something better I can try?

Offline John M.

  • Administrator
  • Hero Member
  • *****
  • Posts: 561
  • Karma: +44/-4
    • getvera.com
Re: Dashboard wont load after new controller setup
« Reply #1 on: November 08, 2017, 07:09:48 am »
Hello automizer,


I've just checked your Vera unit and it seems to be connected and communicating with Vera servers but seems to be running a Vera old firmware version.

You can either navigate and open the interface by it's local IP (need to be in the same location), and try to manually update the firmware.

This should be an easy fix for our Customer Care team as well if you reach them (contact details in signature).


P.S. Leave the unit connected. No need to power cycle at this moment.
John.M. ▾ Senior Customer Care Advocate
Vera Control, Ltd. ▾ Smarter Home Control  ▾ support@getvera.com ▾www.getvera.com ▾ +1 (866) 966-2272

HOURS OF OPERATION (Pacific Time Zone, UTC -8 )
Monday - Friday   12:00 am ? 06:00 pm
Saturday - Sunday   04:00 am ? 06:00 pm

Offline automizer

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
Re: Dashboard wont load after new controller setup
« Reply #2 on: November 08, 2017, 12:19:36 pm »
Hello John

Thank you for looking into my specific unit.
I will contact the Customer Care team as I am trying to connect to it directly with the local IP. I am concerned it may be how I have my home network setup.
I will leave the unit connected.

Thanks again for your help.